Issue with multiple SDI card detection

If you have questions about Linux, then go here.
  • Author
  • Message
Offline

dstaples

  • Posts: 4
  • Joined: Thu Mar 28, 2013 9:38 am

Issue with multiple SDI card detection

PostThu Mar 28, 2013 9:53 am

Hi,

I've got a HP desktop machine fitted with two DeckLink Pro SDI cards. For compatibility reasons I'm using an old-ish SDK (7.9.4rc17). I'm running Ubuntu 10.04 LTS.

Our custom capture application is known to work reliably with one card, and I'm trying to extend it to support multiple cards. The plan is to run an instance of the application for each card, and specify which card each instance should use. But I cannot detect both cards...

The driver is installed. lspci lists both cards. But the BlackMagicControlPanel and BlackmagicFirmwareUpdater only lists one of the two cards. I've tried putting the cards in different PCI slots - this made no apparent difference. I've tried the cards singly, and both work.

Can anyone make any suggestions as to what might be the problem ?

Thanks in advance,
Darren
Offline

dstaples

  • Posts: 4
  • Joined: Thu Mar 28, 2013 9:38 am

Re: Issue with multiple SDI card detection

PostWed Apr 10, 2013 11:18 am

Any help on this, please ?
Offline

Christine Peterson

  • Posts: 663
  • Joined: Mon Sep 24, 2012 9:00 pm
  • Location: Boston, MA

Re: Issue with multiple SDI card detection

PostThu Apr 18, 2013 4:42 pm

The last known Linux driver to support this board was 7.6, published on April 2010. All drivers after that only support PCIExpress cards.

Supporting multiple cards will be dependent on the application and the system resources. If 7.6 does not work, then I'd recommend contacting Support. Since it is out of the 3 year warranty and the card has not been sold in 4 or 5 years, there is chance of limited support...

The phone number for your local support office can be found here: http://www.blackmagicdesign.com/company/
Christine Peterson

(Previously Community Relations Manager for Blackmagic Design)
Offline

dstaples

  • Posts: 4
  • Joined: Thu Mar 28, 2013 9:38 am

Re: Issue with multiple SDI card detection

PostFri Apr 19, 2013 8:40 am

Thanks for replying Christine.

The card I'm using is a PCI-Express card, and the API reports the type as 'DeckLink SDI'.
How do I identify the version of the driver being used ?

Thanks again,
Darren

Return to Linux

Who is online

Users browsing this forum: Kevin Coyle and 3 guests