Controlling HyperDeck Studio Mini RS-422 StatusByte1 Issue

Ask software engineering and SDK questions for developers working on Mac OS X, Windows or Linux.
  • Author
  • Message
Offline
User avatar

Tanis64

  • Posts: 1
  • Joined: Fri Dec 14, 2018 6:40 am
  • Location: Mainz Germany
  • Real Name: Christopher Schmidt

Controlling HyperDeck Studio Mini RS-422 StatusByte1 Issue

PostFri Dec 14, 2018 7:08 am

Hi Everyone

I implemented an controlling process to remote control RS-422 (also known as Sony 9Pin) Devices.

We are running into an issue trying to process the Status Byte 1 when we are interacting with the
Blackmagic HyperDeck Studio Mini Device.

Triggering REOCRD over RS-422 works, also stopping that recording works (over the STOP command), but it seems that the read-out Status Byte 1, after successful stopping the recording on the device, is still stick on the recording state.

Here is a Log excerpt from this issue:

Code: Select all
Requesting Status Byte 1 (every Second)
14:54:45,058    27: >>>CMD>>>> TDCISony9Pin.SendCommand        [STATUS1]
14:54:45,058    27: >>>>>>>>>> TDCISony9Pin.SendToSony9Pin     [0x61 0x20 0x11 0x92]
14:54:45,064    27: <<<ANS<<<< DCISony9Pin.ReceiveFromSony9Pin [0x71 0x20 0xA0 0x31]
14:54:45,064    27: <<<PARS<<< TDCISony9Pin.ParseReceived      [0x71 0x20 0xA0 0x31]-[STATUS1]:[0xA0]

Bits for STANDBY and STOP are set here in this example

Now trigger RECORD via Remote protocol
14:54:47,804    27: >>>CMD>>>> TDCISony9Pin.SendCommand        [RECORD]
14:54:47,805    27: >>>>>>>>>> TDCISony9Pin.SendToSony9Pin     [0x20 0x02 0x22]
14:54:47,810    27: <<<ANS<<<< DCISony9Pin.ReceiveFromSony9Pin [0x10 0x01 0x11]
14:54:47,811    27: <<<PARS<<< TDCISony9Pin.ParseReceived      [0x10 0x01 0x11]->[ACK]

Blackmagic HyperDeck Studio Mini starts Recording

Requesting Status Byte 1
14:54:49,059    27: >>>CMD>>>> TDCISony9Pin.SendCommand        [STATUS1]
14:54:49,059    27: >>>>>>>>>> TDCISony9Pin.SendToSony9Pin     [0x61 0x20 0x11 0x92]
14:54:49,065    27: <<<ANS<<<< DCISony9Pin.ReceiveFromSony9Pin [0x71 0x20 0x82 0x13]
14:54:49,065    27: <<<PARS<<< TDCISony9Pin.ParseReceived      [0x71 0x20 0x82 0x13]->[STATUS1]:[0x82]

Bits for STANDBY and RECORD are set

Now trigger STOP via Remote protocol
14:54:55,167    27: >>>CMD>>>> TDCISony9Pin.SendCommand        [STOP]
14:54:55,167    27: >>>>>>>>>> TDCISony9Pin.SendToSony9Pin     [0x20 0x00 0x20]
14:54:55,172    27: <<<ANS<<<< DCISony9Pin.ReceiveFromSony9Pin [0x10 0x01 0x11]
14:54:55,172    27: <<<PARS<<< TDCISony9Pin.ParseReceived      [0x10 0x01 0x11]->[ACK]

Blackmagic HyperDeck Studio Mini stops Recording

Requesting Status Byte 1
14:54:55,666    27: >>>CMD>>>> TDCISony9Pin.SendCommand        [STATUS1]
14:54:55,666    27: >>>>>>>>>> TDCISony9Pin.SendToSony9Pin     [0x61 0x20 0x11 0x92]
14:54:55,672    27: <<<ANS<<<< DCISony9Pin.ReceiveFromSony9Pin [0x71 0x20 0x82 0x13]
14:54:55,672    27: <<<PARS<<< TDCISony9Pin.ParseReceived      [0x71 0x20 0x82 0x13]->[STATUS1]:[0x82]

Bits for STANDBY and RECORD are still set, [b]this seems to be wrong[/b]

Now trigger PLAY via Remote protocol
14:55:00,578    27: >>>CMD>>>> TDCISony9Pin.SendCommand        [PLAY]
14:55:00,579    27: >>>>>>>>>> TDCISony9Pin.SendToSony9Pin     [0x20 0x01 0x21]
14:55:00,584    27: <<<ANS<<<< DCISony9Pin.ReceiveFromSony9Pin [0x10 0x01 0x11]
14:55:00,584    27: <<<PARS<<< TDCISony9Pin.ParseReceived      [0x10 0x01 0x11]->[ACK]

Blackmagic HyperDeck Studio Mini starts Playing

Requesting Status Byte 1
14:55:00,949    27: >>>CMD>>>> TDCISony9Pin.SendCommand        [STATUS1]
14:55:00,949    27: >>>>>>>>>> TDCISony9Pin.SendToSony9Pin     [0x61 0x20 0x11 0x92]
14:55:00,954    27: <<<ANS<<<< DCISony9Pin.ReceiveFromSony9Pin [0x71 0x20 0xA0 0x31]
14:55:00,954    27: <<<PARS<<< TDCISony9Pin.ParseReceived      [0x71 0x20 0xA0 0x31]->[STATUS1]:[0xA0]

Bits for STANDBY and STOP are set

Requesting Status Byte 1
14:55:02,263    27: >>>CMD>>>> TDCISony9Pin.SendCommand        [STATUS1]
14:55:02,263    27: >>>>>>>>>> TDCISony9Pin.SendToSony9Pin     [0x61 0x20 0x11 0x92]
14:55:02,269    27: <<<ANS<<<< DCISony9Pin.ReceiveFromSony9Pin [0x71 0x20 0x81 0x12]
14:55:02,269    27: <<<PARS<<< TDCISony9Pin.ParseReceived      [0x71 0x20 0x81 0x12]->[STATUS1]:[0x81]

Bits for STANDBY and PLAY are set

Now trigger STOP via Remote protocol
14:55:12,304    27: >>>CMD>>>> TDCISony9Pin.SendCommand        [STOP]
14:55:12,305    27: >>>>>>>>>> TDCISony9Pin.SendToSony9Pin     [0x20 0x00 0x20]
14:55:12,310    27: <<<ANS<<<< DCISony9Pin.ReceiveFromSony9Pin [0x10 0x01 0x11]
14:55:12,310    27: <<<PARS<<< TDCISony9Pin.ParseReceived      [0x10 0x01 0x11]->[ACK]

Blackmagic HyperDeck Studio Mini stops Playing

Requesting Status Byte 1
14:55:12,809    27: >>>CMD>>>> TDCISony9Pin.SendCommand        [STATUS1]
14:55:12,809    27: >>>>>>>>>> TDCISony9Pin.SendToSony9Pin     [0x61 0x20 0x11 0x92]
14:55:12,815    27: <<<ANS<<<< DCISony9Pin.ReceiveFromSony9Pin [0x71 0x20 0xA0 0x31]
14:55:12,815    27: <<<PARS<<< TDCISony9Pin.ParseReceived      [0x71 0x20 0xA0 0x31]->[STATUS1]:[0xA0]

Bits for STANDBY and STOP are set


Reading out the Device Info via proprietary protocol gives this response:
device info
204 device info:
protocol version: 1.9
model: HyperDeck Studio Mini
slot count: 2

For us this looks like there is an issue with the RS-422 protocol in this firmware of the Blackmagic HyperDesk Studio Mini.

Thanks
Christopher

Return to Software Developers

Who is online

Users browsing this forum: No registered users and 2 guests