Intensity Pro 4K - detected video input issues

Ask software engineering and SDK questions for developers working on Mac OS X, Windows or Linux.
  • Author
  • Message
Offline
User avatar

Dmitry Vasilyev

  • Posts: 2
  • Joined: Thu Mar 30, 2017 11:15 pm

Intensity Pro 4K - detected video input issues

PostThu Mar 30, 2017 11:59 pm

Hello SDK team,

I'm trying to use Intensity Pro 4K with the latest SDK 10.8.5 on Windows 10 Pro and it works very unstable and strange.

1. I can request bmdDeckLinkStatusDetectedVideoInputMode,
but I don't see any option to request the detected pixel format (RGB/YUV).

2. So I must use ksDeckLinkModeAuto.
Intensity Pro 4K supports ksDeckLinkModeAuto, but sometime fails.
Repro steps are:
1) No input signal.
Video Input Signal Locked: no
Detected Video Input Mode: Unknown
2) Set ksDeckLinkModeAuto.
3) Add Blackmagic WDM capture filter to the graph.
4) Video pin format is 720x486i 29.97fps (UYVY)
5) Connect 720p59.94 to HDMI input.
6) Notify callback is ok.
Detected Video Input Mode is 720p59.94.
But the video pin format is still 720x486i 29.97fps (UYVY).
Any reconnecting does not help.
I would like to override the mode, but I don't know the correct pixel format (RGB/YUV).
Hope you will add bmdDeckLinkStatusDetectedVideoInputPixelFormat and/or fix ksDeckLinkModeAuto behavior.

3. I tried to connect RGB 4K from the nVidia video card.
Intensity Pro 4K does not support RGB 4K, but it did not report any error or unknown mode.
Detected Video Input Mode was 2160p30 and the pixel format was HDYC (UYVY) instead of RGB32.
The Blackmagic WDM capture filter captured a black (or blue) screen.
I tried the CapturePreview sample from SDK and it even blinks with the wrong casting RGB 4:4:4 to UYVY 4:2:2.
Hope you will add support RGB 4K or at least report ModeUnknown in this case.

Thanks,
Dmitry

Return to Software Developers

Who is online

Users browsing this forum: No registered users and 2 guests