Please update the support to 4.10 linux kernel

Get answers to your questions about color grading, editing and finishing with DaVinci Resolve.
  • Author
  • Message
Offline

Alessandro Fontana

  • Posts: 18
  • Joined: Fri Mar 03, 2017 5:14 pm

Please update the support to 4.10 linux kernel

PostThu Apr 27, 2017 4:16 pm

....like title, nothing more.
The kernels supported from video desktop for Decklink card are always older.

Thank you.

alessandro
Offline

Knud Christiansen

  • Posts: 6
  • Joined: Sun Apr 10, 2016 10:37 am

Re: Please update the support to 4.10 linux kernel

PostFri Apr 28, 2017 5:24 am

Maybe it would be an idea to make the update to cover kernel 4.11 also
4.11 are quite stable now and will proberly go into release this weekend

In 4.11 there are a few additional changes mostly moving around som header content.

I have patched the 10.8.6 driver to install under 4.11...works fine with my Intensity 4K Pro
Can provide a diff file

Knud
Offline

Alessandro Fontana

  • Posts: 18
  • Joined: Fri Mar 03, 2017 5:14 pm

Re: Please update the support to 4.10 linux kernel

PostFri Apr 28, 2017 5:34 am

Hi Knud,
can you explain how you have patched the driver?
I'm on Ubuntu 17.04, and I have an Intensity 4K too.

tnx

a.

P.S. I have this error when I try install the driver:

Selecting previously unselected package desktopvideo.
(Reading database ... 199676 files and directories currently installed.)
Preparing to unpack .../desktopvideo_10.8.6a2_amd64.deb ...
Unpacking desktopvideo (10.8.6a2) ...
Setting up desktopvideo (10.8.6a2) ...
Preparing new blackmagic driver for 4.10.0-20-generic kernel...
Adding to DKMS
Building (failed)
Preparing new blackmagic-io driver for 4.10.0-20-generic kernel...
Adding to DKMS
Building (failed)
Loading modules...
Enabling systemd services...
DesktopVideoHelper
Starting systemd services...
DesktopVideoHelper
********************************************************************************
Failed to build driver(s)

Possible causes:
1. Driver is incompatible with your kernel version
2. Kernel headers/gcc/make/etc. is not installed
3. Kernel header version does not match the running kernel (4.10.0-20-generic)

Error messages:
dkms build -m blackmagic -v 10.8.6a2
---

Kernel preparation unnecessary for this kernel. Skipping...

Building module:
cleaning build area...
make -j40 KERNELRELEASE=4.10.0-20-generic KERNELRELEASE=4.10.0-20-generic...(bad exit status: 2)
ERROR (dkms apport): unable to determine source package for desktopvideo
Error! Bad return status for module build on kernel: 4.10.0-20-generic (x86_64)
Consult /var/lib/dkms/blackmagic/10.8.6a2/build/make.log for more information.

dkms build -m blackmagic-io -v 10.8.6a2
---

Kernel preparation unnecessary for this kernel. Skipping...

Building module:
cleaning build area...
make -j40 KERNELRELEASE=4.10.0-20-generic KERNELRELEASE=4.10.0-20-generic...(bad exit status: 2)
ERROR (dkms apport): unable to determine source package for desktopvideo
Error! Bad return status for module build on kernel: 4.10.0-20-generic (x86_64)
Consult /var/lib/dkms/blackmagic-io/10.8.6a2/build/make.log for more information.


********************************************************************************
Processing triggers for systemd (232-21ubuntu3) ...
Processing triggers for ureadahead (0.100.0-19) ...
ureadahead will be reprofiled on next reboot
Processing triggers for man-db (2.7.6.1-2) ...
Processing triggers for libc-bin (2.24-9ubuntu2) ...
/sbin/ldconfig.real: /usr/lib/nvidia-375/libEGL.so.1 is not a symbolic link

/sbin/ldconfig.real: /usr/lib32/nvidia-375/libEGL.so.1 is not a symbolic link
Offline

Knud Christiansen

  • Posts: 6
  • Joined: Sun Apr 10, 2016 10:37 am

Re: Please update the support to 4.10 linux kernel

PostFri Apr 28, 2017 5:56 am

I am using Fedora 26 and AMD Ryzen 7 so I am forced to use new kernels.

Are you familiar with building kernel modules for Ubuntu (debian based) ?

I installed the driver (rpm files) which fails...

Then I patch the driver src in /usr/src..../Blackmagic...

Installed the modules with DKMS

The diff file with detailed patches I dont have at this machine right now...can provide it later today

Knud

PS

My patch is made rough for 4.11
It shall be "cleaned" a little bit to work for your kernel 4.10
Because some of the changes are only in 4.11 and not in 4.10

Knud
Offline

Alessandro Fontana

  • Posts: 18
  • Joined: Fri Mar 03, 2017 5:14 pm

Re: Please update the support to 4.10 linux kernel

PostFri Apr 28, 2017 7:47 am

Seem complicated....
but if isn't so much disturbs for you, I would like know more, the BM support on it is little in delay.

tnx

alessandro
Offline

Knud Christiansen

  • Posts: 6
  • Joined: Sun Apr 10, 2016 10:37 am

Re: Please update the support to 4.10 linux kernel

PostFri Apr 28, 2017 12:59 pm

I can not upload the patch files to the forum...says "extension not allowed"

But send me a private message with your mail address then I will send the files to you

Knud
Offline

TomToom

  • Posts: 3
  • Joined: Fri Mar 28, 2014 6:24 pm

Re: Please update the support to 4.10 linux kernel

PostTue May 09, 2017 10:08 am

Can't install on Kubuntu 17.04 :-(

Waiting for update

********************************************************************************
Failed to build driver(s)

Possible causes:
1. Driver is incompatible with your kernel version
2. Kernel headers/gcc/make/etc. is not installed
3. Kernel header version does not match the running kernel (4.10.0-20-generic)

Error messages:
dkms build -m blackmagic -v 10.9a7
---

Kernel preparation unnecessary for this kernel. Skipping...

Building module:
cleaning build area...
make -j8 KERNELRELEASE=4.10.0-20-generic KERNELRELEASE=4.10.0-20-generic...(bad exit status: 2)
ERROR: Cannot create report: [Errno 17] File exists: '/var/crash/desktopvideo.0.crash'
Error! Bad return status for module build on kernel: 4.10.0-20-generic (x86_64)
Consult /var/lib/dkms/blackmagic/10.9a7/build/make.log for more information.

dkms build -m blackmagic-io -v 10.9a7
---

Kernel preparation unnecessary for this kernel. Skipping...

Building module:
cleaning build area...
make -j8 KERNELRELEASE=4.10.0-20-generic KERNELRELEASE=4.10.0-20-generic...(bad exit status: 2)
ERROR: Cannot create report: [Errno 17] File exists: '/var/crash/desktopvideo.0.crash'
Error! Bad return status for module build on kernel: 4.10.0-20-generic (x86_64)
Consult /var/lib/dkms/blackmagic-io/10.9a7/build/make.log for more information.

Error! Bad return status for module build on kernel: 4.10.0-20-generic (x86_64)
Offline
User avatar

Michael Reilly

  • Posts: 7
  • Joined: Mon Apr 17, 2017 11:19 pm
  • Location: Atlanta, GA

Re: Please update the support to 4.10 linux kernel

PostFri May 12, 2017 12:26 am

Hey there.

I made a post about this ages ago. You can find it here:

It includes patched source code and rebuilt debs.

viewtopic.php?f=18&t=58357

I have made a short write-up on the ubuntu forums.

ubuntuforums.org/showthread.php?t=2359332

Neither of which got any traction, which is ironic, because you found either post your problem would have been solved before you even asked. ;)
Offline

Alessandro Fontana

  • Posts: 18
  • Joined: Fri Mar 03, 2017 5:14 pm

Re: Please update the support to 4.10 linux kernel

PostFri May 12, 2017 3:03 pm

Thank you Michael!!
I fix it with your patch.

a.
Offline

Arun Gurung

  • Posts: 1
  • Joined: Wed May 24, 2017 12:31 pm

Re: Please update the support to 4.10 linux kernel

PostWed May 24, 2017 5:42 pm

Please update with support for Linux 4.11. I successfully installed my Intensity Extreme on Linux 3.10 (CentOS 7.3) but with the new kernel, I get the same errors as the other people.
Offline
User avatar

Vassilis Kontodimas

  • Posts: 57
  • Joined: Wed May 31, 2017 7:10 pm

Re: Please update the support to 4.10 linux kernel

PostThu Jul 06, 2017 9:35 pm

Yes, I would agree on the kernel support needed to be updated.
I am running Davinci/Fusion/Decklink on an SSD-only station, CentOS 7.3 and going through a kernel update, something that -according to specs- increases my SSD performance by at least 50%. This is extremely needed, especially for Davinci Resolve.

The current offered stable kernel for CentOS is the 4.12. Installing it and crossing fingers. The 3.10 is simply excruciatingly slow.

Update:
Minus the protest by AMDGPU-Pro, not being able to install the DKMS module and a slight protest by Decklink's drivers that I need a reboot, the Kernel update to 4.12 on CentOS 7.3 made a huge difference on Resolve. Both on the SSD speed read and the graphics display in general.

Return to DaVinci Resolve

Who is online

Users browsing this forum: Glenn Venghaus, James Harkness, Peter Lee and 33 guests