Capture/playback hangs on user switching.

Ask software engineering and SDK questions for developers working on Mac OS X, Windows or Linux.
  • Author
  • Message
Offline

Oleksandr Torgovets

  • Posts: 2
  • Joined: Mon Jul 10, 2017 10:34 am

Capture/playback hangs on user switching.

PostMon Jul 10, 2017 11:55 am

We have found an issue in DeckLinkAPI.dll (or CheckVersionPCI.exe).
Decklink Duo 2 card hangs periodically (from several hours to several weeks) when performs 24/7/365 capture or playback.

Hungs are observed at several hardware/software platforms:
- Xeon E3-1245v5, Supermicro X11SSH-LN4F, Win8.1 Enterprise x64;
- Xeon E3-1220v5, Win7 x64;
- Xeon E3-1225v5, Win8.1 Enterprise x64;
- Core i7-4770K, Asus B85M-E, Win10 Pro x64;
- Xeon E5-2630v3, Win8.1 Pro x64.

We debugged a little that issue on i7-4770K Win10 x64 with SDI capturing.
And found that card hangs when user login occurs (hope it's the same problem as on other machines).

Hang occurs in worker thread that makes IDeckLinkInputCallback::VideoInputFrameArrived() calls.
Location: 0x000122DB from DeckLinkAPI.dll begin (dll version 10.9.3.0), inside WaitForMultipleObjects( 6, , FALSE, INFINITE ) call.

We checked different conditions:
- local logon and through RDP;
- one and several simultaneous capturings;
- capture application(s) running under user and as service (with system account).
Issue occur in all cases.

It was also noticed that hung occurs when CheckVersionPCI.exe starts (it is registered at AllUsers-autorun).

So (until issue will be fixed), can I remove CheckVersionPCI.exe from autostart?
For what CheckVersionPCI.exe is responsible?
Can it affect running applications even without other-user logon?
Offline

Nicholas Gill

Blackmagic Design

  • Posts: 168
  • Joined: Mon May 04, 2015 10:28 pm

Re: Capture/playback hangs on user switching.

PostWed Jul 12, 2017 3:48 am

Hi Oleksandr,

This is a primarily user-oriented forum, with this sub-forum being dedicated to discussion related to the Blackmagic Design SDKs and Protocols.

I would recommend contacting Blackmagic Design Support for their assistance to diagnose the issue you are experiencing.

Sincerely,

-nick
Offline

Oleksandr Torgovets

  • Posts: 2
  • Joined: Mon Jul 10, 2017 10:34 am

Re: Capture/playback hangs on user switching.

PostThu Jul 13, 2017 7:30 am

Nicholas Gill wrote:Hi Oleksandr,
This is a primarily user-oriented forum.
-nick


Ok. Thank you! Will contact support.

Return to Software Developers

Who is online

Users browsing this forum: No registered users and 2 guests