Blackmagic DeckLink SDK compatibility

Ask software engineering and SDK questions for developers working on Mac OS X, Windows or Linux.
  • Author
  • Message
Offline

Mikhail Gorodilov

  • Posts: 1
  • Joined: Fri Aug 18, 2017 6:59 am

Blackmagic DeckLink SDK compatibility

PostFri Aug 18, 2017 7:09 am

I've updated SDK from version 10.4 to version 10.9.5.
CDeckLinkIterator uuid was changed.
Code: Select all
 [
-    uuid(1F2E109A-8F4F-49E4-9203-135595CB6FA5),
+    uuid(87D2693F-8D4A-45C7-B43F-10ACBA25E68F),
     helpstring("CDeckLinkIterator Class")
 ] coclass CDeckLinkIterator

Now it's not possible to create CDeckLinkIterator instance if installed driver version is lower then 10.9.3 :(

Was it planned or it's mistake?
Offline

Nicholas Gill

Blackmagic Design

  • Posts: 169
  • Joined: Mon May 04, 2015 10:28 pm

Re: Blackmagic DeckLink SDK compatibility

PostWed Sep 06, 2017 11:29 pm

Posting result of discussion in developer support for general information.

An application built against an older SDK can always be used with a newer Desktop Video driver version.

It is not however possible to reliably use a newer SDK with an older driver, as the newer SDK against which the application is built will require the presence of newer interfaces which are not likely to be present in the older driver.

For example, if the application is built against SDK version 10.4 it will be possible to deploy the application with any Desktop Video version from 10.4 onwards.

Unless your application requires interfaces added to later Desktop Video SDK versions, there is no requirement to update.

-nick

Return to Software Developers

Who is online

Users browsing this forum: No registered users and 2 guests