issue with Micro Studio 4K camera and DeckLink 4K card

Ask software engineering and SDK questions for developers working on Mac OS X, Windows or Linux.
  • Author
  • Message
Offline

Andres Gonzalez

  • Posts: 10
  • Joined: Tue Apr 21, 2015 2:05 am

issue with Micro Studio 4K camera and DeckLink 4K card

PostThu Aug 31, 2017 5:29 pm

Hi,
I bought a Micro Studio 4K camera when they first came out and have been using it successfully at 1080p30 with several different DeckLink interface cards. I now need to develop the 2180p30 features of my linux video server, however, I am having problems running at 2180p30.

The camera appears to be generating 2180p30 successfully. I have a Video Assist that shows the 2180p30 setting and I have a SmartScope that captures the video correctly. But the DeckLink 4K interface card does not capture valid video frames.

I can configure the DeckLink 4K card interface without error for 2180p30 and my DeckLinkDelegate routine gets called correctly. However, it is called at 29.9 fps and the bmdFrameHasNoInputSource is always set. I don't know if it is a problem with the camera or the DeckLink 4K card.

Does the SDK driver delegate get called at its configured rate or at the rate it reads off the SDI video bit stream? Knowing that would at least be a clue as to if it is a problem with the camera or the DeckLink 4K card.

Thanks,
-Andres
Offline

Cameron Nichols

Blackmagic Design

  • Posts: 4
  • Joined: Mon Sep 04, 2017 4:05 am

Re: issue with Micro Studio 4K camera and DeckLink 4K card

PostMon Sep 11, 2017 5:19 am

Hi Andres,

Can you check in Media Express what video mode is reported by capture? Is it consistent with the video settings from Micro Studio Camera 4K?

Regards
Cameron

Return to Software Developers

Who is online

Users browsing this forum: No registered users and 3 guests