GetBufferForVerticalBlankingLine broken in latest drivers?

Ask software engineering and SDK questions for developers working on Mac OS X, Windows or Linux.
  • Author
  • Message
Offline

dheitmueller@ltnglobal.com

  • Posts: 3
  • Joined: Mon Mar 26, 2018 4:59 pm
  • Real Name: Devin Heitmueller

GetBufferForVerticalBlankingLine broken in latest drivers?

PostThu Jul 26, 2018 6:59 pm

Hello,

I setup a new Ubuntu 18.04 system, and installed the most recent videodesktop 10.11.1 package from the support site. I'm using a Duo2 to capture 720p59 over SDI and using the same capture code I've been using for the last several years with older driver versions.

It appears that the IDeckLinkVideoFrameAncillary::GetBufferForVerticalBlankingLine() call got broken, starting in version 10.10.

All attempts to call it, regardless of the line specified return 0x80000003, suggesting an invalid line number was specified, and I'm attempting to make calls with lines 9-21.

I have tried this with both the 10.8.5 SDK (which I have used in production for quite some time) against the 10.11.1 driver, as well as trying the latest 10.11.1 SDK to see if this was some breakage in compatibility between newer drivers and older SDKs. The problem occurs regardless of whether using the 10.8.5 SDK or the latest.

So I went through and narrowed the problem down to having been introduced in driver 10.10 (10.9.12 worked fine). In all these tests I'm using the 10.8.5 SDK headers and the same code I've had in production for a number of years.

I know Blackmagic introduced a new API for receiving ancillary data and the docs indicate that would be the preferred API going forward, but I haven't seen anything to suggest that the existing API has been deprecated or obsoleted.

Is this a known issue?

Thanks,

Devin Heitmueller

Return to Software Developers

Who is online

Users browsing this forum: No registered users and 2 guests