DeckLink Quad - FMPEG - Output not interlaced

Ask software engineering and SDK questions for developers working on Mac OS X, Windows or Linux.
  • Author
  • Message


  • Posts: 1
  • Joined: Thu Aug 09, 2018 8:40 am
  • Real Name: Lukas Lange

DeckLink Quad - FMPEG - Output not interlaced

PostThu Aug 09, 2018 9:32 am


I have a problem with my Decklink Quad Card. I need an 1080i Output but it only sends out an progressive Output. Did anyone else had this problem and solved it? I use the following Command:

ffmpeg -i rtmp://$name -s 1920x1080 -r 25000/1000 -vf scale=interl=1 -ar 48000 -ac 2 -pix_fmt uyvy422 -f decklink "DeckLink SDI (3)"

My Input is an non interlaced RTMP Stream which should be converted in an interlaced Output. If i do the same thing with the Resoulution 720x576 it worked fine.

I use the following FFMPEG and SDK (Ubuntu 18.04):

ffmpeg version 4.0 Copyright (c) 2000-2018 the FFmpeg developers
built with gcc 7 (Ubuntu 7.3.0-16ubuntu3)
configuration: --disable-yasm --enable-nonfree --enable-libx264 --enable-gpl --enable-decklink --extra-cflags=-I/$home/Blackmagic_DeckLink_SDK_10.11.1/Linux/include --extra-ldflags=-L/$home/Blackmagic_DeckLink_SDK_10.11.1/Linux/include


  • Posts: 4
  • Joined: Mon Mar 26, 2018 4:59 pm
  • Real Name: Devin Heitmueller

Re: DeckLink Quad - FMPEG - Output not interlaced

PostThu Aug 09, 2018 6:41 pm

Hello Sevenlive,

The issue is that ffmpeg doesn't preserve the interlaced status through the entire pipeline. Hence when it gets to the decklink output libavdevice module the module chooses 1080p/25 (i.e. PSF). I've got patches to preserve this info so the proper output mode is chosen, but they haven't made it upstream yet.

In the short term, you can use the DesktopVideo GUI to set enable PSF mode. This will cause the 1080p/25 to be output as 1080i/50, which will accomplish the same objective if your equipment is not using the payload identifier to know it's in PSF mode.

Unfortunately there also is not a way to force a specific output mode in the decklink libavdevice module, which is also on my TODO list.

Devin Heitmueller
LTN Global Communications

Alberto Diaz

  • Posts: 14
  • Joined: Thu Jun 19, 2014 2:07 pm

Re: DeckLink Quad - FMPEG - Output not interlaced

PostWed Jan 23, 2019 6:00 pm

Hello Devin and Sevenlive

We are facing this exact same issue. Is there any way to activate the DeckLink interlaced output (Hi50) when using ffmpeg? Any news?

Activating the PSF output is not always an option (because of the 25p effect).

Thank you!

Amnon Israely

  • Posts: 10
  • Joined: Sun May 05, 2013 9:07 am

Re: DeckLink Quad - FMPEG - Output not interlaced

PostFri Jan 25, 2019 1:46 pm

I solve this by gstreamer with interlace field-pattern=2:2 pipe

Return to Software Developers

Who is online

Users browsing this forum: No registered users and 3 guests