Error Compiling driver for intensity shuttle usb3 linux

Ask software engineering and SDK questions for developers working on Mac OS X, Windows or Linux.
  • Author
  • Message
Offline

pedropt

  • Posts: 3
  • Joined: Tue Aug 28, 2018 4:43 pm
  • Real Name: Pedro Amaro

Error Compiling driver for intensity shuttle usb3 linux

PostSat Oct 20, 2018 11:46 pm

Hi , i am having some issues installing intensity shuttle in my linux
My linux is a based on debian and i have an amd64 machine .
When i try to iinstall the package desktopvideo_10.2a5_amd64.deb in my kernel 4.18.0-0.bpo.1-amd64

i get these errors on the log

DKMS make.log for blackmagic-io-10.2a5 for kernel 4.18.0-0.bpo.1-amd64 (x86_64)
Sun Oct 21 00:36:58 CDT 2018
make -C /lib/modules/4.18.0-0.bpo.1-amd64/build M=/var/lib/dkms/blackmagic-io/10.2a5/build
make[1]: Entering directory '/usr/src/linux-headers-4.18.0-0.bpo.1-amd64'
CC [M] /var/lib/dkms/blackmagic-io/10.2a5/build/bmio_client.o
CC [M] /var/lib/dkms/blackmagic-io/10.2a5/build/bmio_dev.o
CC [M] /var/lib/dkms/blackmagic-io/10.2a5/build/bmio_driver.o
CC [M] /var/lib/dkms/blackmagic-io/10.2a5/build/bmio_serial.o
/var/lib/dkms/blackmagic-io/10.2a5/build/bmio_client.c: In function ‘bmio_open’:
/var/lib/dkms/blackmagic-io/10.2a5/build/bmio_client.c:95:38: error: ‘struct file’ has no member named ‘f_dentry’; did you mean ‘f_owner’?
drv = bmio_driver_find_by_inode(filp->f_dentry->d_inode);
^~
/var/lib/dkms/blackmagic-io/10.2a5/build/bmio_client.c: In function ‘bmio_read’:
/var/lib/dkms/blackmagic-io/10.2a5/build/bmio_client.c:174:9: error: implicit declaration of function ‘signal_pending’ [-Werror=implicit-function-declaration]
if (!signal_pending(current))
^~~~~~~~~~~~~~
cc1: some warnings being treated as errors
make[4]: *** [/usr/src/linux-headers-4.18.0-0.bpo.1-common/scripts/Makefile.build:322: /var/lib/dkms/blackmagic-io/10.2a5/build/bmio_client.o] Error 1
make[4]: *** Waiting for unfinished jobs....
make[3]: *** [/usr/src/linux-headers-4.18.0-0.bpo.1-common/Makefile:1518: _module_/var/lib/dkms/blackmagic-io/10.2a5/build] Error 2
make[2]: *** [Makefile:146: sub-make] Error 2
make[1]: *** [Makefile:8: all] Error 2
make[1]: Leaving directory '/usr/src/linux-headers-4.18.0-0.bpo.1-amd64'
make: *** [Makefile:47: all] Error 2


I believe i downloaded the latest package for my usb3 intensity shuttle , but i believe that these errors could be related to a very new kernel , and problably the driver was for kernel 3.16 until 4.0 , but i am not sure .

Is there a way to solve this issue without downgrading the kernel on my linux ?
In case i have to downgrade the kernel then witch debian kernel version was this package tested ?

Thank you
Offline

Cameron Nichols

Blackmagic Design

  • Posts: 129
  • Joined: Mon Sep 04, 2017 4:05 am

Re: Error Compiling driver for intensity shuttle usb3 linux

PostWed Oct 31, 2018 12:20 am

Hi Pedro,

To build against kernel 3.19 or later, you will need at least Desktop Video 10.4.1 package, preferably the latest package. Desktop Video v10.2 was released over 4 years ago.

Regards
Cameron

Return to Software Developers

Who is online

Users browsing this forum: No registered users and 2 guests