FFmpeg unable to compile for DeckLink Duo

Ask software engineering and SDK questions for developers working on Mac OS X, Windows or Linux.
  • Author
  • Message
Offline

Fawkes

  • Posts: 2
  • Joined: Wed Jan 30, 2019 3:49 pm
  • Real Name: Patrick L'Hoir

FFmpeg unable to compile for DeckLink Duo

PostWed Jan 30, 2019 4:36 pm

Dear all,

A couple of days ago I installed a DeckLink Duo on my computer.
I updated the driver as soon as I restarted the desktop.
I first downloaded the latest Blackmagic DeckLink SDK 10.11.4
And secondly I downloaded FFmpeg from the official git.

I tried to configure with --enable-decklink, --extra-cflags and --extra-ldflags

Here is the command I made:
Code: Select all
sudo PATH="$HOME/bin:$PATH" PKG_CONFIG_PATH="$HOME/ffmpeg_build/lib/pkgconfig" ./configure --prefix="$HOME/ffmpeg_build" --pkg-config-flags="--static" --extra-cflags="-I$HOME/ffmpeg_build/include" --extra-cflags="-I$HOME/Blackmagic\ DeckLink\ SDK\ 10.11.4/Linux/include" --extra-ldflags="-L$HOME/ffmpeg_build/lib" --extra-ldflags="-L$HOME/Blackmagic\ DeckLink\ SDK\ 10.11.4/Linux/include" --extra-libs="-lpthread -lm" --bindir="$HOME/bin" --enable-decklink --enable-gpl --enable-libass --enable-libfdk-aac --enable-libfreetype --enable-libmp3lame --enable-libopus --enable-libtheora --enable-libvorbis --enable-libvpx --enable-libx264 --enable-libx265 --enable-nonfree && PATH="$HOME/bin:$PATH" make && make install


However I get the following message: C compiler test failed.

I am on ubuntu 18.04.1

I do not know what is my mistake, your help is very welcome.
Please ask me if I forgot to mention any relevant data.
Offline

Amnon Israely

  • Posts: 10
  • Joined: Sun May 05, 2013 9:07 am

Re: FFmpeg unable to compile for DeckLink Duo

PostThu Jan 31, 2019 2:19 pm

Look into the config.log
Offline

Fawkes

  • Posts: 2
  • Joined: Wed Jan 30, 2019 3:49 pm
  • Real Name: Patrick L'Hoir

Re: FFmpeg unable to compile for DeckLink Duo

PostThu Jan 31, 2019 2:44 pm

Thank you for your comment,
It was not happy with the spaces in the default Blackmagic Decklink SDK folder's name.
I replace it with underscore and now it is compiling.

Return to Software Developers

Who is online

Users browsing this forum: No registered users and 1 guest