Ultrastudio mini not recognised as device by MacOS

Ask software engineering and SDK questions for developers working on Mac OS X, Windows or Linux.
  • Author
  • Message
Offline

heeton

  • Posts: 1
  • Joined: Tue Jun 18, 2019 4:43 pm
  • Real Name: Alex Heeton

Ultrastudio mini not recognised as device by MacOS

PostTue Jun 18, 2019 4:47 pm

Any pointers would be greatly appreciated:

I'm trying to integrate my device with a toolchain which starts with needing the device as a video input. I can read from the Ultrastudio using Quicktime, OBS, and Media Express. Interestingly, VLC recognises on the audio stream, not the video stream.

If I run `system_profiler SPCameraDataType` then I see the following errors for the Blackmagic drivers

2019-06-18 17:39:59.014 system_profiler[1879:17297] Error loading /Library/CoreMediaIO/Plug-Ins/DAL/DeckLinkCMIO.plugin/Contents/MacOS/DeckLinkCMIO: dlopen(/Library/CoreMediaIO/Plug-Ins/DAL/DeckLinkCMIO.plugin/Contents/MacOS/DeckLinkCMIO, 0x0106): code signature in (/Library/CoreMediaIO/Plug-Ins/DAL/DeckLinkCMIO.plugin/Contents/MacOS/DeckLinkCMIO) not valid for use in process: mapping process is a platform binary, but mapped file is not
2019-06-18 17:39:59.014 system_profiler[1879:17297] Cannot find function pointer DeckLinkPluginFactory for factory 4675C20F-0269-4425-9F5D-E6C6C6CF4A3B in CFBundle/CFPlugIn 0x7fcfb300d430 </Library/CoreMediaIO/Plug-Ins/DAL/DeckLinkCMIO.plugin> (bundle, not loaded)

How can I best address this, or bring it to the attention of Blackmagic?

Return to Software Developers

Who is online

Users browsing this forum: No registered users and 2 guests