Page 1 of 1

OT - Bad SSD?

PostPosted: Fri Jul 07, 2017 1:44 am
by Greg Huson
This is a little off topic, but maybe someone here has a tip - I accidently pulled an SSD out of an external drive holder (aka 'toaster') and now it won't reformat. In Mac OSx Disk Utility it fails after a long time trying unmount; can't seem to partition it using terminal commands, either. I tried formatting in Win7 on a USB 2, but it failed at the very end - now it mounts in OSx Disk Utility showing a completely 'full' partition, but still won't re-partition the drive. (fails during 'unmount.'

Disk warrior says the hardware is fine, but obviously doesn't do anything with the directory, since there doesn't seem to be one.

This is one of the faithful sandisk drives out of my 1st-gen cameras- which I no longer have, so I can't use them to format.

Anyone have an idea how to resurrect this drive? I obviously don't care about the media that was on it - just want to get it back into service.

thanks in advance.

Re: OT - Bad SSD?

PostPosted: Fri Jul 07, 2017 7:25 am
by Peter J. DeCrescenzo
I recently had a similar situation where a drive wouldn't format under Mac Sierra or Windows 10.

I connected it to an old Mac running (whatever preceded Sierra -- Snow Leopard?) and its Disk Utility was able to format the drive.

After that the drive could be formatted under Sierra on my newer Mac & under Win 10 on my PC. Weird. YMMV.


Re: OT - Bad SSD?

PostPosted: Fri Jul 07, 2017 10:35 pm
by rick.lang
El Capitan came right before Sierra, but Snow Leopard may well be on your old machine.

Sent from my iPhone using Tapatalk

Re: OT - Bad SSD?

PostPosted: Tue Jul 11, 2017 1:20 am
by Greg Huson
We have one older system (10.9.5?) with the earlier disk utility - no luck there either.

Even tried 'clean' (or was it 'clear?') in diskpart on a PC. I think the drive is screwed. BUT they have 10-year warranty. Now, if Sandisk will just answer my email...

Re: OT - Bad SSD?

PostPosted: Sat Jul 15, 2017 7:38 pm
by Thierry Bergeron
Whenever I have a problem formatting a HDD or SSD I boot in recovery mode run Disk Utility and usually it works