My 3rd monitor stopped working...

Getting started with a Blackmagic product? Ask questions here about setup and installation.
  • Author
  • Message
Offline

austindonald1

  • Posts: 282
  • Joined: Tue Jan 15, 2019 4:54 pm
  • Real Name: Donald Austin

My 3rd monitor stopped working...

PostMon Nov 11, 2019 10:32 pm

Dont know whats going on, the first one was a neewer, i sent it back, the second one was a viltrox, i sent it back and tonight my FeelWorld 5.5 inch stopped working.

I have a BMPCC

Is there something else happening with these monitors im not aware of?

I dont know which monitor to buy now in fear of its going to stop working.
Donald Austin
Offline

Brad Hurley

  • Posts: 1395
  • Joined: Wed Jan 17, 2018 7:42 pm
  • Location: Montréal

Re: My 3rd monitor stopped working...

PostMon Nov 11, 2019 11:11 pm

Sounds like you may have just been unlucky, but just as a check do you always have the camera turned off and the monitor turned off when you connect them to each other? As far as I know the HDMI connections should be made with all equipment (camera and monitor) turned off.

When you say the monitor "stopped working" do you mean it no longer turns on? Or it turns on but doesn't display an image?
Resolve 16.1, Mac Pro 3.0 GHz 8-core, 32 gigs RAM, dual AMD D700 GPU.
Audio I/O: Sound Devices USBPre-2
Offline

austindonald1

  • Posts: 282
  • Joined: Tue Jan 15, 2019 4:54 pm
  • Real Name: Donald Austin

Re: My 3rd monitor stopped working...

PostTue Nov 12, 2019 12:06 am

Brad Hurley wrote:Sounds like you may have just been unlucky, but just as a check do you always have the camera turned off and the monitor turned off when you connect them to each other? As far as I know the HDMI connections should be made with all equipment (camera and monitor) turned off.

When you say the monitor "stopped working" do you mean it no longer turns on? Or it turns on but doesn't display an image?


I left camera and monitor on and turned on my Juice box power supply to charge the monitor battery, because it was only 40 percent. The juice box has been charging my camera and monitor battery, I left the room, came back about 1/2 an hour later and the monitor was off, there was no red light, nothing. Tried to get the red light to come on by plugging directly in dc adapter, but nothing.
Donald Austin
Offline

Brad Hurley

  • Posts: 1395
  • Joined: Wed Jan 17, 2018 7:42 pm
  • Location: Montréal

Re: My 3rd monitor stopped working...

PostTue Nov 12, 2019 2:12 am

If you're powering both your monitor and the camera using the Juicebox battery it can fry either your monitor or your camera. I have a split cable for the Juicebox that's supposed to power the camera and the monitor but I've never used it because I've read too many horror stories.

It's best to have separate batteries for monitor and camera. If you know what you're doing and have the right equipment you can power both with the same battery, but if not it's pretty easy to destroy either the monitor or the battery this way. Also I think you should be using the Juicebox to power the camera or the monitor directly, not to charge their internal batteries while the equipment is running. In general you want to remove the internal battery when you're powering the camera or monitor via V-mount. This may require using a dummy battery (on the monitor). When I power the original BMPCC with an external battery, I always remove the internal battery. Same goes for my monitor; if I'm powering by V-mount I remove the battery on the back of the monitor.
Resolve 16.1, Mac Pro 3.0 GHz 8-core, 32 gigs RAM, dual AMD D700 GPU.
Audio I/O: Sound Devices USBPre-2
Offline

austindonald1

  • Posts: 282
  • Joined: Tue Jan 15, 2019 4:54 pm
  • Real Name: Donald Austin

Re: My 3rd monitor stopped working...

PostThu Nov 14, 2019 2:55 pm

ok, at first, I thoguht the Juice box was going to charge the monitor battery through the HDMI (i'm feeling silly).Most likely, my previous monitors stopped working because the new battery I bought, went dead and I thought the monitors were no longer working.

How I came to this conclusion is, the new lilliput I got, did not work either when i put battery on, but did work when i used wall adapter.

Conclusion: Don (me) could be an idiot
Donald Austin

Return to Getting Started

Who is online

Users browsing this forum: No registered users and 14 guests