Page 1 of 1

Decklink Quad HDMI - Device Not Detected

PostPosted: Mon Dec 02, 2019 12:28 am
by T2Cheetor
Hello,

I recently purchased the Decklink Quad HDMI and have experienced significant difficulty installing the product. This is not my first Blackmagic product, as I've used PCI-E and USB 3 Intensity devices in the past. Upon installing the card and drivers/software, the card is recognized by Windows and the drivers appear to be installed properly in the device manager, but the Blackmagic software will not recognize the device. I have tried uninstalling and reinstalling the drivers/software many times, using different versions, but have had no success. I've tried swapping my GPU and the Decklink card, placing the Decklink in the first PCI-E slot. I've disabled all other startup applications and ensured the OS is up to date. My BIOS also appears to be the most recent version.

Motherboard: ASUS P8Z77 WS
BIOS: Version 3505
OS: Windows 10 1909 18363.476
GPU: NVidia 2080 Ti
CPU: Intel 3770K

Again, the drivers appear to be installed and the device is listed in the device manager without warnings of any kind. It's simply that the Blackmagic software will not detect the device. Any advice would be greatly appreciated.

Thank You

Re: Decklink Quad HDMI - Device Not Detected

PostPosted: Mon Dec 02, 2019 7:51 pm
by Xtreemtec
After the reboot when the software was installed. Did it prompt for a Firmware upgrade on the card?

If not. Hit Ctrl Alt Del, Go to Task manager, > Processes > BMDUpdateHelper and trigger it to start. Or go to the DesktopVideo folder and find the Updater there. ;)

Re: Decklink Quad HDMI - Device Not Detected

PostPosted: Mon Dec 02, 2019 7:55 pm
by T2Cheetor
Xtreemtec wrote:After the reboot when the software was installed. Did it prompt for a Firmware upgrade on the card?

If not. Hit Ctrl Alt Del, Go to Task manager, > Processes > BMDUpdateHelper and trigger it to start. Or go to the DesktopVideo folder and find the Updater there. ;)


I'll try this as soon as I get home from work. Thanks!

Re: Decklink Quad HDMI - Device Not Detected

PostPosted: Tue Dec 03, 2019 1:53 am
by smithclarkson01
As far as I know Black Magic cards / software does not auto detect the input it receives, meaning the settings have to match the input. Try setting your PS4 to 1080p and the Black Magic to search for 1080p / 59.94.

Re: Decklink Quad HDMI - Device Not Detected

PostPosted: Tue Dec 03, 2019 4:58 pm
by Xtreemtec
Blackmagic Software Updater is the tool that scans if you card has the correct FW inside.
restart this tool or right click, go to file location and trigger it yourself.

And you might also need the Desktop Video Updater.


Image

Re: Decklink Quad HDMI - Device Not Detected

PostPosted: Tue Dec 03, 2019 5:49 pm
by T2Cheetor
Xtreemtec wrote:Blackmagic Software Updater is the tool that scans if you card has the correct FW inside.
restart this tool or right click, go to file location and trigger it yourself.

And you might also need the Desktop Video Updater.


Image


Strange, I don't remember seeing the Blackmagic Software Updater on the system. I'll check again once I am home.

Re: Decklink Quad HDMI - Device Not Detected

PostPosted: Wed Dec 04, 2019 1:03 pm
by T2Cheetor
Xtreemtec wrote:Blackmagic Software Updater is the tool that scans if you card has the correct FW inside.
restart this tool or right click, go to file location and trigger it yourself.

And you might also need the Desktop Video Updater.


Image


Thank you so much! That did the trick. I enabled Blackmagic Software Updater in the startup options and then rebooted. Once the system came back up the firmware update ran and the card was immediately recognized. Everything is working properly now.

Re: Decklink Quad HDMI - Device Not Detected

PostPosted: Wed Dec 04, 2019 4:44 pm
by Xtreemtec
Great you solved it. Was happy to assist. :D