Linux Kernel 4.10 vs Intensity Pro 4K

Getting started with a Blackmagic product? Ask questions here about setup and installation.
  • Author
  • Message
Offline

Michael Reilly

  • Posts: 1
  • Joined: Mon Apr 17, 2017 11:19 pm

Linux Kernel 4.10 vs Intensity Pro 4K

PostMon Apr 17, 2017 11:28 pm

Hello,

I get the following error in the DKMS log when installing the deb packages via dpkg under Kubuntu 17.04:

Code: Select all
/var/lib/dkms/blackmagic/10.8.6a3/build/blackmagic_lib.c: In function 'dl_get_user_pages':
/var/lib/dkms/blackmagic/10.8.6a3/build/blackmagic_lib.c:669:10: error: too few arguments to function 'get_user_pages_remote'
    ret = get_user_pages_remote(current_task, current_task->mm, (unsigned long)ptr & PAGE_MASK, *nr_pages, write ? FOLL_WRITE : 0, pages, NULL);
          ^~~~~~~~~~~~~~~~~~~~~


There seems to be another few drivers such as nvidia's that were also broken by the API change in 4.10 (apparently.)

Is this a known issue with a patch I can apply or an updated .deb I can download? Or should I construct one? I do have a coding background, but only a little experience with linux drivers. And rebuilding .deb files is a minor pain in the neck. :)

Return to Getting Started

Who is online

Users browsing this forum: bretthazlett and 7 guests