DeckLink 4K Extreme not working

Getting started with a Blackmagic product? Ask questions here about setup and installation.
  • Author
  • Message
Offline

Wayne Scicluna

  • Posts: 3
  • Joined: Mon Jul 25, 2016 12:59 pm

DeckLink 4K Extreme not working

PostFri Aug 04, 2017 7:07 am

Hi all,

I have a DeckLink 4K Extreme card and it was working top notch until one day it decided to stop...
I changed the PCIe slot and even tried it on an other workstation still with no luck...
Right now I'm using a DeckLink Duo 2 as a workaround but it's for a TV station and I really need it.

Any information about why the DeckLink 4K Extreme stopped working? Is it gone forever?

Thanks,
Wayne
Offline
User avatar

Jack Fairley

  • Posts: 369
  • Joined: Mon Oct 03, 2016 7:58 pm

Re: DeckLink 4K Extreme not working

PostFri Aug 04, 2017 6:30 pm

Does it appear in device manager at all? I would contact BMD support directly, if it doesn't work on multiple machines it could be busted.
Offline

Wayne Scicluna

  • Posts: 3
  • Joined: Mon Jul 25, 2016 12:59 pm

Re: DeckLink 4K Extreme not working

PostMon Aug 07, 2017 6:33 am

Jack Fairley wrote:Does it appear in device manager at all? I would contact BMD support directly, if it doesn't work on multiple machines it could be busted.


It does not appear in the device manager on multiple machines... But when I connect a USB cable to the usb slot located on the board, it displays something in the dev manager. I don't know what that USB is for...
Offline
User avatar

Jack Fairley

  • Posts: 369
  • Joined: Mon Oct 03, 2016 7:58 pm

Re: DeckLink 4K Extreme not working

PostMon Aug 07, 2017 5:58 pm

USB is for BMD use only. Sounds like the card is broken to me.

Return to Getting Started

Who is online

Users browsing this forum: IanJones and 12 guests