Intensity Shuttle No Desktop Video Device Detected Firmware

Getting started with a Blackmagic product? Ask questions here about setup and installation.
  • Author
  • Message
Offline

Jason Dove

  • Posts: 2
  • Joined: Mon Oct 16, 2017 2:07 am

Intensity Shuttle No Desktop Video Device Detected Firmware

PostMon Oct 16, 2017 10:28 pm

Intensity Shuttle Thunderbolt with Windows 10 Pro 64-bit & Lenovo P51

1. Installed "Desktop Video for Windows v 10.9.7" on my Win 64 system Lenovo P51

2. Plugged in Intensity Shuttle Thunderbolt device: It was recognized by Intel Thunderbolt Utility. But not recognized by Blackmagic Desktop Video Setup software: "No Desktop Video Device Detected".

3. ~30 minutes later I was prompted to provide a firmware update to the Intensity Shuttle Thunderbolt. I proceeded. After the firmware update it worked!! I captured video & Audio from a composite video input and analog audio through RCA cables.

4. ~15 hours later... I was prompted to install another firmware update (stupidly - not following 'if it ain't broke don't fix it' philosophy) I proceeded however, it did not complete successfully. Then it did not work again. Device is still recognized by computer.. just not by blackmagic software. Same message as before: "No Desktop Video Device Detected"

I tried everything:
[*]Every version of the software going back to 10.5.4
[*]Made sure drivers, BIOS, windows... all up to date, Disable Security in BIOS,
[*]disable firewalls, disabled anti virus and anything else I could think of, checked to ensure device on approved list according to Intel Thunderbolt.
[*]Twenty other things I can't even remember now.

I am almost certain the issue is corrupt firmware however, since there is NO utility that will FORCE an update the firmware, I am SOOL.

I've read that the firmware is supposed to be included in the software but there is NO indication the firmware is actually updated by the software. First off, it is recommended that the device not be plugged in when installing the software therefore, the firmware update procedure must not be done as part of the install process.

When installing the different software versions, I have seen no step in the process in which the device firmware is being updated... I was not prompted to plug-in the device. After plugging in the device I never saw anything like I did during the first time I was prompted to updated the firmware. I didn't see any prompt like I did before ~"Don't unplug the device while firmware is being updated".

I don't see a procedure for checking the firmware in the windows scheduler.

The update firmware procedure could be part of a check when you initialize the Desktop Video Setup software however, it probably takes no action unless the firmware version is LESS than the FIRMWARE version that corresponds with the version of the software being used (instead of the check being: [if not equal to]).

My hypothesis is: the Firmware is corrupt but it still appears to the "Desktop Video Setup" as having the latest Firmware version therefore, the software sees no reason to kick of the procedure to update the firmware. And then fails when moving to the next procedure to connect the device b/c the firmwrae is corrupt.

I called tech support... they have NO utility that will directly force a firmware update! This seems absolutely crazy to me!! There doesn't even seem to be a log-file to see if the software did a check on the firmware. Not a happy camper.

Please please Blackmagic, please provide a utility to force the firmware update (i.e. a re-installation of the firmware... even if it is the same version seemly on the device already).

Return to Getting Started

Who is online

Users browsing this forum: No registered users and 11 guests