Level Clipping using DeckLink 4K Extreme

Getting started with a Blackmagic product? Ask questions here about setup and installation.
  • Author
  • Message
Offline
User avatar

Morgan Morel

  • Posts: 3
  • Joined: Tue Aug 29, 2017 9:41 pm
  • Location: San Francisco

Level Clipping using DeckLink 4K Extreme

PostWed Nov 08, 2017 7:02 pm

Howdy,

It appears that later versions of Desktop Video Software (10.6.x and on) are clipping the levels on SD Composite signal. Earlier versions allow for full-range signal (8-bit values of 0 to 254, or 10-bit values of 0 to 1023), but later versions clip at Broadcast Range (8-bit values of 16 to 235, or 10-bit values of 64 to 940).

The clipping appears to be related to hardware as well. I have 4 machines using a DeckLink 4K Extreme card via PCIe which all have this clipping with versions later than 10.6.x. However, I have a machine using an Ultrastudio Express via Thunderbolt and this is able to use version 10.8.5 without any clipping problems.

I know that the Converters software has a switch to toggle this clipping. Can we please a patch that allows us to do this with the latest version of Desktop Video? I am one of many people using this hardware for analog video preservation and we need to capture full-range signals for non-broadcast materials. Many of us are stuck using older versions of the software because of this issue, please help!
✌ ✌ ✌

Return to Getting Started

Who is online

Users browsing this forum: Bing [Bot] and 11 guests