Page 1 of 1

Blackmagic Intensity Shuttle recognized but not usable

PostPosted: Fri Dec 01, 2017 3:01 pm
by Andrew Kelble
I have a windows 10 64-bit machine, recently installed a PCI-e USB 3.0 into it.
The drivers for this device are not installed. (Code 28)

There are no compatible drivers for this device.


To find a driver for this device, click Update Driver.


When I update them automatically it says they are. and I cannot find the drivers manually at all since it is apparently "plug and play" which makes no sense to me. (This is an Insignia pci-e usb 3.0 host card, 2 ports. purchased from best buy, no disk or anything with it and their site just has the same manual. I have contacted them and am awaiting a response, and best buy didn't know anything).

Meanwhile, those usb ports do work, I have used several devices through them. Which only confuses me more. When I plug in my Blackmagic Intensity Shuttle, I can find it in my computer and get the following
This device cannot start. (Code 10)

{Operation Failed}
The requested operation was unsuccessful.

I can look at it, but nothing else works about it. I have checked for drivers or anything on the Blackmagic site but perhaps I'm blind cause all I have found is the "Desktop Video" software which I also tried and it won't see the Shuttle, nor will Media Express.

I sadly am not the MOST experienced, so any further guidance would be greatly appreciated. I've been trying to figure this out for about 3 days now.

Re: Blackmagic Intensity Shuttle recognized but not usable

PostPosted: Tue Dec 05, 2017 12:11 am
by Tony Rivera
Did you download and install Desktop Video 10.9.7?