Page 1 of 1

Side Handle Not Working

PostPosted: Sat Feb 03, 2018 12:43 am
by James McDonagh
Hello,

I have recently acquired an URSA Mini Pro. On said camera is a handle on the right hand side that I can grip. This grip comes with a host of buttons. One of these buttons is record. However, neither the record button not any of the other buttons on the grip seem to have any communication with the camera. Is there anyway I can fix this?

Many thanks,
James

Re: Side Handle Not Working

PostPosted: Sat Feb 03, 2018 12:57 am
by Denny Smith
Is the Lanc jumper cable plugged into both the grip and camera body? The kit came with this short cable with a straight and a 90-degree right angle TRS 1/8 Mini plugs on it, this cable connects to the back side of the grip, next to the Rosette Mount and plugs into the small 1/8 socket on the camera side. See the camera manual for details.
Cheers

Re: Side Handle Not Working

PostPosted: Sat Feb 03, 2018 12:59 am
by James McDonagh
Denny Smith wrote:Is the Lanc jumper cable plugged into both the grip and camera body? The kit came with this short cable with a straight and a 90-degree right angle TRS 1/8 Mini plugs on it, this cable connects to the back side of the grip, next to the Rosette Mount and plugs into the small 1/8 socket on the camera side. See the camera manual for details.
Cheers


Hi Denny,

No it's not. I'd imagine that's the problem. Many thanks for your help.

Re: Side Handle Not Working

PostPosted: Sat Feb 03, 2018 1:11 am
by Denny Smith
Yes, it needs the cable to get a connection between the camera dB grip handle.
Cheers.