Decklink Studio 4K Audio problems

Getting started with a Blackmagic product? Ask questions here about setup and installation.
  • Author
  • Message
Offline
User avatar

Doug Marsh

  • Posts: 62
  • Joined: Thu Mar 20, 2014 9:33 pm

Decklink Studio 4K Audio problems

PostWed Feb 21, 2018 6:12 am

Back in September of 2017, I ordered a Decklink Studio 4K (PCI) and for various reasons never got around to really using it until recently. I hope the card doesn't have an issue and require a swap but that might be necessary.

When capturing audio over HDMI along with video, it (eventually) will have audio break ups. It takes a while on the order of 10-30 minutes between each breakup, clears up then occurs again later.

I've used the capture software that comes from BMD (Media Express), I used OBS Studio and a custom compiled version of FFMPEG. All three have audio issues.

I searched a little and haven't found others talk about it much, figure I'd ask here first before contact support on possible exchange.

--Doug (dx9s)
Offline
User avatar

Doug Marsh

  • Posts: 62
  • Joined: Thu Mar 20, 2014 9:33 pm

Re: Decklink Studio 4K Audio problems

PostWed Feb 21, 2018 7:02 am

Video of short examples:


That was from one PC, out HDMI to splitter, one to a TV with output to headphones and other to Decklink. Never heard any scratching in the headphones from the TV's copy of the audio stream. But in testing and watching audio levels in OBS, I can see the audio peaking when it does that "glitching"

I've also recording video for an HOUR using Media Express to SSD and had it glitch several times (no HDMI splitter). I've also "passed" through the HDMI output on Decklink, but haven't had a chance to listen for and glitchy audio when capturing as I normally am not listening to that audio (but it is something to do, but doesn't change the fact that the card glitches when it should not happen).

Known facts: It will glitch (capture bad audio from HDMI source) given long enough time (30 minutes is usually enough to glitch once if not twice).

As I don't have SDI hardware I haven't been able to test SDI capture -- I hate to purchase SDI converter.. If it work with SDI input, then I should not have gotten the Decklink Studio 4K (which I got because it has HDMI input). **IF** should have gotten SDI input/output only and SDI converters, then it's way to late to exchange and get that. I already spent a sizable amount of money on this card.

--Doug (dx9s)
Offline
User avatar

Xtreemtec

  • Posts: 2843
  • Joined: Wed Jan 02, 2013 11:48 am
  • Location: The Netherlands

Re: Decklink Studio 4K Audio problems

PostWed Feb 21, 2018 9:48 am

What version of Desktop video are you running?
Have you tryed another version? There have been a few different issues in last 8 months with different versions working or not working on some cards for 100%.. ;)
Daniel Wittenaar .:: Xtreemtec Media Productions ::. -= www.xtreemtec.nl =-
4K OBV, ATEM TVS HD, 1M/E 4K, 2M/E Broadcast Studio 4K, Hyperdeck Studio Mini, SONY FS7 4K, Ursa Broadcast 4K
Offline
User avatar

Doug Marsh

  • Posts: 62
  • Joined: Thu Mar 20, 2014 9:33 pm

Re: Decklink Studio 4K Audio problems

PostWed Feb 21, 2018 4:08 pm

Desktop Videos? Not sure about that. I'll poke around and see if I can answer that in a update

I first notice this around October in Media Express (whatever was current at the time). There was a firmware update and did so using the firmware updating tool. Since then, I have tried other tools for capturing and experienced audio issues there.

I'll check for the latest installing software. Just curious if others have experienced same audio issues. If so then it might be a known issue and there is a solution (hopefully). If I am a one-off then that means it could be a bad card and contacting support for a swap.

--Doug (dx9s)
Offline
User avatar

Xtreemtec

  • Posts: 2843
  • Joined: Wed Jan 02, 2013 11:48 am
  • Location: The Netherlands

Re: Decklink Studio 4K Audio problems

PostWed Feb 21, 2018 4:11 pm

Since october there has been 3 new versions online.. 10.9.9 (only briefly) 10.9.10 & 10.9.11

Update 10.9.10 wrote:This update improves capture and playback compatibility for DeckLink and UltraStudio models including fixing an intermittent bug where audio samples are not captured, as well as improving compatibility with cameras.
:lol: :lol: So yes you might want to try an update ;)
Daniel Wittenaar .:: Xtreemtec Media Productions ::. -= www.xtreemtec.nl =-
4K OBV, ATEM TVS HD, 1M/E 4K, 2M/E Broadcast Studio 4K, Hyperdeck Studio Mini, SONY FS7 4K, Ursa Broadcast 4K
Offline
User avatar

Doug Marsh

  • Posts: 62
  • Joined: Thu Mar 20, 2014 9:33 pm

Re: Decklink Studio 4K Audio problems

PostWed Feb 21, 2018 4:21 pm

I think you are right, produced a report here:

Blackmagic Design System Report
Desktop Video 10.9.7
DeckLink Studio 4K
Video Input

HDMI


1080p59.94, 8-bit YUV 4:2:2
Reference

-


-
Video Output

SDI


1080p59.94, 8-bit YUV 4:2:2

HDMI


1080p59.94, 8-bit YUV 4:2:2

Component


-

Composite


-

S Video


-
Video Options

Capture 1080p as PsF


Disabled

Output 1080p as PsF


Disabled

4:4:4 RGB


Disabled
Device Interface

PCI


PCIe Status

Link Width


4x

Link Speed


5 Gbps
System Configuration
Machine Name

Operating System

Ubuntu 17.10 (4.13.0-36-generic)
Physical Memory

67456 MiB
Physical Processors

12


I will update and hope for the BEST!

--Doug (dx9s)
Offline
User avatar

Doug Marsh

  • Posts: 62
  • Joined: Thu Mar 20, 2014 9:33 pm

Re: Decklink Studio 4K Audio problems

PostWed Feb 21, 2018 7:18 pm

DL'ed both SDK and DEB file.. Installed newer packages, it compiled newer KO (kernel objects), etc...

I test recorded through OBS to disk for 35 minutes.. and no issues so far.. so I *THINK* (hope) that fixed it...

Blackmagic Design System Report
Desktop Video 10.9.11
DeckLink Studio 4K
Video Input
[...]


THANKS for the help Xtreemtec

--Doug (dx9s)
Offline
User avatar

Doug Marsh

  • Posts: 62
  • Joined: Thu Mar 20, 2014 9:33 pm

Re: Decklink Studio 4K Audio problems

PostSat Feb 24, 2018 6:15 pm

I spoke too soon.... Still have issue after updating software.

I am going to have to contact Backmagic Support.. This is a little irritating. Guess I will have to avoid using Decklink for anything audio capture related.



--Doug (dx9s)
Offline
User avatar

Doug Marsh

  • Posts: 62
  • Joined: Thu Mar 20, 2014 9:33 pm

Re: Decklink Studio 4K Audio problems

PostSat Feb 24, 2018 11:58 pm

I think I either have a bad card or this is a known issue.

* I switched to using the analogue audio input and while sending audio in (music at low level) from a music player, and switch to "analog input" in Desktop Video Setup. Trying to capture from SDI "audio" will probably yield the same issue.

* I can hear the audio back in the output from Decklink (HDMI monitor preview).

* Getting static glitchy audio in Media Express and OBS Studio, (don't have to record to disk can just monitor the HDMI preview output from the capture sources, HDMI video + analog audio).

To date: Can't use this card to capture HDMI audio or analog audio!

--Doug (dx9s)
Offline
User avatar

Xtreemtec

  • Posts: 2843
  • Joined: Wed Jan 02, 2013 11:48 am
  • Location: The Netherlands

Re: Decklink Studio 4K Audio problems

PostSun Feb 25, 2018 11:38 am

Shoot a ticket in to BMD Support.
Daniel Wittenaar .:: Xtreemtec Media Productions ::. -= www.xtreemtec.nl =-
4K OBV, ATEM TVS HD, 1M/E 4K, 2M/E Broadcast Studio 4K, Hyperdeck Studio Mini, SONY FS7 4K, Ursa Broadcast 4K

Return to Getting Started

Who is online

Users browsing this forum: Google [Bot] and 6 guests