Issues with Intensity Pro 4K and Ubuntu LTS 18.04

Getting started with a Blackmagic product? Ask questions here about setup and installation.
  • Author
  • Message
Offline

mazreds

  • Posts: 5
  • Joined: Thu May 03, 2018 12:51 pm
  • Real Name: Massimo Rossi

Issues with Intensity Pro 4K and Ubuntu LTS 18.04

PostThu May 03, 2018 12:59 pm

Hi,

yesterday I upgraded the Linux version of a machine on which is installed an "Intensity Pro 4K" and I encountered some problems.

I upgraded to the latest Ubuntu LTS release: "Ubuntu 18.04 Bionic Beaver". (currently not included in the list of tested versions). At the same time I updated the blackmagic drivers to version 10.9.12a3

The card is detected by the system but it isn't possible to start capturing from the HDMI input, probably due a kernel error during driver loading. In the dmesg logs I found the message:

"module license 'Proprietary' taints kernel - module verification failed: signature and/or required key missing - tainting kernel"

I know that I am using an untested version of OS, but this LTS will probably be the Ubuntu reference for the next 5 years ... so I would like to be able to run Intensity Pro on this version as well.

Does anyone have experiences on this? do you have any suggestions?


Here some info:

Linux version:
Ubuntu 18.04 Bionic Beaver
Linux 4.15.0-20-generic #21-Ubuntu SMP x86_64 GNU/Linux

Blackmagic softrware version:
Blackmagic_Desktop_Video_Linux_10.9.12

BlackmagicFirmwareUpdater status:
0: /dev/blackmagic/io0 [Intensity Pro 4K] 0xbf OK


lspci -v:
01:00.0 Multimedia video controller: Blackmagic Design Intensity Pro 4K
Subsystem: Blackmagic Design Intensity Pro 4K
Flags: bus master, fast devsel, latency 0, IRQ 28
Memory at f7c00000 (64-bit, non-prefetchable) [size=1M]
Capabilities: <access denied>
Kernel driver in use: blackmagic-io
Kernel modules: blackmagic_io

lsmod | grep blackmagic
blackmagic_io 1802240 2

dmesg:

[ 43.011942] blackmagic_io: loading out-of-tree module taints kernel.
[ 43.011949] blackmagic_io: module license 'Proprietary' taints kernel.
[ 43.012933] blackmagic_io: module verification failed: signature and/or required key missing - tainting kernel
[ 43.015832] BlackmagicIO: Driver version 10.9.12a3 loading
[ 43.023487] BlackmagicIO: Enabled device "Intensity Pro 4K" x4/5 Gbps (3c5a04b1,4b0100) FW Date: 08-16 17:41
[ 43.024927] BlackmagicIO: Intensity Pro 4K as blackmagic!io0 [0000:01:00.0]
[ 43.024931] BlackmagicIO: Initialised serial driver for blackmagic!io0


modinfo blackmagic_io:
filename: /lib/modules/4.15.0-20-generic/updates/dkms/blackmagic-io.ko
license: Proprietary
version: 10.9.12a3
description: Blackmagic Design BlackmagicIO driver
author: Blackmagic Design Inc. <developer@blackmagicdesign.com>
srcversion: 4C5C750A8CC70C21A8D1F01
alias: pci:v0000BDBDd0000A147sv*sd*bc*sc*i*
alias: pci:v0000BDBDd0000A144sv*sd*bc*sc*i*
alias: pci:v0000BDBDd0000A143sv*sd*bc*sc*i*
alias: pci:v0000BDBDd0000A142sv*sd*bc*sc*i*
alias: pci:v0000BDBDd0000A141sv*sd*bc*sc*i*
alias: pci:v0000BDBDd0000A140sv*sd*bc*sc*i*
alias: pci:v0000BDBDd0000A13Fsv*sd*bc*sc*i*
alias: pci:v0000BDBDd0000A13Esv*sd*bc*sc*i*
alias: pci:v0000BDBDd0000A13Dsv*sd*bc*sc*i*
alias: pci:v0000BDBDd0000A13Csv*sd*bc*sc*i*
alias: pci:v0000BDBDd0000A13Bsv*sd*bc*sc*i*
alias: pci:v0000BDBDd0000A139sv*sd*bc*sc*i*
alias: pci:v0000BDBDd0000A138sv*sd*bc*sc*i*
alias: pci:v0000BDBDd0000A137sv*sd*bc*sc*i*
alias: pci:v0000BDBDd0000A136sv*sd*bc*sc*i*
alias: pci:v0000BDBDd0000A132sv*sd*bc*sc*i*
alias: pci:v0000BDBDd0000A130sv*sd*bc*sc*i*
alias: pci:v0000BDBDd0000A12Esv*sd*bc*sc*i*
alias: pci:v0000BDBDd0000A12Dsv*sd*bc*sc*i*
depends:
retpoline: Y
name: blackmagic_io
vermagic: 4.15.0-20-generic SMP mod_unload
parm: irq:The default irq type: msi, legacy (charp)
parm: tty:Serial TTY driver is enabled (bool)
Offline

jakarr

  • Posts: 1
  • Joined: Wed May 09, 2018 4:57 pm
  • Real Name: Jake Harr

Re: Issues with Intensity Pro 4K and Ubuntu LTS 18.04

PostWed May 09, 2018 5:10 pm

The tainted kernel message isn't necessarily an error. It seems to be used mostly for licensing and kernel debugging:

https://unix.stackexchange.com/question ... ted-kernel

The nvidia drivers have always caused this message to appear for me on 16.04. Oddly enough, the blackmagic drivers have not.

Do you have any other problems on 18.04? I actually came here to check if people are having trouble before I do my own upgrade.

EDIT:
I am also using older drivers. So the current ones could very well cause the same message on 16.04.
Offline

mazreds

  • Posts: 5
  • Joined: Thu May 03, 2018 12:51 pm
  • Real Name: Massimo Rossi

Re: Issues with Intensity Pro 4K and Ubuntu LTS 18.04

PostThu May 10, 2018 3:24 pm

Hi, thank you so much for the suggestion. The pc has a motherboard with integrated intel 915 video card that is properly detected and configured.

from dmesg:

[ 3.109383] fb: switching to inteldrmfb from VESA VGA
[ 3.109399] Console: switching to colour dummy device 80x25
[ 3.110007] [drm] Replacing VGA console driver
[ 3.116073] [drm] Supports vblank timestamp caching Rev 2 (21.10.2013).
[ 3.116074] [drm] Driver supports precise vblank timestamp query.
[ 3.118449] i915 0000:00:02.0: vgaarb: changed VGA decodes: olddecodes=io+mem,decodes=io+mem:owns=io+mem
[ 3.123456] [drm] Initialized i915 1.6.0 20171023 for 0000:00:02.0 on minor 0
[ 3.123928] ACPI: Video Device [GFX0] (multi-head: yes rom: no post: no)
[ 3.124159] input: Video Bus as /devices/LNXSYSTM:00/LNXSYBUS:00/PNP0A08:00/LNXVIDEO:00/input/input6
[ 3.232232] fbcon: inteldrmfb (fb0) is primary device
[ 3.232276] Console: switching to colour frame buffer device 160x64
[ 3.232294] i915 0000:00:02.0: fb0: inteldrmfb frame buffer device


I do not find any other anomalies.

Blackmagic device is active, in Desktop Video Setup the hdmi signal presence is detected but in Media Express nothing can be captured. Only a black screen...

Your observations make me think that there may be a problem related to MESA or in general to the behavior with openCL ... Currently is installed

OpenGL version string: 3.0 Mesa 18.0.0-rc5
LibOpenCL version: /usr/lib/x86_64-linux-gnu/libOpenCL.so.1.0.0


I will try to investigate about it ....
Offline

willycat

  • Posts: 5
  • Joined: Wed May 02, 2018 1:14 pm
  • Real Name: wilfried catteau

Re: Issues with Intensity Pro 4K and Ubuntu LTS 18.04

PostFri May 11, 2018 6:49 pm

Hi,

did you install the drivers again after upgrading your ubuntu (a part need to be recompiled) ?

Did you try another software like OBS Studio to see if it works or not ??

Willy.
Offline

mazreds

  • Posts: 5
  • Joined: Thu May 03, 2018 12:51 pm
  • Real Name: Massimo Rossi

Re: Issues with Intensity Pro 4K and Ubuntu LTS 18.04

PostThu May 17, 2018 12:39 pm

Hi,

yes, after the upgrade I reinstalled the drivers and tried also with other software including obs.

Since Yesterday came out the new version of the driver (10.10), I also tried it but the result is the same.

The card driver is loaded with the message "tainting kernel".

In Desktop Video the HDMI source is detected, but in the various software (Media Express, OBS, ffmpeg, ...) I cannot acquire any image, only a black screen.

Info in Blackmagic Design System Report are:

Desktop Video 10.10
Intensity Pro 4K
Video Input HDMI 1080i50, 8-bit YUV 4:2:2
Video Output HDMI 1080i50, 8-bit BGRA Component 1080i50, 8-bit BGRA Composite - S Video
Device Interface PCI PCIe Status
Link Width 4x
Link Speed 2.5 Gbps
Operating System Ubuntu 18.04 LTS (4.15.0-20-generic)
Physical Memory 3012 MiB Physical Processors 2

To remove any doubt, I also tried to reinstall the old driver 10.9.10 (the one that worked with the previous version of Linux, the ubuntu 16.04 LTS), but the result is the same.

So I'm afraid that the problem is related to an incompatibility of the Ubuntu 18.04 LTS kernel (4.15.0-20-generic) with the blackmagic drivers.

I tried to contact the support but I was told that this version of linux is not among those tested ones and at the moment no driver version for this LTS is currently planned .....

So, how can I work it out ?
Thank you.

Return to Getting Started

Who is online

Users browsing this forum: Bing [Bot] and 4 guests