UM46 - Sigma 18-35 / 50-100 NO IRIS CONTROL

The place for questions about shooting with Blackmagic Cameras.
  • Author
  • Message
Offline
User avatar

mauro.fluehler

  • Posts: 2
  • Joined: Wed Oct 25, 2017 8:45 pm

UM46 - Sigma 18-35 / 50-100 NO IRIS CONTROL

PostWed Oct 25, 2017 8:50 pm

Hello people, I have a problem with the IRIS control to my Sigma 18-35 and Sigma 50-100. Sometimes my Ursa Mini 4.6k loses control to the iris. I have no idea why.. Ursa mini and the lenses have the latest firmware. Has anyone an idea why that could be? Thanks..!
Mauro Flühler | film student | switzerland
Offline
User avatar

Robert Niessner

  • Posts: 1768
  • Joined: Thu Feb 21, 2013 9:51 am
  • Location: Graz, Austria

Re: UM46 - Sigma 18-35 / 50-100 NO IRIS CONTROL

PostWed Oct 25, 2017 11:07 pm

If memory serves me right, there was a problem with older Sigma 18-35 lenses, which got solved by a firmware update FOR THE LENS (not the camera). For updating Sigma lenses you need a dock from Sigma.

I have the UM46k with firmware 4.2 and a Sigma 18-35 (bought in late 2016). No problems with the iris control so far.
Robert Niessner
LAUFBILDkommission
Graz / Austria
---------------------------------------------------------------------
Blackmagic Camera Blog (German):
http://laufbildkommission.wordpress.com

Read the blog in English via Google Translate:
http://tinyurl.com/pjf6a3m
Offline
User avatar

Robert Niessner

  • Posts: 1768
  • Joined: Thu Feb 21, 2013 9:51 am
  • Location: Graz, Austria

Re: UM46 - Sigma 18-35 / 50-100 NO IRIS CONTROL

PostWed Oct 25, 2017 11:18 pm

Yep, found the lens firmware problem here:
viewtopic.php?f=2&t=50972&start=100#p294704
Robert Niessner
LAUFBILDkommission
Graz / Austria
---------------------------------------------------------------------
Blackmagic Camera Blog (German):
http://laufbildkommission.wordpress.com

Read the blog in English via Google Translate:
http://tinyurl.com/pjf6a3m
Offline
User avatar

mauro.fluehler

  • Posts: 2
  • Joined: Wed Oct 25, 2017 8:45 pm

Re: UM46 - Sigma 18-35 / 50-100 NO IRIS CONTROL

PostThu Oct 26, 2017 8:22 am

Thanks for your reply. Already checked the firmware of the lenses. So, this can't be the issue..

Anyone else has an idea?
Offline

Jesse Widener

  • Posts: 8
  • Joined: Tue Jun 13, 2017 2:29 am

Re: UM46 - Sigma 18-35 / 50-100 NO IRIS CONTROL

PostMon Nov 13, 2017 6:17 am

I have this same problem and would love a solution. Lens firmware is also up to date for me. In addition to losing iris control, the iris occasionally "jumps" causing a split second burst in exposure which ruins a shot. That is the greatest concern.
Offline

Ryan Payne

  • Posts: 193
  • Joined: Sat Apr 15, 2017 6:48 am

Re: UM46 - Sigma 18-35 / 50-100 NO IRIS CONTROL

PostMon Nov 13, 2017 11:33 am

Maybe it's something to do with how the mount is connecting to the lens.

I know that if I don't have my micro mounted bmpcc speed booster locked down to the cage I can sometimes cause the connection to wiggle and I assume this grinds the pins back n forth. This causes the lens to freak out, change Iris back and forth quickly or stops responding at all. If it happens I need to power down the camera and as such the speed booster down then back on and it's fine. I've yet to have it happen if the booster is bolted down to the support foot. The speed booster sits quite tightly when mounted. Lens to booster has a small wiggle but I haven't managed to force this to happen when the booster is bolted.

This only happened when using the old nifty fifty Canon lens with it's poor plastic ef mount.
Offline

Dan Smith

  • Posts: 9
  • Joined: Mon Oct 16, 2017 11:55 am

Re: UM46 - Sigma 18-35 / 50-100 NO IRIS CONTROL

PostWed Jul 11, 2018 10:49 am

Jesse Widener wrote:I have this same problem and would love a solution. Lens firmware is also up to date for me. In addition to losing iris control, the iris occasionally "jumps" causing a split second burst in exposure which ruins a shot. That is the greatest concern.


Hi all, just wondering if anyone ever got a solution to this? Having the exact same issue. Such and awesome lens but just doesnt want to work on my UM46 :(

Thanks
Offline

Denny Smith

  • Posts: 9510
  • Joined: Thu Aug 01, 2013 4:19 pm
  • Location: USA, Northern Calif.

Re: UM46 - Sigma 18-35 / 50-100 NO IRIS CONTROL

PostWed Jul 11, 2018 5:03 pm

Dan, as previously mentioned in your other posts about this, you need to update the lens FW, this should fix the issue.
Cheers
Denny Smith
SHA Productions
Offline

Ben Kaiser

  • Posts: 23
  • Joined: Thu Jul 17, 2014 2:25 pm

Re: UM46 - Sigma 18-35 / 50-100 NO IRIS CONTROL

PostThu Oct 18, 2018 5:06 pm

Hi guys,

I have encountered the same problem (no iris control/jumps) with my two Canon photo lenses:
EF 50mm f1.2 L & EF 70-200mm f2.8 II :cry:
Firmware on the UM4.6K is v4.8

Even if I use Xeen cine lenses (with no electronics inside), the camera shows randomly a f-stop number on the screen!! How is this possible?

Are there any firmware updates available for the canon lenses?

cheers, Ben
cinematographer & avid editor
Offline

Tim Schumann

Blackmagic Design

  • Posts: 347
  • Joined: Tue Oct 23, 2012 6:21 am

Re: UM46 - Sigma 18-35 / 50-100 NO IRIS CONTROL

PostThu Oct 18, 2018 7:16 pm

If you are having these lens issues then you should check your mount.
Are the pins damaged at all?

Those Sigma and Canon lenses are definitely supported on URSA Mini and Mini Pro software and have been for a long time.
Offline

Ben Kaiser

  • Posts: 23
  • Joined: Thu Jul 17, 2014 2:25 pm

Re: UM46 - Sigma 18-35 / 50-100 NO IRIS CONTROL

PostFri Oct 19, 2018 7:07 pm

Tim Schumann wrote:If you are having these lens issues then you should check your mount.
Are the pins damaged at all?

Those Sigma and Canon lenses are definitely supported on URSA Mini and Mini Pro software and have been for a long time.



Hi Tim, the pins seem to be fine....
Attachments
2BC11991-B490-421C-9B2A-76E772330E0E.jpeg
2BC11991-B490-421C-9B2A-76E772330E0E.jpeg (304.26 KiB) Viewed 199 times
cinematographer & avid editor

Return to Cinematography

Who is online

Users browsing this forum: Andrew Lucas, David Hutchinson, Reynold Dodson and 19 guests