"No Card" Issue BMPCC

The place for questions about shooting with Blackmagic Cameras.
  • Author
  • Message


  • Posts: 1
  • Joined: Mon Oct 08, 2018 5:36 am
  • Real Name: Matthew Jackson

"No Card" Issue BMPCC

PostMon Oct 08, 2018 5:44 am

Hi All,
I have now three 128 GB Sandisk Extreme Pro XC 95 MB/s cards that give me the "No Card" message when placed in my BMPCC. I have four identical cards that I use (two of which worked right out of the box.). I have tried what seems like EVERYTHING (disk utility in Mac, partitions and command prompt in Windows, formatting in other cameras) to get them formatted for use in the BMPCC. They format just fine in other cameras, mixers, and on both Mac and PC but still read “No Card” in my BMPCC. They work in every other computer/camera/drive I try them in (including my sound mixer's mixer), but will not read in my BMPCC, and I'm unable to format them in camera. Please advise. Many thanks in advance.
Last edited by mtjackson on Tue Oct 09, 2018 2:19 pm, edited 1 time in total.

Denny Smith

  • Posts: 9120
  • Joined: Thu Aug 01, 2013 4:19 pm
  • Location: USA, Northern Calif.

Re: "No Card" Issue BMPCC

PostMon Oct 08, 2018 5:14 pm

Two cards work, and two ddn’t, sounds like the two thst are not working are either defective or counterfeit.
I use these cards in my original Pocket Camera, and the Micro Cinema camera without any issues.
Denny Smith
SHA Productions

David Regenthal

  • Posts: 126
  • Joined: Sat Aug 25, 2012 7:15 am

Re: "No Card" Issue BMPCC

PostMon Oct 08, 2018 9:02 pm

Are you able to format (computer+card reader) them "out" of camera, then try them?
User avatar

Robert Baker

  • Posts: 24
  • Joined: Mon Jul 11, 2016 4:09 pm

Re: "No Card" Issue BMPCC

PostMon Oct 08, 2018 10:05 pm

I had this issue with a Video Assist 4K. Cards that would work fine in other devices or cameras would just not be recognized in the Video Assist. Had to wait for a firmware update to fix the problem.
Small List of my current toolset:

BMD Ursa Mini Pro - JVC GY-LS300 - JVC HM170UA - Canon 80D - Canon 60D
DaVinci Resolve Studio 14 - Sony Vegas Pro 13 - Adobe Premiere Pro CC 2017
Sony Soundforge 11 - Izotope RX6 Elements - Izotope Neutron Elements


  • Posts: 1
  • Joined: Thu Oct 11, 2018 5:22 pm
  • Real Name: Michael Anderson

Re: "No Card" Issue BMPCC

PostThu Oct 11, 2018 5:29 pm

OP, any luck with this? I've been having the same issue in the past few days. From Amazon, ordered a Sandisk Extreme Pro 128GB UHS-I V30 for my BMPCC, and it said no card. Formatted as both HFS and ExFAT in Mac, formatted as both ExFAT and NTFS in Windows. The BMPCC still wouldn't see it. Returned it and ordered another one. The second one is doing the same thing. These were the "Amazon's Choice" cards, so I'm guessing they trust the retailer (same retailer both times), as Amazon wasn't selling it themselves, just distributing.

They work fine in other cameras and computers.

EDIT: I should add that both cards looked 100% legit, based on comparison photos of real/fake cards. I also tested the 2nd one with H2testw, and it came out clean. I doubt I got two defective cards (that work in every other device) in a row from an Amazon's Choice retailer, and am wondering whether:

1) Sandisk changed the firmware on their recent UHS-I cards?
2) If so, can Blackmagic pretty-please make a tiny firmware update for the BMPCC to deal with this, otherwise, owners might be out of luck going forward.
Last edited by burningarms on Fri Oct 12, 2018 4:51 pm, edited 1 time in total.


  • Posts: 7
  • Joined: Mon Oct 01, 2018 4:48 pm
  • Real Name: William Randall

Re: "No Card" Issue BMPCC

PostThu Oct 11, 2018 8:15 pm

I'm having "No Card" behavior depending on the camera's mood. Sometimes it can detect the SSD, sometimes not. Same with the cheap-old SD cards I've used.

I'll try to figure out if it's a pattern. It has detected everything I've put in it, but not always.

Return to Cinematography

Who is online

Users browsing this forum: Bing [Bot], Marco Raboy and 31 guests