Italics issue in subtitles Resolve 15.0.0.86

Get answers to your questions about color grading, editing and finishing with DaVinci Resolve.
  • Author
  • Message
Offline

Pedro Nunez

  • Posts: 12
  • Joined: Tue May 09, 2017 8:02 am

Italics issue in subtitles Resolve 15.0.0.86

PostWed Aug 29, 2018 1:52 pm

We have been testing the use of italics (importing a *.srt file in a subtitle track) and here is a list of what what does not work:

1. In a subtitle with 2 lines in italics, just the first line is shown in italics, the second line comes normal. Example:

Input Text:
This 2 lines should
be in italics.

Output in Resolve:
This 2 lines should
be in italics.

2. In a subtitle with 2 lines, where the second line is in italics, the italics are not shown at all. Example:

Input text:
This first line is not in italics,
this line should be in italics.

Output in Resolve:
This first line is not in italics,
this line should be in italics.

3. In a subtitle with 2 lines, with one word in italics in the second line. Example:

Input text:
This line is normal,
just this word is in italics.

Output in Resolve:
This line is normal,
just this word is in italics.

4. When we try to export a *.srt file from the subtitle track, Resolve crashes. It does not matter if the subtitle track has italics or not, it crushes anyway.

As extra information: tests were made in a computer running on Windows 10.
Offline

Pedro Nunez

  • Posts: 12
  • Joined: Tue May 09, 2017 8:02 am

Re: Italics issue in subtitles Resolve 15.0.0.86

PostWed Aug 29, 2018 2:27 pm

Update: we did the same test on a Mac with OS Sierra 10.12.6. , it has the same problems as in Windows, but there we were able to export an srt file. The output srt file is almost the same as the input srt file, where we found a difference in the 2 lines subtitles where both lines are in italics. Example:

Original srt:

both lines
are in italics


Output srt:

both lines
are in italics
Offline

Pedro Nunez

  • Posts: 12
  • Joined: Tue May 09, 2017 8:02 am

Re: Italics issue in subtitles Resolve 15.0.0.86

PostMon Sep 24, 2018 2:20 pm

We have tested now the importing of *.srt files in Resolve 15.1.0.25, and the problem of italics not appearing in the second subtitle line is still there. Would be good if this bug is fixed soon, otherwise we cannot use the subtitle feature in our projects.
Offline

Vit Reiter

  • Posts: 107
  • Joined: Mon Sep 04, 2017 5:36 pm

Re: Italics issue in subtitles Resolve 15.0.0.86

PostMon Sep 24, 2018 3:45 pm

DaVinci needs html tags on both lines:

Right:
<i>Hello,</i>
<i>Guys</i>

Bad:
<i>Hello,
Guys</i>
DaVinci Resolve 15.1.2 Studio, Fusion 9.0.2 Studio
macOS High Sierra 10.13.6
Mac Pro 2013,
AMD FirePro D700 Graphics, 64 GB RAM

Film Editor, Colorist, VFX and Motion Graphic Designer, DIT, Encoding technician
linkedin.com/in/vít-reiter-film-editor
Offline

Tom Early

  • Posts: 557
  • Joined: Wed Jul 17, 2013 11:01 am

Re: Italics issue in subtitles Resolve 15.0.0.86

PostMon Sep 24, 2018 6:31 pm

Vit Reiter wrote:DaVinci needs html tags on both lines:

Right:
<i>Hello,</i>
<i>Guys</i>

Bad:
<i>Hello,
Guys</i>


is this how other software do subtitles? Resolve exported an SRT like this but I'm not sure other packages will.
edit: Title Exchange Pro does so I imagine it's standard.

Also, Resolve will only reliably deal with italics/bold formatting if done at the clip level. It won't output html tags for formatting applied in the Track Style tab.

It won't auto-switch to Caption Style unless the html tagging is on the first line either, so those italics applied to just the second line or a single word do work, you just have to switch to Caption Style manually.
MBP2016, MacOS 10.14, 2.9 GHz Intel Core i7, 16 GB 2133 MHz LPDDR3,
Radeon Pro 460 4096 MB, Resolve Studio 15.1.1.005
Offline

Pedro Nunez

  • Posts: 12
  • Joined: Tue May 09, 2017 8:02 am

Re: Italics issue in subtitles Resolve 15.0.0.86

PostTue Sep 25, 2018 8:01 am

Vit Reiter wrote:DaVinci needs html tags on both lines:

Right:
<i>Hello,</i>
<i>Guys</i>

Bad:
<i>Hello,
Guys</i>


Thanks for your reply, sadly neither shows italics in the 2nd line.
Offline

Pedro Nunez

  • Posts: 12
  • Joined: Tue May 09, 2017 8:02 am

Re: Italics issue in subtitles Resolve 15.0.0.86

PostTue Sep 25, 2018 8:18 am

Tom Early wrote:
Vit Reiter wrote:DaVinci needs html tags on both lines:

Right:
<i>Hello,</i>
<i>Guys</i>

Bad:
<i>Hello,
Guys</i>


is this how other software do subtitles? Resolve exported an SRT like this but I'm not sure other packages will.
edit: Title Exchange Pro does so I imagine it's standard.

Also, Resolve will only reliably deal with italics/bold formatting if done at the clip level. It won't output html tags for formatting applied in the Track Style tab.

It won't auto-switch to Caption Style unless the html tagging is on the first line either, so those italics applied to just the second line or a single word do work, you just have to switch to Caption Style manually.


Working manually at the clip level for subtitles is totally a no go for us, we are a post production company, we get a finished subtitle file with usually somewhere between 1000-2000 subtitles, the work around you suggest is viable just if you have a few subtitles.
What it is needed from Resolve is that the italics are imported correctly from the beginning, and not lost either if we change the Track style after importing the *.srt file.
Offline

Willian Aleman

  • Posts: 290
  • Joined: Thu Aug 23, 2012 10:08 pm
  • Location: NYC, USA

Re: Italics issue in subtitles Resolve 15.0.0.86

PostTue Sep 25, 2018 10:27 am

Pedro Nunez wrote:
Tom Early wrote:
Vit Reiter wrote:DaVinci needs html tags on both lines:

Right:
<i>Hello,</i>
<i>Guys</i>

Bad:
<i>Hello,
Guys</i>


is this how other software do subtitles? Resolve exported an SRT like this but I'm not sure other packages will.
edit: Title Exchange Pro does so I imagine it's standard.

Also, Resolve will only reliably deal with italics/bold formatting if done at the clip level. It won't output html tags for formatting applied in the Track Style tab.

Accordingly, with SRT-Subtitles, the way italics is formatted in Resolve is more part of SRT specifications than a fault. Whatever the italics appear in one line only is another issue.

"Currently almost all subtitle displayers support HTML's <i>, <b>, <u> & <font> tags
<b>text</b>: put text in boldface
<i>text</i>: put text in italics
<u>text</u>: underline text
<font color="#00ff00">text</font>: apply green color formatting to the text (you can use the font tag only to change color)"

https://srt-subtitles.com
Willian Aleman
Digital Imaging Technician
New York City
USA
Always willing to travel
Offline

Pedro Nunez

  • Posts: 12
  • Joined: Tue May 09, 2017 8:02 am

Re: Italics issue in subtitles Resolve 15.0.0.86

PostWed Oct 03, 2018 10:13 am

[quote="Vit Reiter"]DaVinci needs html tags on both lines:

Right:
<i>Hello,</i>
<i>Guys</i>

Bad:
<i>Hello,
Guys</i>[/quote]

I was trying again to find a way to show correctly the italics in the subtitles, and the "right" way to tag the italics works... more or less... Here what I found out:
1. If you use the "Use track style" mode:
- If you use the tagging in both the first and second lines shows italics in both of them.
- If you tag italics just in the 2nd line (the entire line or just one word) it does not show italics at all.
- If you change the caption style to something different than Open Sans, ALL the italics are GONE !!!
2. Then, if you uncheck the "Use track style":
- All the italics in the second line are shown correctly.
- If you change the font family to something different from the default, ALL the italics disappear...

Somebody else have found a work around to this issue?

(Tested in Resolve 15.1.1.005)
Offline

Pedro Nunez

  • Posts: 12
  • Joined: Tue May 09, 2017 8:02 am

Re: Italics issue in subtitles Resolve 15.0.0.86

PostThu Oct 04, 2018 10:42 am

Vit Reiter wrote:DaVinci needs html tags on both lines:

Right:
<i>Hello,</i>
<i>Guys</i>

Bad:
<i>Hello,
Guys</i>


I was wondering if is it really an SRT default. I tested it giving the start of italics tag "<i>" at the beginning of the first line and the end of italics "</i>" at the end of the second line.

example:
<i>Hello
world</i>

I imported the *.srt file in Annotation Edit, Belle Nuit Subtitler and Subtitle Edit. ALL of them interpreted it correctly as a subtitle with both lines in italics.

Then I exported it as *.srt to see if the keeps the format or not. Belle Nuit and Subtitle Edit keeps exactly the same format, that is with the tag at the beginning of first line and the end of the second line. Annotation edit changes it, adding the the italics tags at the beginning and at the end of each line.

Return to DaVinci Resolve

Who is online

Users browsing this forum: Google [Bot], Google Feedfetcher, Jack Swart and 20 guests