Cannot enable Brainworx plugins in Resolve

Get answers to your questions about color grading, editing and finishing with DaVinci Resolve.
  • Author
  • Message
Offline

Sean Meacher

  • Posts: 5
  • Joined: Sat May 03, 2014 10:50 am

Cannot enable Brainworx plugins in Resolve

PostThu Nov 08, 2018 7:51 pm

So I've got a video that needs some audio repair work and noticed that none of the Brainworx/Plugin Alliance plugins I have are showing up in the list. According to the plugin window (screenshot attached), they are all shown as "working" (VST2.4 editions installed), but I can't actually enable them.
All the others I have (Slate, Waves, etc) work fine.
What can I do?
Obviously, I can fix the audio in another host package, but I'd rather not have to.

Resolve is currently 15.1.2.008 but I've got the installer for the 15.0 version as well (and likely v14 somewhere).

Thanks,
Sean
Attachments
Screenshot 2018-11-08 19.39.17.png
Plugin window screenshot
Screenshot 2018-11-08 19.39.17.png (35.02 KiB) Viewed 46 times
Win10 x64 / i7 / 16G / 4xSSD RAID, 4xSATA RAID / GTX980Ti / 3x24" Iiyama screens / Mackie MCU / Tangent Ripple / + Audio Studio
Offline

Sean Meacher

  • Posts: 5
  • Joined: Sat May 03, 2014 10:50 am

Re: Cannot enable Brainworx plugins in Resolve

PostThu Nov 08, 2018 8:25 pm

After a bit of poking around in
C:\ProgramData\Blackmagic Design\DaVinci Resolve\Preferences\Fairlight\Effects\FXConfiguration.xml
I've discovered it may be that they may not be reporting their supported channel configuration correctly. Or it's not being read.
(I first discovered from that file that the VST3 editions were also being scanned in the VSTPlugins folder, so I moved those somewhere else, then I removed the xml file to force a re-scan of the plugins)

For example, the De-Verb I edited the XML to set it to enabled and (channel?) width of "2", which made it show up in Resolve plugins list, but I still can't add it to a channel.
The Free Ranger entry below that is what all of these plugins show up as once they are scanned, meaning a width of -1, which I'm guessing is invalid(?)

<Effect>
<Path>C:/Program Files/VstPlugins/VST2/Plugin Alliance/SPL De-Verb.dll</Path>
<FileTime>Wed May 9 00:58:04 2018</FileTime>
<Name>SPL De-Verb</Name>
<ID>SPL De-Verb</ID>
<Category>0</Category>
<Width>2</Width>
<Enabled>1</Enabled>
<Working>1</Working>
</Effect>
<Effect>
<Path>C:/Program Files/VstPlugins/VST2/Plugin Alliance/SPL Free Ranger.dll</Path>
<FileTime>Thu Nov 8 01:05:04 2018</FileTime>
<Name>SPL Free Ranger</Name>
<ID>SPL Free Ranger</ID>
<Category>0</Category>
<Width>-1</Width>
<Enabled>0</Enabled>
<Working>1</Working>
</Effect>
Win10 x64 / i7 / 16G / 4xSSD RAID, 4xSATA RAID / GTX980Ti / 3x24" Iiyama screens / Mackie MCU / Tangent Ripple / + Audio Studio

Return to DaVinci Resolve

Who is online

Users browsing this forum: Jack Kim, Majestic-12 [Bot], Pedro Dias, Ross Wood, Scott Heysen and 18 guests