Problem with PNG and Text +

Get answers to your questions about color grading, editing and finishing with DaVinci Resolve.
  • Author
  • Message
Offline

MacMillan1525

  • Posts: 2
  • Joined: Thu Jan 23, 2020 11:28 am
  • Location: Russia
  • Real Name: Andrey Komelin

Problem with PNG and Text +

PostThu Jan 23, 2020 11:49 am

Hello everybody!
There was a problem displaying PNG-images and animated text.
The screenshots show that the text and image of the Instagram have either low resolution or no smoothing. The resolution of the PNG image is 1600 * 1600 pixels. Timeline Resolution 1920 * 1080. The text next to it is the "Title Center Reveal" effect. If I increase the size of the text more, then the resolution is still poor, it does not look smooth.
How is this possible to fix? Thanks so much for the answers.
Текст.PNG
Текст.PNG (21.54 KiB) Viewed 139 times

Error.mxf_snapshot_00.01.447.jpg
Error.mxf_snapshot_00.01.447.jpg (131.3 KiB) Viewed 139 times
Offline

Shrinivas Ramani

Blackmagic Design

  • Posts: 688
  • Joined: Wed Sep 20, 2017 10:19 am

Re: Problem with PNG and Text +

PostFri Jan 24, 2020 4:02 am

Hi

I would like to understand more about your issue, so I did a few tests:

With a 4096x3112 project, Test image:1600x1600 and with different title types on a 5K iMac 2015 and a Windows machine with an Nvidia graphics card and a 4K screen.

The tests are simple to setup:
• I start with an Untitled project, add in text, add in icon, scale each to different sizes.
• I vary color and/or add background to check for isolated issues.
An example project is attached. Test image from web search (https://ya-webdesign.com/explore/open-source-icons-png/)

The following tests work as expected without jagged edges, or quality issues on both platforms:
• Stepping through and playing back in fullscreen (Control-/Command-F without any special hardware)
• Grabbing stills and cehcking for issues.
• Rendering out MXF clips (using default settings for Op1A and OP Atom)
• Viewing that rendered file in full-screen.
• Overlaying the render on the original and using composite modes to check for differences.
• Using the color picker.

So, now for my queries:
• What's your platform? OS, graphics card, display hardware, monitor resolution etc. Do you have any DPI scaling?
• Do you see this issue in previews or do they appear on rendered clips?
• What method did you use to get the snapshot?
• Can you give us links to source samples for the icons (please be aware of copyright). If you see issues with renders, please include a small render sample as well.
Attachments
title-raster-test.drp.zip
(28.23 KiB) Downloaded 3 times
Offline
User avatar

iddos-l

  • Posts: 264
  • Joined: Sat Mar 30, 2019 7:55 pm
  • Real Name: iddo lahman

Re: Problem with PNG and Text +

PostFri Jan 24, 2020 7:30 am

Also, what are the project settings?
Is it progressive like 25P or 24P?
Offline

elBrandzo

  • Posts: 2
  • Joined: Mon Jan 13, 2020 11:44 am
  • Real Name: Linus Brandes

Re: Problem with PNG and Text +

PostFri Jan 24, 2020 8:48 am

Hi Shrinivas,

I am not sure if this issue has been further explored, but I am still dealing with the same/similar problem.
The Jagged edges though I could refine by changing the output settings to high Quality - so I think this solved my issue.

BUT

what I cannot get a grip on is the fact that imported graphics (logos etc) with Alpha are having a black thin border when placed over a background AND WHEN APPLYING A DROP SHADOW in edit as well as in fusion.

No matter which Clip Attributes Settings, I cannot get a clean alpha channel.
Do you have any Idea how to deal with that?

please have a look at my attached example:
Attachments
dirtyAlphaEdge.PNG
Titletool=clean alpha vs. png=dirty alpha
dirtyAlphaEdge.PNG (187.5 KiB) Viewed 68 times
Offline

MacMillan1525

  • Posts: 2
  • Joined: Thu Jan 23, 2020 11:28 am
  • Location: Russia
  • Real Name: Andrey Komelin

Re: Problem with PNG and Text +

PostFri Jan 24, 2020 12:44 pm

Thanks for answers!
I started your project, and got a normal result, but because of the big resolution. In my working project (1080p24), I also had to use 4k output to get rid of low-quality text and logo. The result was much better. But now the main problem is the resolution of 1080p.
I created a zip archive in which there is a test project with text and PNG. I also put the original Instagram icon in the archive. Video render in MXF Op1A. The video opened in the MPC-HC x64 player, there a full-screen screenshot was made by built-in tools. I received poor quality text and PNG images, regardless of size. Interestingly, in Davinci, when viewing a project in full screen (Ctrl + F), all text and images are smoothed and look good. But when viewing in normal mode, I see a loss of quality and resolution.
My computer:
Intel Core i5 3570K @ 4100 MHz, 32 Gb DDR3 @ 1600 MHz, Nvidia GTX1070. Monitor DELL U2312HM. DPI scaling is not.
Windows 10 1909, Davinci Resolve Studio 16.1.2.026, Nvidia Driver 441.87
The project is in 24p.
Test.zip
(938.12 KiB) Downloaded 2 times

MXF file link - - https://drive.google.com/file/d/1Cg44FQ ... sp=sharing

Return to DaVinci Resolve

Who is online

Users browsing this forum: Brad Hurley, Geoff Win, isticism, MyName, tyshanklin, xunile and 93 guests