Page 1 of 1

Compositing showing edge lines

PostPosted: Tue Aug 11, 2015 2:54 am
by Elliott Balsley
I want to do a simple split-screen composite in Resolve (v11) to hide an actor issue. I put a shot on track V2 above an identical shot on track V1, and crop the top clip to make a split screen. Now I am seeing a horizontal line across the frame along the edge of the top clip. How to fix this?

The clips are 6K R3D in an HD timeline, and I'm using full debayer. The problem is visible in the viewer and also in rendered QuickTime output. I thought maybe it's related to anti-aliasing, but I've tried aliasing both on and off in Image Scaling settings, and it makes no difference. I also tried changing the Resize Filter from sharper to smoother

Re: Compositing showing edge lines

PostPosted: Tue Aug 11, 2015 8:01 am
by Eddy Juillerat
Did you have an alpha mask with blur contour? Maybe for some reason Resolve bring the blurring around the frame. Or a power window position or size?
It happened to me once, when I was enhancing the contrast in midtones of some part of the image with qualifier, suddenly the frame shows a little white border.
Maybe if you show a capture of your nodes tree, we can see what's going on.

Re: Compositing showing edge lines

PostPosted: Tue Aug 11, 2015 6:55 pm
by Elliott Balsley
This happens with zero clip and track nodes. No alpha channels — the only thing I set is the crop on clip 2.

Re: Compositing showing edge lines

PostPosted: Wed Aug 12, 2015 7:13 pm
by Kelly Reese
I've seen the same thing in R11. It seems like a limitation of the software.

Re: Compositing showing edge lines

PostPosted: Wed Aug 12, 2015 7:17 pm
by Patrick Tauscher
Looks like a premult / unpremult problem.

Re: Compositing showing edge lines

PostPosted: Wed Aug 12, 2015 9:43 pm
by Dmitry Kitsov BMD
Hello, Elliot,
Thank you for alerting us to this issue.
I was able to replicate an issue

I have found a workaround:

On a clip that is cropped (layer above):

1. Smooth setting for both resize and debayer in the sizing tab of the Project settings. Bilinear setting for the Monitoring section of the Master Project Settings.

2. In a node tree upstream of any corrections add a layer mixer node.

3. Remove link from the origin to the secondary node that feeds the layer mixer.

4. Right click on the secondary node and add external matte (chose the clip itself)

5. New node will pop up upstream of the secondary node, that is feeding the layer mixer node.

6. Disconnect the key feeder link (Triangle to Triangle) from the EXT MATTE and replace with the image link circle to circle).

This will remove the matte line. The layer mixer node should be on the normal mode.

I have performed the testing on a 6K r3d media in both 11.3.1 and 12 beta 28

2015-08-12 02.18.32 pm.jpg
2015-08-12 02.18.32 pm.jpg (150.83 KiB) Viewed 1381 times

Re: Compositing showing edge lines

PostPosted: Thu Aug 13, 2015 12:03 am
by Elliott Balsley
Thanks, that trick works.