DaVinci Resolve on Linux - Install issues

Get answers to your questions about color grading, editing and finishing with DaVinci Resolve.
  • Author
  • Message
Offline

Julian Tsvetanov

  • Posts: 6
  • Joined: Mon Jul 03, 2017 10:29 am

Re: DaVinci Resolve on Linux - Install issues

PostFri Aug 04, 2017 4:24 pm

Dwaine Maggart wrote:I can't speak for Peter.

Thanks, but do you have information and possibly opinion about USB audio card that I can use, so my Resolve Studio outputs audio on my Linux laptop?
Offline

Adam Brown

  • Posts: 10
  • Joined: Sat Jul 22, 2017 2:29 pm

Re: DaVinci Resolve on Linux - Install issues

PostSat Aug 05, 2017 1:21 pm

Julian Tsvetanov wrote:
Dwaine Maggart wrote:I can't speak for Peter.

Thanks, but do you have information and possibly opinion about USB audio card that I can use, so my Resolve Studio outputs audio on my Linux laptop?


That's exactly want I want to know as well, as I can't get Audio working on my Linux laptop. Please can add full audio support out of the box, without having to rely on extra pieces of hardware? It really is a critical feature for any video editing program.
Offline

Ian Duncan

  • Posts: 5
  • Joined: Wed Aug 09, 2017 6:55 pm
  • Location: Los Angeles

Re: DaVinci Resolve on Linux - Install issues

PostWed Aug 09, 2017 7:06 pm

Hello

This is great to see Blackmagic getting linux versions out there. We are in the process of making our office as linux as it can be and this is a huge step.

Ia m hoping someone can help me with an issue I have getting the Desktop video driver to install.

Resolve is working fine although I am having issues with the Desktop video driver, i expect to have issues with the database too. I was running centos7 so i thought i would give it a try.

Here is the error:
Code: Select all
[root@WHITE-FOREST Downloads]# cd /home/ijd/Downloads/Blackmagic_Desktop_Video_Linux_10.9.5a4/rpm/x86_64
[root@WHITE-FOREST x86_64]# rpm -ivh desktopvideo-10.9.5-a4.x86_64.rpm
Preparing...                          ################################# [100%]
Updating / installing...
   1:desktopvideo-10.9.5-a4           ################################# [100%]
Preparing new blackmagic driver for 3.10.0-514.26.2.el7.x86_64 kernel...
  Adding to DKMS
  Building (failed)
Preparing new blackmagic-io driver for 3.10.0-514.26.2.el7.x86_64 kernel...
  Adding to DKMS
  Building (failed)
Loading modules...
Enabling systemd services...
  DesktopVideoHelper
Starting systemd services...
  DesktopVideoHelper
********************************************************************************
Failed to build driver(s)

Possible causes:
 1. Driver is incompatible with your kernel version
 2. Kernel headers/gcc/make/etc. is not installed
 3. Kernel header version does not match the running kernel (3.10.0-514.26.2.el7.x86_64)

Error messages:
dkms build -m blackmagic -v 10.9.5a4 --rpm_safe_upgrade
---
Error! echo
Your kernel headers for kernel 3.10.0-514.26.2.el7.x86_64 cannot be found at
/lib/modules/3.10.0-514.26.2.el7.x86_64/build or /lib/modules/3.10.0-514.26.2.el7.x86_64/source.

dkms build -m blackmagic-io -v 10.9.5a4 --rpm_safe_upgrade
---
Error! echo
Your kernel headers for kernel 3.10.0-514.26.2.el7.x86_64 cannot be found at
/lib/modules/3.10.0-514.26.2.el7.x86_64/build or /lib/modules/3.10.0-514.26.2.el7.x86_64/source.
Offline

Philippe GALLE

  • Posts: 7
  • Joined: Fri Jul 28, 2017 1:03 pm

Re: DaVinci Resolve on Linux - Install issues

PostThu Aug 10, 2017 6:47 am

I do not know if this comes from an installation issue or anything else but Resolve linux returns the error "Missing Look Up Table - 3D Lut Film Looks/Rec709 Kodak 2383 D55.cube" when I try to apply this 3D Lut (for exemple) on a video coming from a GH5.

I try this manipulation by following the example given by Aram K in one of his color grading tutorials for GH5 "https://www.youtube.com/watch?v=bbYqowlQyj4" found on youtube.

Why this error under linux? (Aram K uses Windows)
How to correct it?

For information the error occurs both under Resolve Studio 12.5.6 and under 14b6 (and fresh CentOS 7.3 install).

Thank's
Offline
User avatar

Vassilis Kontodimas

  • Posts: 57
  • Joined: Wed May 31, 2017 7:10 pm

Re: DaVinci Resolve on Linux - Install issues

PostThu Aug 10, 2017 2:14 pm

Ian Duncan wrote:Hello

This is great to see Blackmagic getting linux versions out there. We are in the process of making our office as linux as it can be and this is a huge step.

Ia m hoping someone can help me with an issue I have getting the Desktop video driver to install.

Resolve is working fine although I am having issues with the Desktop video driver, i expect to have issues with the database too. I was running centos7 so i thought i would give it a try.

Hello Ian,

It would seem your issue is installing the Kernel Headers for your version of Kernel. Normally, they should be installed, but I cannot be 100% certain since I don't have a system running CentOS at the moment.

Run the following command:
Code: Select all
yum search headers

And see if this gives you any hits. If it does, then you can yum install it. Otherwise, you might need to activate the kernel repository to do that. Just make sure you download the exact same Kernel version the "uname -r" command gives you.

Hope that helps!
Offline

Przemek Jeske

  • Posts: 29
  • Joined: Sun Dec 28, 2014 2:58 pm

Re: DaVinci Resolve on Linux - Install issues

PostMon Aug 14, 2017 9:28 am

Ian Duncan wrote:Hello

Resolve is working fine although I am having issues with the Desktop video driver, i expect to have issues with the database too. I was running centos7 so i thought i would give it a try.


install kernel headers:
Code: Select all
sudo yum install kernel-headers


- that should do the trick (unless you've installed latest mainline kernel - but I doubt you did :D ).
Offline

Philippe GALLE

  • Posts: 7
  • Joined: Fri Jul 28, 2017 1:03 pm

Re: DaVinci Resolve on Linux - Install issues

PostMon Aug 14, 2017 1:16 pm

Hello,

No one would have the solution to correct this 3D Lut error message "Missing Look Up Table" with Resolve Linux (posted a few days ago)?
Offline
User avatar

Dwaine Maggart

Blackmagic Design

  • Posts: 3368
  • Joined: Wed Aug 22, 2012 2:53 pm

Re: DaVinci Resolve on Linux - Install issues

PostMon Aug 14, 2017 9:05 pm

@Philippe: This works here. Is that the only LUT selection not working? Do the D60 and D65 versions work?
Dwaine Maggart
Blackmagic Design DaVinci Support
Offline

Philippe GALLE

  • Posts: 7
  • Joined: Fri Jul 28, 2017 1:03 pm

Re: DaVinci Resolve on Linux - Install issues

PostTue Aug 15, 2017 6:46 am

Hello Dwaine,

No, I have the same error with all 3D LUT film looks.

I have temporarily installed macos on the second hard disk of the same PC and it works. I also made this manipulation on my laptop which is still under windows 10 and it works, and always with the same video.

I looked if it was not a rights issue but apparently everything is ok. I still tried a chmod 777 on the / opt / resolve directory but no better results. ;-(

I just reviewed the logs and found this in the rollinglog.txt:
[0x7faed272eb00] | SyManager.Lut | ERROR | 2017-08-15 08:37:17,191 | Invalid Cube LUT file '/opt/resolve/LUT/Film Looks/DCI-P3 Fujifilm 3513DI D55.cube'
[0x7faed272eb00] | SyManager.Lut | ERROR | 2017-08-15 08:37:17,191 | Invalid Cube LUT file '/opt/resolve/LUT/Film Looks/DCI-P3 Fujifilm 3513DI D60.cube'
[0x7faed272eb00] | SyManager.Lut | ERROR | 2017-08-15 08:37:17,191 | Invalid Cube LUT file '/opt/resolve/LUT/Film Looks/DCI-P3 Fujifilm 3513DI D65.cube'
[0x7faed272eb00] | SyManager.Lut | ERROR | 2017-08-15 08:37:17,191 | Invalid Cube LUT file '/opt/resolve/LUT/Film Looks/DCI-P3 Kodak 2383 D55.cube'
[0x7faed272eb00] | SyManager.Lut | ERROR | 2017-08-15 08:37:17,191 | Invalid Cube LUT file '/opt/resolve/LUT/Film Looks/DCI-P3 Kodak 2383 D60.cube'
[0x7faed272eb00] | SyManager.Lut | ERROR | 2017-08-15 08:37:17,191 | Invalid Cube LUT file '/opt/resolve/LUT/Film Looks/DCI-P3 Kodak 2383 D65.cube'
[0x7faed272eb00] | SyManager.Lut | ERROR | 2017-08-15 08:37:17,191 | Invalid Cube LUT file '/opt/resolve/LUT/Film Looks/Rec709 Fujifilm 3513DI D55.cube'
[0x7faed272eb00] | SyManager.Lut | ERROR | 2017-08-15 08:37:17,191 | Invalid Cube LUT file '/opt/resolve/LUT/Film Looks/Rec709 Fujifilm 3513DI D60.cube'
[0x7faed272eb00] | SyManager.Lut | ERROR | 2017-08-15 08:37:17,191 | Invalid Cube LUT file '/opt/resolve/LUT/Film Looks/Rec709 Fujifilm 3513DI D65.cube'
[0x7faed272eb00] | SyManager.Lut | ERROR | 2017-08-15 08:37:17,191 | Invalid Cube LUT file '/opt/resolve/LUT/Film Looks/Rec709 Kodak 2383 D55.cube'
[0x7faed272eb00] | SyManager.Lut | ERROR | 2017-08-15 08:37:17,191 | Invalid Cube LUT file '/opt/resolve/LUT/Film Looks/Rec709 Kodak 2383 D60.cube'
[0x7faed272eb00] | SyManager.Lut | ERROR | 2017-08-15 08:37:17,192 | Invalid Cube LUT file '/opt/resolve/LUT/Film Looks/Rec709 Kodak 2383

and the last line:
[0x7faddf7fe700] | GPUManager | ERROR | 2017-08-15 08:37:26,367 | Failed to read Shaper LUT 'Film
Looks/Rec709 Kodak 2383 D55.cube'

May be that this may help in the diagnosis ?

Cuda is installed and I have a Nvidia GTX1080 video card.
Offline

Fanjan Combrink

  • Posts: 1
  • Joined: Tue Aug 15, 2017 9:57 am

Re: DaVinci Resolve on Linux - Install issues

PostTue Aug 15, 2017 10:05 am

Is there a thread regarding installing Resolve on CentOS only?

I setting up a new build (Ryzen 1600, RX550 as a start from my 5 year old laptop) on CentOS but that far I got Resolve installed however in the application menu it was labeled as "unnamed"

Fusion was a dream to install since it uses a .run file (haven't worked on Linux for the last 5 years, been missing it so please excuse stupid terminology).

Now I'm looking for the link to the CentOS Resolve image file. I keep reading about the link being in the readme.txt file but I am still to locate it and I'm not interested in downloading a software archive only to get a readme file so that I can get a link to a download page for a software archive.

Mods: Can this thread be split. One thread for Installing Resolve on Linux, and another for installing Resolve on CentOS?
Offline
User avatar

Dwaine Maggart

Blackmagic Design

  • Posts: 3368
  • Joined: Wed Aug 22, 2012 2:53 pm

Re: DaVinci Resolve on Linux - Install issues

PostWed Aug 16, 2017 1:16 am

Dwaine Maggart
Blackmagic Design DaVinci Support
Offline

felixsanz

  • Posts: 1
  • Joined: Wed Aug 16, 2017 5:30 am

Re: DaVinci Resolve on Linux - Install issues

PostWed Aug 16, 2017 5:31 am

whats needs to be done in order to get audio working on linux? It is only possible using a hardware device? If so, would the Intensity Shuttle make the work?

thanks
Offline

Diego Borghello

  • Posts: 3
  • Joined: Fri Mar 03, 2017 10:14 am

Re: DaVinci Resolve on Linux - Install issues

PostWed Aug 16, 2017 9:29 pm

Resolve 14 beta 7 won't start on Linux, but it starts with 12.5.6
I'm running the latest BM Centos 7.3 with Resolve 12.5.6 on a Z840 with GTX1080
Offline

Mark Bethel

  • Posts: 1
  • Joined: Thu Aug 17, 2017 11:58 pm

Arch Linux DaVinci Resolve Studio Issues

PostFri Aug 18, 2017 12:04 am

I originally started off with DaVinci Resolve which worked fine, but upon moving over to the studio version I now get the issue upon launch

bin/resolve: error while loading shared libraries: libCrmSdk.so.2.0: cannot open shared object file: No such file or directory

I tried looking for the library online and trying to see if someone has ever had the same issue. I didn't find anything of anyone ever having a similar issue nor did I find anything on the library. Any help is appreciated, thank you.

I am also running the most up to date version of Arch Linux.
Offline

Michal Nemec

  • Posts: 1
  • Joined: Fri Aug 18, 2017 9:30 am

Re: DaVinci Resolve on Linux - Install issues

PostFri Aug 18, 2017 9:37 am

Library is located at: /opt/resolve/libs/libCrmSdk.so.2.0

My guess is, that your installation is corrupted.


I have also a question. My installation of Studio is not saving some color correction settings - like saturation, hue vs sat curve etc. - in Studio 12.5, 14b6, 14b7. Anyone with same problem?

And I can also confirm problems with 10bit replay and no LUT.

Gentoo linux.
Offline

Ian Duncan

  • Posts: 5
  • Joined: Wed Aug 09, 2017 6:55 pm
  • Location: Los Angeles

Re: DaVinci Resolve on Linux - Install issues

PostFri Aug 18, 2017 6:39 pm

Vassilis Kontodimas wrote:
Ian Duncan wrote:Hello

This is great to see Blackmagic getting linux versions out there. We are in the process of making our office as linux as it can be and this is a huge step.

Ia m hoping someone can help me with an issue I have getting the Desktop video driver to install.

Resolve is working fine although I am having issues with the Desktop video driver, i expect to have issues with the database too. I was running centos7 so i thought i would give it a try.

Hello Ian,

It would seem your issue is installing the Kernel Headers for your version of Kernel. Normally, they should be installed, but I cannot be 100% certain since I don't have a system running CentOS at the moment.

Run the following command:
Code: Select all
yum search headers

And see if this gives you any hits. If it does, then you can yum install it. Otherwise, you might need to activate the kernel repository to do that. Just make sure you download the exact same Kernel version the "uname -r" command gives you.

Hope that helps!


I see

kernel-headers.x86_64 : Header files for the Linux kernel for use by glibc

but that is it.
Offline

Ian Duncan

  • Posts: 5
  • Joined: Wed Aug 09, 2017 6:55 pm
  • Location: Los Angeles

Re: DaVinci Resolve on Linux - Install issues

PostFri Aug 18, 2017 6:41 pm

Przemek Jeske wrote:
Ian Duncan wrote:Hello

Resolve is working fine although I am having issues with the Desktop video driver, i expect to have issues with the database too. I was running centos7 so i thought i would give it a try.


install kernel headers:
Code: Select all
sudo yum install kernel-headers


- that should do the trick (unless you've installed latest mainline kernel - but I doubt you did :D ).



I get :

Package kernel-headers-3.10.0-514.26.2.el7.x86_64 already installed and latest version
Nothing to do

How do i know if i have installed the latest mainline kernel?
Offline

Ian Duncan

  • Posts: 5
  • Joined: Wed Aug 09, 2017 6:55 pm
  • Location: Los Angeles

Re: DaVinci Resolve on Linux - Install issues

PostFri Aug 18, 2017 8:41 pm

I was able to install the software and the driver.

HArdware is installed:

# lspci | grep Blackmagic
02:00.0 Multimedia video controller: Blackmagic Design DeckLink 4K Extreme


However No Desktop Video Device Detected and then i enter:

# lsmod | grep blackmagic

it returns nothing

Anybody have any ideas?
Offline

Philippe GALLE

  • Posts: 7
  • Joined: Fri Jul 28, 2017 1:03 pm

Re: DaVinci Resolve on Linux - Install issues

PostSat Aug 19, 2017 7:39 am

@Dwaine,

I just found the reason I have the error message "Missing Look Up Table".
It seems that there are missing files and directories in .LUT.
By copying these missing files and directories from a windows version to my linux configuration, it works.
I do not know why they are not created during the installation.
I tried a "update list" from the color management menu (project settings) but without success.
Is there any other manipulation to generate these missing files?
Offline

Adam Archer

  • Posts: 122
  • Joined: Wed Dec 17, 2014 2:12 am

Re: DaVinci Resolve on Linux - Install issues

PostMon Aug 21, 2017 12:40 am

Just wondering if anyone has tried to install Resolve on RHEL/CENTOS 7.4 yet?

I'm going to undertake the challenge in the next few weeks sometime when I have some spare time but thought if anyone had tried already then I may as well seek some advice.

Thanks in advance.
Previous

Return to DaVinci Resolve

Who is online

Users browsing this forum: Renato Zanardo and 13 guests