Trying to figure out cause of nasty aliasing in render

Get answers to your questions about color grading, editing and finishing with DaVinci Resolve.
  • Author
  • Message
Offline

Seth Goldin

  • Posts: 124
  • Joined: Wed Nov 04, 2015 7:43 pm

Trying to figure out cause of nasty aliasing in render

PostFri Apr 21, 2017 4:05 pm

Several months back, I created proxies for an offline edit with an earlier version of Resolve and an earlier version of CUDA.

The OCNs were UHD XAVC-I from an FS7 and the proxies were UHD ProRes 422 Proxy.

The proxies came out fine, and the offline editor, working in Premiere, would render out 1080p H.264 drafts that looked great. So Premiere was downscaling our UHD proxies to 1080p H.264, without any issues.

Here's a still from a proxy that's looking fine: http://imgur.com/a/lGJH4

Recently, we conformed back to the OCNs inside Resolve and were prepping a "single-clip" 1080p export for a 1080p finish.

The plan was to render the UHD XAVC-I to 1080p ProRes 4444. Unfortunately, Resolve now seems to be reading the OCNS with pretty nasty aliasing, and it does pass that aliasing along into the ProRes 4444 export. Whether merely previewing 1080p out of the DeckLink Mini Monitor or looking at the 1080p ProRes 4444 export, the aliasing is quite bad.

Here are stills of the 1080p DI, before and after some grading:
Log: http://imgur.com/mYeat1G
Some grading: http://imgur.com/a/sg8JS

Notice the edge of the subject's left shoulder. Compare the proxy to the ungraded and graded DI.

Image Scaling was set to "Sharper," and we tried all the settings for "Anti-alias edges:" auto, on, and off. Nothing seemed to improve the aliasing.

My hunch is that this might just be a CUDA issue, because that's the major thing that seems to have changed, but I'm not sure. I'm wondering how I might try to diagnose and fix this.

System specs:
NVIDIA Web Driver 378.05.05.05f01
CUDA driver 8.0.81
DaVinci Resolve 12.5.5.026
MacPro5,1 (Mid 2010)
macOS Sierra 10.12.4 (16E195)
NVIDIA GeForce GTX TITAN X 12288 MB (9-series with MacVidCards firmware)

There is an update for the NVIDIA Web Driver available, 378.05.05.05f02, but I'd like to confirm whether that would fix this issue before I update. Does anyone know of any issues with 378.05.05.05f01 or is there something else I might be missing?
Offline

Seth Goldin

  • Posts: 124
  • Joined: Wed Nov 04, 2015 7:43 pm

Re: Trying to figure out cause of nasty aliasing in render

PostFri Apr 21, 2017 5:15 pm

I just tried the same OCNs on a different system entirely, and I don't think it's CUDA. 12.5.5 on a MacPro6,1 with AMD FirePros is also causing this problem, even with "Sharper" image scaling.

Seems like a Resolve bug. Can anyone else confirm? Possibly this thread will be made obsolete by Resolve 14's imminent release.


Sent from my iPhone using Tapatalk
Offline

Andrew Kolakowski

  • Posts: 2771
  • Joined: Tue Sep 11, 2012 10:20 am

Re: Trying to figure out cause of nasty aliasing in render

PostFri Apr 21, 2017 6:19 pm

These sort of aliasing (stepping on diagonal lines) happens when you interpret progressive footage as interlaced and work in progressive project.

Are you sure your source clips are integrated as progressive? (I assume you work with progressive sources)
Offline

Seth Goldin

  • Posts: 124
  • Joined: Wed Nov 04, 2015 7:43 pm

Re: Trying to figure out cause of nasty aliasing in render

PostFri Apr 21, 2017 8:05 pm

The footage is all progressive. All the problem clips are 23.976 fps, and Resolve is properly interpreting them as such.

Just to be sure, I just confirmed this in the Master Project Settings tab of the Project Settings window, as well as the Clip Attributes window for the problem clips.
Offline

Seth Goldin

  • Posts: 124
  • Joined: Wed Nov 04, 2015 7:43 pm

Re: Trying to figure out cause of nasty aliasing in render

PostWed Apr 26, 2017 7:00 pm

I figured this out, in case anyone ever runs into a similar issue. The problem was that I was using video field processing on my progressive footage. This is a project-level setting.

So, all my footage was progressive, and I had accidentally checked: Project Settings>Master Project Settings>Timeline Format>Enable video field processing.

Once I unchecked this, the aliasing was gone.

An explanation from the manual:

Enable video field processing: Interlaced media is supported throughout DaVinci Resolve. The “Enable video field processing” checkbox forces Resolve to process all operations internally using separated fields. A corresponding checkbox in the Format settings of the Deliver page, “Field rendering,” lets you enable and disable field rendering when rendering file-based output. In addition, each clip in the Media Pool has a Field Dominance pop-up menu in the Video panel of the Clip Attributes window that lets you specify whether clips are upper- or lower-field dominant; an Auto setting makes this choice by default.

If you’re working with progressive-frame media, it is not necessary to turn this checkbox on. Furthermore, if you’re using interlaced clips in a progressive-frame project and you’re intending to deinterlace those clips using the Enable Deinterlacing checkbox in the Clip Attributes window, then you must turn “Enable video field processing” off. Otherwise, the Enable Deinterlacing checkbox will be disabled for all clips. For more information about deinterlacing clips, see the “Changing Clip Attributes” section of Chapter 9, “Working With Media.”

Whether or not it’s necessary to turn field processing on to maintain the field integrity of interlaced clips in your program depends on what types of corrections you’re applying to your clips. If you’re mastering your program to an interlaced format, and you’re applying any adjustments that would cause pixels from one field to move or bleed into adjacent fields, then field processing should be enabled; effects requiring field processing include filtering operations such as blur, sharpen, and OpenFX operations, as well as sizing transforms that include pan, tilt, zoom, rotate, pitch, and yaw.

On the other hand, regardless of whether you’re outputting interlaced or progressive- frame media, if you’re not filtering or resizing your clips, and you’re only applying adjustments to color and contrast, it’s not necessary to turn on field processing for interlaced material, and in fact, leaving it off may somewhat shorten your project’s rendering time.


Big thanks to Dmitry Kitsov on the Blackmagic tech support team for figuring this out.

Return to DaVinci Resolve

Who is online

Users browsing this forum: Bing [Bot], Google [Bot], Jeff Brass, Marc Wielage, Mark Sterne, PeterMoretti and 9 guests