Page 1 of 1

SMPTE Color bars (ARIB) on ACES show 4% green in the Red bar

PostPosted: Tue May 16, 2017 6:19 pm
by Cary Knoop
A video with SMPTE Color bars (ARIB) on ACES showabout 4% green in the Red bar.

YRGB and color managed color science seems to work correctly but using ACES color science there is green in the Red SMPTE bar. I tried input and output combinations (Rec 709, Rec 709 (Camera) and sRGB).

Interestingly when using Rec709 D60 Sim the Red bar is actually correct but the overall color balance is obviously wrong.

Noteworthy is that when selecting YRGB colos science and using two nodes to explicitly transform from Rec709 to ACES and back the result is correct.

Is this a bug or am I doing something wrong?

Using Resolve 14 beta 2 on Windows 10.

Re: SMPTE Color bars (ARIB) on ACES show 4% green in the Red

PostPosted: Fri May 19, 2017 4:14 pm
by waltervolpatto
I dont think you can use "bars" under ACES.....

Re: SMPTE Color bars (ARIB) on ACES show 4% green in the Red

PostPosted: Fri May 19, 2017 6:26 pm
by Cary Knoop
waltervolpatto wrote:I dont think you can use "bars" under ACES.....

I did not use the DaVinci generated "bars" the "bars" where imported from a ProRes source.

Re: SMPTE Color bars (ARIB) on ACES show 4% green in the Red

PostPosted: Fri May 19, 2017 6:28 pm
by waltervolpatto
all "bars",

Sent from my SM-N920T using Tapatalk

Re: SMPTE Color bars (ARIB) on ACES show 4% green in the Red

PostPosted: Fri May 19, 2017 6:35 pm
by Cary Knoop
waltervolpatto wrote:all "bars",

So if I have a video where there is red (192, 0, 0 RGB) it is OK for ACES to add 4% green?

Here is a link to the video:
https://www.dropbox.com/s/in43qdl7n7nf2 ... 0.mov?dl=0

Re: SMPTE Color bars (ARIB) on ACES show 4% green in the Red

PostPosted: Fri May 19, 2017 6:43 pm
by waltervolpatto
Cary Knoop wrote:
waltervolpatto wrote:all "bars",

So if I have a video where there is red (192, 0, 0 RGB) it is OK for ACES to add 4% green?


The RRT/ODT has an inherent "look+color mapping" to it, that depend upon few factors including ITD you use, the actual RRT and the display you're targeting (ODT).

Re: SMPTE Color bars (ARIB) on ACES show 4% green in the Red

PostPosted: Fri May 19, 2017 6:46 pm
by Cary Knoop
waltervolpatto wrote:
Cary Knoop wrote:
waltervolpatto wrote:all "bars",

So if I have a video where there is red (192, 0, 0 RGB) it is OK for ACES to add 4% green?


The RRT/ODT has an inherent "look+color mapping" to it, that depend upon few factors including ITD you use, the actual RRT and the display you're targeting (ODT).

All Rec.709

Re: SMPTE Color bars (ARIB) on ACES show 4% green in the Red

PostPosted: Fri May 19, 2017 10:15 pm
by Andrew Kolakowski
Sounds like a bug.

Re: SMPTE Color bars (ARIB) on ACES show 4% green in the Red

PostPosted: Fri May 19, 2017 10:40 pm
by JPOwens
Cary Knoop wrote:All Rec.709


But not "all" 709. You have to forget 709 throughput because ACES works in its own "standardized" workspace.

"The system defines its own color primaries that completely encompass the visible spectral locus as defined by the CIE xyY specification. The white point is approximate to the CIE D60 standard illuminant, and ACES compliant files are encoded in 16-bit half-floats, thus allowing ACES OpenEXR files to encode 30 stops of scene information.[1] ACES supports both high dynamic range (HDR) and wide color gamut."

"Color bars" lose their relevance except you may use them again to refer to your completed output, rendered with a 709 ODT. But they are not likely to survive linearly across a primary transform entering the grade workflow. Experiment... you could try rendering a QT of bars and then adding them to the timeline - change the IDT to "none..." But I doubt it.

jPo, CSI

Re: SMPTE Color bars (ARIB) on ACES show 4% green in the Red

PostPosted: Fri May 19, 2017 10:54 pm
by Cary Knoop
Andrew Kolakowski wrote:Sounds like a bug.

I agree!

Replace "color bar" with a red apple. I have a scene with a red apple, I record it using Rec.709, and the destination is Rec.709 as well, I make no changes.

So now it is a feature of ACES and not a bug that it adds some green to the apple?

Sorry but you have to forgive me for not finding that a satisfactory explanation.

Re: SMPTE Color bars (ARIB) on ACES show 4% green in the Red

PostPosted: Fri May 19, 2017 11:21 pm
by waltervolpatto
Cary Knoop wrote:
Andrew Kolakowski wrote:Sounds like a bug.

I agree!

Replace "color bar" with a red apple. I have a scene with a red apple, I record it using Rec.709, and the destination is Rec.709 as well, I make no changes.

So now it is a feature of ACES and not a bug that it adds some green to the apple?

Sorry but you have to forgive me for not finding that a satisfactory explanation.

please forward your complain to the motion picture academy....

Sent from my SM-N920T using Tapatalk

Re: SMPTE Color bars (ARIB) on ACES show 4% green in the Red

PostPosted: Fri May 19, 2017 11:50 pm
by Andrew Kolakowski
Lets say I'm working on a master. Job done and I'm adding Rec.709 bars to final export.
Ups- I'm working in Resolve and ACES, so bars are incorrect. Nice feature :)
It has to be bug and has nothing to do with ACES itself.

Re: SMPTE Color bars (ARIB) on ACES show 4% green in the Red

PostPosted: Fri May 19, 2017 11:58 pm
by Cary Knoop
waltervolpatto wrote:
Cary Knoop wrote:
Andrew Kolakowski wrote:Sounds like a bug.

I agree!

Replace "color bar" with a red apple. I have a scene with a red apple, I record it using Rec.709, and the destination is Rec.709 as well, I make no changes.

So now it is a feature of ACES and not a bug that it adds some green to the apple?

Sorry but you have to forgive me for not finding that a satisfactory explanation.

please forward your complain to the motion picture academy....

The question is is it a problem with Resolve only or is it a generic ACES issue.

Perhaps someone could be so kind kind to very if the problem exists on alternative color grading software (I included a link in a previous message with a test video).

Anyways, as advised I posted the matter on ACES central.

http://acescentral.com/t/color-accuracy ... olors/1040

Re: SMPTE Color bars (ARIB) on ACES show 4% green in the Red

PostPosted: Sat May 20, 2017 3:28 pm
by Andrew Kolakowski
Very recent technology, huge theoretical color gamut and precision and yet it can't properly "represent" Rec.709 which is quite old, but mostly used standard?
Sound bit bizarre to me.

Re: SMPTE Color bars (ARIB) on ACES show 4% green in the Red

PostPosted: Sat May 20, 2017 5:27 pm
by waltervolpatto
it is not bizarre, the rrt has a look.

has modified and it should be reversible IIRC, as it might well be that the odt is simply not right...

Sent from my SM-N920T using Tapatalk

Re: SMPTE Color bars (ARIB) on ACES show 4% green in the Red

PostPosted: Sun May 21, 2017 8:20 am
by jussi rovanpera
I've noticed the same thing.

The Color Gurus commented that some of the Aces transforms cannot be reversed, and that's the reason...

Re: SMPTE Color bars (ARIB) on ACES show 4% green in the Red

PostPosted: Sun May 21, 2017 11:00 am
by Andrew Kolakowski
They said it's rather bug, not that it's impossible.
http://acescentral.com/t/color-accuracy ... olors/1040

Re: SMPTE Color bars (ARIB) on ACES show 4% green in the Red

PostPosted: Sun May 21, 2017 4:59 pm
by Cary Knoop
Andrew Kolakowski wrote:Very recent technology, huge theoretical color gamut and precision and yet it can't properly "represent" Rec.709 which is quite old, but mostly used standard?
Sound bit bizarre to me.

It certainly does not sound like an ivory tower ;)

Re: SMPTE Color bars (ARIB) on ACES show 4% green in the Red

PostPosted: Fri May 26, 2017 3:13 pm
by Cary Knoop
Running DaVinci 14 (beta 3) using the YRGB Color Managed color science and doing an explicit Rec.709 to ACES and back transform using the Color Space Transform effect does not add the 4% green!

So it seems to me that color space transform can work!