Your GPU Memory is full.

Get answers to your questions about color grading, editing and finishing with DaVinci Resolve.
  • Author
  • Message
Offline

Chris Timson

  • Posts: 10
  • Joined: Thu Oct 12, 2017 3:05 pm

Re: Your GPU Memory is full.

PostTue Nov 21, 2017 5:33 pm

I've had the same issue (14.1 Studio)
I seem to have found a workaround by exporting less than maximum speed, ie when exporting go to File/Advanced/ limit 20 25fps.

Seems to work for me so far.

Chris Timson
Offline

Paul Ingvarsson

  • Posts: 231
  • Joined: Tue Sep 10, 2013 3:57 pm
  • Location: London, UK

Re: Your GPU Memory is full.

PostThu Nov 23, 2017 11:19 am

14.1.1 Solves our issues - thanks for sorting it out so swiftly, it's much appreciated.
Paul Ingvarsson
StormHD
Strongbox DX-G (Dual e5-2690 v3 64GB)
K6000 | Titan-X | Decklink 4K Pro
Resolve 15.0.1
Windows 10.0.17134
Offline

Frederic Berger

  • Posts: 41
  • Joined: Mon May 23, 2016 7:00 pm

Re: Your GPU Memory is full.

PostMon Nov 27, 2017 12:42 pm

Unfortunately I tested 14.1.1 and it made no difference for me. I still get the same error message almost instantly with just one video segment on the timeline and one color node.
The source clip is h.264 compressed.
Core i7-4790k 4 Ghz
EVGA GTX 1060 SC 6 GB
BlackMagic Intensity Pro 4k
32 GB RAM
Windows 10 & programs on Samsung 850 256 GB SSD
Scratch volume on RAID 0 4x1TB 260 MB/s Write, 360 MB/s Read
BlackMagic DaVinci Resolve Studio 14.2
Offline

Dermot Shane

  • Posts: 1376
  • Joined: Tue Nov 11, 2014 6:48 pm

Re: Your GPU Memory is full.

PostMon Nov 27, 2017 4:13 pm

what is you timeline set to?
with only 3G vram it's entirely possibale that it truly is out of vram
alot of the issues folks had with 14.1.0 also had 8g or more vram + hd timelines, something that is well inside Resolve's comfort zone
Offline
User avatar

Jean Claude

  • Posts: 1723
  • Joined: Sun Jun 28, 2015 4:41 pm

Re: Your GPU Memory is full.

PostMon Nov 27, 2017 6:35 pm

Frederic Berger wrote:Unfortunately I tested 14.1.1 and it made no difference for me. I still get the same error message almost instantly with just one video segment on the timeline and one color node.
The source clip is h.264 compressed.



Hi Frederic,

Do a test from a new project with a clip that creates issue? OK/KO?
If it works :
Workaround: with an old project => Try to manually delete everything that is a cache
Windows 10 PRO X64 1709 and 1803 | DaVinci Resolve Studio 15.1.1.005 | Fusion Studio 9.0.2 | Decklink Studio 4K 6G | Desktop Video 10.10.11 | Nvidia 416.16
Offline
User avatar

Jack Fairley

  • Posts: 823
  • Joined: Mon Oct 03, 2016 7:58 pm
  • Location: Los Angeles

Re: Your GPU Memory is full.

PostMon Nov 27, 2017 8:49 pm

I don't have this issue on Win 10 1703 with a GTX 1080, but do on a different PC running Win 10 1709 with a GTX 1080 Ti, both running Resolve Studio 14.1. I don't normally use Resolve on the second PC, but I believe the test was with interlaced footage, so it could be that issue.
Offline

Frederic Berger

  • Posts: 41
  • Joined: Mon May 23, 2016 7:00 pm

Re: Your GPU Memory is full.

PostMon Nov 27, 2017 9:51 pm

Dermot Shane wrote:what is you timeline set to?
with only 3G vram it's entirely possibale that it truly is out of vram
alot of the issues folks had with 14.1.0 also had 8g or more vram + hd timelines, something that is well inside Resolve's comfort zone

My timeline is set to 1920x1080. I never had any problem in 12.5, only started happening when the engine got rewritten for version 14.

Also troubling: I just reinstalled 14.1.1 in my test environment (Windows 10 Insider Preview build 17025) after deleting all user preferences. BMD does a system check for compatibility and both the OS and the graphics card passed it. If a GPU with 3 GB was not enough there should at least be a warning. Instead I got two perfectly green checkmarks validating my configuration.
Core i7-4790k 4 Ghz
EVGA GTX 1060 SC 6 GB
BlackMagic Intensity Pro 4k
32 GB RAM
Windows 10 & programs on Samsung 850 256 GB SSD
Scratch volume on RAID 0 4x1TB 260 MB/s Write, 360 MB/s Read
BlackMagic DaVinci Resolve Studio 14.2
Offline

Frederic Berger

  • Posts: 41
  • Joined: Mon May 23, 2016 7:00 pm

Re: Your GPU Memory is full.

PostTue Nov 28, 2017 2:14 am

Jean Claude wrote:Hi Frederic,

Do a test from a new project with a clip that creates issue? OK/KO?
If it works :
Workaround: with an old project => Try to manually delete everything that is a cache


Hi Jean-Claude,

- I installed a fresh copy of 14.1.1.
- Created a brand new project.
- Selected one .MXF clip from my library.
- Without even dropping the clip into the project library or adding it to the timeline, I got the error "Your GPU Memory is full".

Clip is 90 seconds from a Sony PXW-X70, 100 Mbps 3840x2160 29.97 fps XAVC MPEG4.

So I figured I would try and determine if the fact that this clip is in a compressed format had anything to do with it. I changed the default view from icons to List in order to avoid taxing the system with displaying instant frames from the clips when one hovers over it with the mouse. Then I added one clip to my project media, and generated optimized media for it. The result: no more crashes! I have been playing with the clip, adding color nodes, etc... and so far, not a single GPU Memory Full error.

So, it seemed that the system was choking on the decompression of my UHD MPEG4 media, not really graphic effects processing.
Could it be a bug with the processing of the Sony MXF format I am using?

Having nothing to lose and trying to prove this point, I started to add more clips from the same project but this time without first generating optimized media. If video compression was the problem, DVR 14 should instantly complain about GPU memory issues. Surprise! Still no crash! I've pasted color nodes from one clip to another, tried playback/stop/fast forward and many combinations that I know, used to crash the program without being able to make the GPU Memory error reappear while editing the timeline!

It is as if the initial sequence I used when starting this project to gradually add clips without Live Preview was key to not consume GPU memory to its limit. Strange. There might be some memory management issues when preparing to process compressed video files.

I hope someone from the development team reads this and understands what is going on. It is puzzling to me.
Core i7-4790k 4 Ghz
EVGA GTX 1060 SC 6 GB
BlackMagic Intensity Pro 4k
32 GB RAM
Windows 10 & programs on Samsung 850 256 GB SSD
Scratch volume on RAID 0 4x1TB 260 MB/s Write, 360 MB/s Read
BlackMagic DaVinci Resolve Studio 14.2
Offline

Frederic Berger

  • Posts: 41
  • Joined: Mon May 23, 2016 7:00 pm

Re: Your GPU Memory is full.

PostTue Nov 28, 2017 4:23 pm

Does anybody know how to turn off the feature that updates the video clips' icons as one moves the mouse over it? I know how to turn off Live Preview, but I would also like to completely turn off updating the icons themselves.
Core i7-4790k 4 Ghz
EVGA GTX 1060 SC 6 GB
BlackMagic Intensity Pro 4k
32 GB RAM
Windows 10 & programs on Samsung 850 256 GB SSD
Scratch volume on RAID 0 4x1TB 260 MB/s Write, 360 MB/s Read
BlackMagic DaVinci Resolve Studio 14.2
Offline

PeterMoretti

  • Posts: 916
  • Joined: Sat Aug 03, 2013 12:12 am

Re: Your GPU Memory is full.

PostTue Nov 28, 2017 4:59 pm

Have tried 23.976 progressive, 24 progressive or 25 progressive clips?
Resolve 14.3 Studio. GTX 970 with GeForce 390.77 driver. Desktop Video 10.9.10. Intensity Shuttle USB 3.0. Windows 10 Pro.
Offline
User avatar

Jean Claude

  • Posts: 1723
  • Joined: Sun Jun 28, 2015 4:41 pm

Re: Your GPU Memory is full.

PostTue Nov 28, 2017 5:22 pm

Frederic Berger wrote:.../...
Surprise! Still no crash! .../...


Hi Frederic,

If it works without crash it's fine. It remains to find an explanation.
Is it possible to share a small problematic clip source so that we can test on our PCs?
Windows 10 PRO X64 1709 and 1803 | DaVinci Resolve Studio 15.1.1.005 | Fusion Studio 9.0.2 | Decklink Studio 4K 6G | Desktop Video 10.10.11 | Nvidia 416.16
Offline

Frederic Berger

  • Posts: 41
  • Joined: Mon May 23, 2016 7:00 pm

Re: Your GPU Memory is full.

PostWed Nov 29, 2017 9:32 pm

I will upload a sample clip for you to try.
What is also interesting to me is that some people seem to be able to fully utilize 14.1.1 with a Quadro card and 2 GB of vRAM. Why would a Radeon 3 GB card run out of GPU memory an not an Nvidia with 2 GB?
Core i7-4790k 4 Ghz
EVGA GTX 1060 SC 6 GB
BlackMagic Intensity Pro 4k
32 GB RAM
Windows 10 & programs on Samsung 850 256 GB SSD
Scratch volume on RAID 0 4x1TB 260 MB/s Write, 360 MB/s Read
BlackMagic DaVinci Resolve Studio 14.2
Offline

Yiorgos Tryfonas

  • Posts: 28
  • Joined: Thu Jun 02, 2016 12:40 pm

Re: Your GPU Memory is full.

PostThu Nov 30, 2017 11:09 am

I've been having the same experience as Frederic with compressed files on Resolve after the 14.1 update. 14.1.1 did not fix it. RAW files work just fine. H264 at one point or another they will cause GPU memory full while editing even with one clip without any coloring nodes. This is a GTX1080 8GB system btw. I've created a thread and uploaded logs as well. It's clearly a bug - perhaps between Resolve 14.1+ with some versions of QuickTime or whatever Resolve uses to decompress those files. Sometimes it happens immediately and sometimes after a bit. Best solution so far is to generate optimised media to something that doesn't generate the GPU memory full message till BM fixes it.
Offline
User avatar

Charles Bennett

  • Posts: 351
  • Joined: Sat Nov 05, 2016 11:55 am
  • Location: United Kingdom

Re: Your GPU Memory is full.

PostThu Nov 30, 2017 2:27 pm

I have just done a test with 14.1.1 importing an mp4 3840x2160 50fps 66Mbps into a matching timeline. My GTX 750ti with 2gb will happily run this with some dropped frames. No memory full error reported.
Dell XPS 8700 Core i7-4790 @ 3.60GHz, 24GB RAM, Nvidia Geforce GTX 750Ti, Win 10 Home, DaVinci Resolve 15.1.1 (free), Canon HF G40.
Dell Precision 490 dual 4 core Xeon Workstation, 16GB ECC RAM, Win 7 Ultimate, Pro Tools 2018.7
Offline

Chris Blake

  • Posts: 3
  • Joined: Thu Nov 30, 2017 8:00 pm

Re: Your GPU Memory is full.

PostThu Nov 30, 2017 8:10 pm

Does this suggest a bug rather than a graphics card issue?

2015 MacBook Pro with AMD R9 M370X
Win10 with GTX 670 (2GB)
Same project (4k from a GH4, some text overlays, minor colour correction). In this example created on MBP and exported to Win10, although I have the same situation the other way around:

On MBP - not a great editing experience once you add some text and nodes, but tolerable with no errors.
On Win10 - completely unusable due to continuous memory full errors. Even when it is not popping up a dialog box at last once a minute, the video monitoring just show corrupted video.

Much as I like my MBP, my Win10 machine has more CPU grunt and a much "better" graphics card. But for some reason Resolve works better on the lower spec machine.
Offline

Frederic Berger

  • Posts: 41
  • Joined: Mon May 23, 2016 7:00 pm

Re: Your GPU Memory is full.

PostFri Dec 01, 2017 1:47 am

I've uploaded a short sample video file that causes the GPU Memory Full under special circumstances.
https://drive.google.com/drive/folders/1eePjnztQbQoV1FtQUXJfBb_eqdcCpO5O?usp=sharing

To reproduce the error:
1. Launch DVR 14.1.1 with a new project and set your Media View to Tiles in the Media Tab
2. Save and restart DVR
3. Launch DVR and create a new project
4. Switch to the Media Tab
5. Navigate your drive/folder hierarchy and pick the folder where you stored the video clip sample you downloaded from my link.
6. Do not add the clip to your project yet, but move your mouse over the tile to preview sound + video from it
7. Add the clip to your project media
8. if DVR has not yet displayed the GPU Memory Full error, switch to the timeline Tab and insert it. Move back and forth over the video, start playback, etc... until the error appears.

If I repeat those same steps but with the initial view of the Media set to List instead of Tiles, the GPU Memory Full error does not come up.
Core i7-4790k 4 Ghz
EVGA GTX 1060 SC 6 GB
BlackMagic Intensity Pro 4k
32 GB RAM
Windows 10 & programs on Samsung 850 256 GB SSD
Scratch volume on RAID 0 4x1TB 260 MB/s Write, 360 MB/s Read
BlackMagic DaVinci Resolve Studio 14.2
Offline
User avatar

Jean Claude

  • Posts: 1723
  • Joined: Sun Jun 28, 2015 4:41 pm

Re: Your GPU Memory is full.

PostFri Dec 01, 2017 6:42 pm

Hi Frederic,

Download GPU_Memory_Full-20171201T175327Z-001.zip
2 clips:
Clip0342.mxf
Clip0342.mxf

Media Info :Clip0343.MXF
Code: Select all
General
Complete name                            : K:\_Shots_Shots\Frederic Berger\GPU_Memory_Full\Clip0343.MXF
Format                                   : MXF
Format version                           : 1.3
Format profile                           : OP-1a
Format settings                          : Closed / Complete
File size                                : 302 MiB
Duration                                 : 25 s 25 ms
Overall bit rate mode                    : Variable
Overall bit rate                         : 101 Mb/s
Encoded date                             : 2017-11-04 00:36:43.000
Writing application                      : Sony Mem 2.00

Video
ID                                       : 2
Format                                   : AVC
Format/Info                              : Advanced Video Codec
Format profile                           : High@L5.1
Format settings                          : CABAC / 2 Ref Frames
Format settings, CABAC                   : Yes
Format settings, RefFrames               : 2 frames
Format settings, wrapping mode           : Frame
Codec ID                                 : 0D01030102106001-0401020201314001
Duration                                 : 25 s 25 ms
Bit rate mode                            : Variable
Bit rate                                 : 96.6 Mb/s
Maximum bit rate                         : 100.0 Mb/s
Width                                    : 3 840 pixels
Height                                   : 2 160 pixels
Display aspect ratio                     : 16:9
Frame rate                               : 29.970 (30000/1001) FPS
Color space                              : YUV
Chroma subsampling                       : 4:2:0
Bit depth                                : 8 bits
Scan type                                : Progressive
Bits/(Pixel*Frame)                       : 0.389
Stream size                              : 288 MiB (95%)
Color range                              : Limited
Color primaries                          : BT.709
Transfer characteristics                 : IEC 61966-2-4
Matrix coefficients                      : BT.709

Audio #1
ID                                       : 3
Format                                   : PCM
Format settings                          : Little
Format settings, wrapping mode           : Frame (AES)
Codec ID                                 : 0D01030102060300-0402020101000000
Duration                                 : 25 s 25 ms
Bit rate mode                            : Constant
Bit rate                                 : 1 152 kb/s
Channel(s)                               : 1 channel
Sampling rate                            : 48.0 kHz
Frame rate                               : 29.970 FPS (1601.6 SPF)
Bit depth                                : 24 bits
Stream size                              : 3.44 MiB (1%)
Locked                                   : Yes

Audio #2
ID                                       : 4
Format                                   : PCM
Format settings                          : Little
Format settings, wrapping mode           : Frame (AES)
Codec ID                                 : 0D01030102060300-0402020101000000
Duration                                 : 25 s 25 ms
Bit rate mode                            : Constant
Bit rate                                 : 1 152 kb/s
Channel(s)                               : 1 channel
Sampling rate                            : 48.0 kHz
Frame rate                               : 29.970 FPS (1601.6 SPF)
Bit depth                                : 24 bits
Stream size                              : 3.44 MiB (1%)
Locked                                   : Yes

Audio #3
ID                                       : 5
Format                                   : PCM
Format settings                          : Little
Format settings, wrapping mode           : Frame (AES)
Codec ID                                 : 0D01030102060300-0402020101000000
Duration                                 : 25 s 25 ms
Bit rate mode                            : Constant
Bit rate                                 : 1 152 kb/s
Channel(s)                               : 1 channel
Sampling rate                            : 48.0 kHz
Frame rate                               : 29.970 FPS (1601.6 SPF)
Bit depth                                : 24 bits
Stream size                              : 3.44 MiB (1%)
Locked                                   : Yes

Audio #4
ID                                       : 6
Format                                   : PCM
Format settings                          : Little
Format settings, wrapping mode           : Frame (AES)
Codec ID                                 : 0D01030102060300-0402020101000000
Duration                                 : 25 s 25 ms
Bit rate mode                            : Constant
Bit rate                                 : 1 152 kb/s
Channel(s)                               : 1 channel
Sampling rate                            : 48.0 kHz
Frame rate                               : 29.970 FPS (1601.6 SPF)
Bit depth                                : 24 bits
Stream size                              : 3.44 MiB (1%)
Locked                                   : Yes

Other #1
ID                                       : 1-Material
Type                                     : Time code
Format                                   : MXF TC
Time code of first frame                 : 10:36:09;11
Time code settings                       : Material Package
Time code, striped                       : Yes

Other #2
ID                                       : 1-Source
Type                                     : Time code
Format                                   : MXF TC
Time code of first frame                 : 10:36:09;11
Time code settings                       : Source Package
Time code, striped                       : Yes

Other #3
ID                                       : 7
Format                                   : Acquisition Metadata
Muxing mode                              : Ancillary data / RDD 18
Duration                                 : 25 s 25 ms
Frame rate                               : 29.970 FPS
IrisFNumber_FirstFrame                   : 4.000000
FocusPositionFromImagePlane_FirstFrame   : 42900000.000 m
AutoExposureMode_FirstFrame              : Manual
AutoFocusSensingAreaSetting_FirstFrame   : Center Sensitive Auto
CaptureFrameRate_FirstFrame              : 29.970 fps
ShutterSpeed_Time_FirstFrame             : 1/60 s
CameraMasterGainAdjustment_FirstFrame    : 21.00 dB
ElectricalExtenderMagnification_FirstFra : 100%
AutoWhiteBalanceMode_FirstFrame          : One Push

Other #4
Type                                     : Time code
Format                                   : SMPTE TC
Muxing mode                              : SDTI
Time code of first frame                 : 10:36:09;11

New project => UHD

No problem except that there is only:
Audio # 3 ID: 5 => empty
Audio # 4 ID: 6 => empty

But no Your GPU Memory is full.
All tabs
(not easy to help)

sample from Fairlight after and no problem, no issue)
Only question: the distribution of the channels is not ordinary. OR ?
frederic.jpg
frederic.jpg (426.76 KiB) Viewed 2934 times
Windows 10 PRO X64 1709 and 1803 | DaVinci Resolve Studio 15.1.1.005 | Fusion Studio 9.0.2 | Decklink Studio 4K 6G | Desktop Video 10.10.11 | Nvidia 416.16
Offline

Frederic Berger

  • Posts: 41
  • Joined: Mon May 23, 2016 7:00 pm

Re: Your GPU Memory is full.

PostSat Dec 02, 2017 10:56 pm

Hello Jean-Claude,

Thanks for downloading my sample and trying it on your system!

I already reported the audio channel mapping problem to BlackMagic's tech support directly. I told them it was importing fine in 12.5, but in 14 the channels were no longer mapped correctly. Dmitry at Tech support USA told me this was not a bug but a feature and closed the case!

What is your GPU?
Core i7-4790k 4 Ghz
EVGA GTX 1060 SC 6 GB
BlackMagic Intensity Pro 4k
32 GB RAM
Windows 10 & programs on Samsung 850 256 GB SSD
Scratch volume on RAID 0 4x1TB 260 MB/s Write, 360 MB/s Read
BlackMagic DaVinci Resolve Studio 14.2
Offline

Dermot Shane

  • Posts: 1376
  • Joined: Tue Nov 11, 2014 6:48 pm

Re: Your GPU Memory is full.

PostSun Dec 03, 2017 3:28 am

i downloaded and tested on three machines, could not repro your issue tho, no "out of gpu ram" errors on any of them;
machine 1 = z400 / k2200 (4g vram)
machine 2 = z800 /1080 (8g vram)
machine 3 = z820 / 2x 1080Ti (11g vram)

what project and timeline settings are you useing?
Offline
User avatar

Jean Claude

  • Posts: 1723
  • Joined: Sun Jun 28, 2015 4:41 pm

Re: Your GPU Memory is full.

PostSun Dec 03, 2017 10:02 am

Frederic Berger wrote:Hello Jean-Claude,

Thanks for downloading my sample and trying it on your system!

I already reported the audio channel mapping problem to BlackMagic's tech support directly. I told them it was importing fine in 12.5, but in 14 the channels were no longer mapped correctly. Dmitry at Tech support USA told me this was not a bug but a feature and closed the case!

What is your GPU?


Hi Frederic,

I have 2 GPUs : GTX 1070 (8GB VRAM) and a GTX980Ti (6 GB VRAM)

Maybe your AMD R9 280X 3 GB is not powerful enough for UHD?

For the sound: it is not Davinci Resolve which is problematic, it is in relation to your clip: there are only the first 2 channels that have sound. Unless it is voluntary.

Have you tried on a 1080p TL to check that it goes?
Windows 10 PRO X64 1709 and 1803 | DaVinci Resolve Studio 15.1.1.005 | Fusion Studio 9.0.2 | Decklink Studio 4K 6G | Desktop Video 10.10.11 | Nvidia 416.16
Offline

Frederic Berger

  • Posts: 41
  • Joined: Mon May 23, 2016 7:00 pm

Re: Your GPU Memory is full.

PostSun Dec 03, 2017 9:02 pm

Dermot Shane wrote:i downloaded and tested on three machines, could not repro your issue tho, no "out of gpu ram" errors on any of them;
machine 1 = z400 / k2200 (4g vram)
machine 2 = z800 /1080 (8g vram)
machine 3 = z820 / 2x 1080Ti (11g vram)

what project and timeline settings are you useing?


I edit in 1920x1080 29.97 fps and always accept when I add my first clip to the project and get prompted by DVR to match the project settings with the clip I am adding.
Core i7-4790k 4 Ghz
EVGA GTX 1060 SC 6 GB
BlackMagic Intensity Pro 4k
32 GB RAM
Windows 10 & programs on Samsung 850 256 GB SSD
Scratch volume on RAID 0 4x1TB 260 MB/s Write, 360 MB/s Read
BlackMagic DaVinci Resolve Studio 14.2
Offline

Frederic Berger

  • Posts: 41
  • Joined: Mon May 23, 2016 7:00 pm

Re: Your GPU Memory is full.

PostSun Dec 03, 2017 9:17 pm

Jean Claude wrote:
Hi Frederic,

I have 2 GPUs : GTX 1070 (8GB VRAM) and a GTX980Ti (6 GB VRAM)

Maybe your AMD R9 280X 3 GB is not powerful enough for UHD?

For the sound: it is not Davinci Resolve which is problematic, it is in relation to your clip: there are only the first 2 channels that have sound. Unless it is voluntary.

Have you tried on a 1080p TL to check that it goes?


Yes I also thought that the 3 GB of vRAM of my RX280 may not have been enough for UHD editing, until I saw that some people use a 2GB Quadro card to edit the same resolution projects. But it is good to see that with 6 GB, both you and Dermot Shane had no problem with the MXF file from my Sony X70.

I edit on my timeline in 1920x1080, I do not have a UHD monitor to edit or preview my videos yet.

Regarding the sound, it is normal for this recording to only have stereo and 2 blank channels since I did not connect another input source to the XLR jacks. I recorded with just the internal mic. But what is not normal is that the two channels are mapped to the left audio. I have to manually reassign one channel to the right output channel, otherwise I only get sound in the left one. In 12.5 everything worked as expected and both left and right channels were mapped properly. Something changed in 14.1.
Core i7-4790k 4 Ghz
EVGA GTX 1060 SC 6 GB
BlackMagic Intensity Pro 4k
32 GB RAM
Windows 10 & programs on Samsung 850 256 GB SSD
Scratch volume on RAID 0 4x1TB 260 MB/s Write, 360 MB/s Read
BlackMagic DaVinci Resolve Studio 14.2
Offline

Chris Blake

  • Posts: 3
  • Joined: Thu Nov 30, 2017 8:00 pm

Re: Your GPU Memory is full.

PostThu Dec 07, 2017 3:49 pm

hi All

I think the amount of RAM and "power" of the card may not be the whole story.

In my example above, I can edit a simple 4k project my macbook pro with its under-powered 2GB AMD R9 M370X, but with my more powerful nvidia GTX 670 (2GB) machine I get constant GPU full errors for the same project.
Offline

Jon Dobson

  • Posts: 3
  • Joined: Tue Feb 04, 2014 10:36 am

Re: Your GPU Memory is full.

PostThu Dec 07, 2017 7:28 pm

For me the 14.1.1 Update has fixed the 'GPU memory full' message on both Mac and Windows when selecting field rendering.

Jon
Offline

Mike Sauls

  • Posts: 3
  • Joined: Tue May 02, 2017 11:35 am

Re: Your GPU Memory is full.

PostTue Feb 06, 2018 5:39 pm

I'm new to this forum but I have been looking at what everyone is saying about the GPU memory issue. I just purchased the studio version as I am very happy with Resolve. I have used Vegas and Premiere for many years. I did some testing with the nodes specifically the noise reduction. I quickly realized there was an issue. My timeline was only about 4 minutes long with very little grading. I did have three 4K clips shot at night and did some light noise reduction on all three. After looking thru this forum at some great tips I checked the resolution in the timeline. It was set at 4K 30 frames. I adjusted this down to 1080 HD and I have had no other issues. I started stressing the system by adding more nodes and more NR and grading. After adjusting over a dozen clips and adding some major NR I never got another gpu out of memory warning. I'm sure I could eventually crash it again but it seems to be working fine. I then rendered in 4K and the video was perfect. It also ran better on the timeline when playing back or scrubbing. My system is an i7 2.8, 24gigs ram, Nvidia 6gig gpu. Lots of good info on these forums. Also thanks for the civil and professional tone everyone has. It's refreshing.Thanks again to everyone.
Mike Sauls
Offline

georgekg

  • Posts: 33
  • Joined: Sat Sep 23, 2017 8:23 pm
  • Real Name: Aleksandar Djordjevic

Re: Your GPU Memory is full.

PostFri Feb 09, 2018 4:59 pm

I had the same problem. I'm working on short film - just about 30 sec. Media is mixed - full HD, UHD and hi res stills. Four video tracks in timeline and just light color correction. My problem occurs when I try to put playhead on the place where all four video tracks are populated. Then I got this message - your GPU Memory is full. I have Davinci Resolve 14.3 and my GPU is nVidia GTX 760 with 2GB of RAM. In the first place I tought that the main reason is GPU, because of small amount of memory. Then I came here and saw that many people with powerfull systems also have this problem.
I try all suggestions that I found so far, but nothing helped. Usualy I have connected 2 monitors - one 4K connected to DP and another HD connected to HDMI. Sometimes I connect UHD monitor to the second HDMI for full screen preview. When everything I try was unsuccesful and the deadline was come close, and film wasn't done, finally I try to disconnect all monitors except that HD and that was helpful. I get the job done without issues. When film was delivered I try to play around and again try to connect one by one 4K and UHD monitors with the same project opened and as soon as I connect 4K monitor I got this famous message. Same happened with UHD monitor. It doesn't matter wether two or three monitors was connected. Just to mention - HD monitor was always connected.
Sory for such long post, but maybe someone will find it helpful.
Last edited by georgekg on Fri Feb 09, 2018 9:11 pm, edited 1 time in total.
Offline
User avatar

Dwaine Maggart

Blackmagic Design

  • Posts: 4471
  • Joined: Wed Aug 22, 2012 2:53 pm

Re: Your GPU Memory is full.

PostFri Feb 09, 2018 7:01 pm

Multiple video tracks increases GPU memory usage. 2GB of GPU VRAM is simply not enough.
Dwaine Maggart
Blackmagic Design DaVinci Support
Offline

georgekg

  • Posts: 33
  • Joined: Sat Sep 23, 2017 8:23 pm
  • Real Name: Aleksandar Djordjevic

Re: Your GPU Memory is full.

PostFri Feb 09, 2018 8:56 pm

Dwaine Maggart wrote:Multiple video tracks increases GPU memory usage. 2GB of GPU VRAM is simply not enough.


Thank you Dwaine, but in Premiere I worked with even 12 video tracks without any issues and hiccups. Therefore I didn't expect this situation in Resolve.
Offline

Uli Plank

  • Posts: 3488
  • Joined: Fri Feb 08, 2013 2:48 am

Re: Your GPU Memory is full.

PostFri Feb 09, 2018 10:22 pm

Resolve is different, it's has been optimized for grading from the start.

If you like, you can always do your editing in Premiere and move the result to Resolve for grading.
Resolve Studio and Fusion Studio
iMac 2017 Radeon Pro 580 8 GB VRAM and 32 GB RAM
Offline

Pete Webb

  • Posts: 6
  • Joined: Wed May 25, 2016 2:28 am

Re: Your GPU Memory is full.

PostSat Feb 10, 2018 11:15 am

I am reading this thread with interest as I am currently building a Ryzen based PC for Resolve and Premiere. As it is a value build I have been gradually adding components - quite a difficult project with the soaring RAM and graphic card prices at the moment due to mining and chinese steam players.
I have been able to source at quite reasonable value everything except a high end graphics card, so as a place holder card I am using a reconditioned R9 270x 2GB.
The rest of my system :

Asus prime B350 plus
Ryzen 1800x cpu
64gB Flare X RAM DDR4 2133

I see that some here are really insistent about Video ram being critical others less so. I expect to be a little frustrated with video card- but am prepared to put up with some pain until a decent card becomes available at a normalised price- perhaps months away.

I purchased the 1800x for the same price that I could buy the 1700x so for me it was an upgrade and will hopefully run more stable at higher clock speeds than the 1700x.
I purchased the 64 GB at a great price, and the original 32GB has been upgraded because of price/value

My question is , will my lack of video card firepower bottleneck my system? Or will the Ram, and extra thread processing and clockspeed help mitigate this?
I look forward to hearing from users who have similar systems and may give me an insight into what to expect.
Thanks
Offline

Darrtel Brown

  • Posts: 10
  • Joined: Tue Jun 13, 2017 10:40 pm

Re: Your GPU Memory is full.

PostSat Feb 10, 2018 8:16 pm

[Solved] Variable video framerate was the issue. [Solved]
I've started getting this error out of the blue. I have been using 14.3 for a little while with the same specs but all of a sudden this error showed up. The GPU memory is definitely not full so I don't understand what is wrong. I have a Ryzen 7 1700, 16GB RAM @ 3000Mhz, GTX 980 4GB, 128GB SSD boot drive that resolve is installed to, 1TB SSD and 1TB HDD that videos come from and are rendered to. This started after I tried using a live stream vod of mine that is barely over an hour long and only 1.7GB. I've tried lowering timeline resolution but that hasn't worked. I would find it tough to believe that it is my hardware considering it has been working perfectly fine up to this point. I had a 3 hour recording at 60Mpbs of gameplay that imported fine not that long ago.
Last edited by Darrtel Brown on Sun Feb 11, 2018 10:42 pm, edited 1 time in total.
Offline

Uli Plank

  • Posts: 3488
  • Joined: Fri Feb 08, 2013 2:48 am

Re: Your GPU Memory is full.

PostSun Feb 11, 2018 7:30 am

Game recordings have varying frame rates and most professional NLEs don't like that.
So, the error message is misleading, but the problem is real.
Resolve Studio and Fusion Studio
iMac 2017 Radeon Pro 580 8 GB VRAM and 32 GB RAM
Offline

Piotr Werewka

  • Posts: 7
  • Joined: Tue Apr 05, 2016 1:53 pm

Re: Your GPU Memory is full.

PostSun Feb 11, 2018 10:21 am

i got same error on gtx1080ti with x264 footage
for me its some CUDA decoder bug
a workaround for me was to change 'GPU processing mode' to OpenCL. After that all was working.
its visibly slower than CUDA but at least it works ..

this bug is over 1year old so i dont think they care much about that codec.
Offline

georgekg

  • Posts: 33
  • Joined: Sat Sep 23, 2017 8:23 pm
  • Real Name: Aleksandar Djordjevic

Re: Your GPU Memory is full.

PostSun Feb 11, 2018 10:43 am

Piotr Werewka wrote:i got same error on gtx1080ti with x264 footage
for me its some CUDA decoder bug
a workaround for me was to change 'GPU processing mode' to OpenCL. After that all was working.
its visibly slower than CUDA but at least it works ..

this bug is over 1year old so i dont think they care much about that codec.



nVidia definitely messing something with their drivers. I have the problem in Premiere, where program monitor is going black after a few seconds of playing back the timeline. Only workaround is to disable CUDA and use software rendering which is way to slower. As I saw on Adobe's forums, that problem persist for a very long time (5 years or so) therefore I don't see any reason to spend a fortune for their graphic cards. Those drivers form nVidia maybe causing this memory leaks problem in Resolve 14...
Offline

Darrtel Brown

  • Posts: 10
  • Joined: Tue Jun 13, 2017 10:40 pm

Re: Your GPU Memory is full.

PostSun Feb 11, 2018 10:41 pm

Uli Plank wrote:Game recordings have varying frame rates and most professional NLEs don't like that.
So, the error message is misleading, but the problem is real.


Apparently that was the issue. After running the video through handbrake to force a constant framerate everything was fine. Like you said, very misleading.
Offline

Manuel Senfft

  • Posts: 6
  • Joined: Sun Feb 26, 2017 10:10 pm

Re: Your GPU Memory is full.

PostSun Mar 11, 2018 11:58 am

I also got this GPU memory full thing in the latest version (14.3). Is it normal to get this with just 1 minute of image and movie files already? I have a "AMD Radeon HD 7900" wwith 3 GB of RAM. Somehow I doubt that it is about to less RAM, when people are talking about GPU memory lack for 2 hours of material and I am here on just 1 minute andit already gives me this annoying message. I cannot even render the material out right now, even with cutting the render passages into 30 sec bits. It says soo often times that my GPU memory is full. This really cannot be, can it!?? My task manager not even says that my GPU memory is full (when the message comes, the windows task manager says 1,9 / 3,0 gb".

This field processing is already disabled and converting the movie files to constant framerate did also not help.


I got a log here:

http://www.tagirijus.de/clients/tmp/DaV ... 125107.zip
Offline

Sam Steti

  • Posts: 1084
  • Joined: Tue Jun 17, 2014 7:29 am
  • Location: France

Re: Your GPU Memory is full.

PostMon Mar 12, 2018 10:07 am

Hey,
Believe it or not, I've been having looks regularly on this kind of topic but never really had this issue (maybe a couple of time 2 years ago).
Yesterday was the first time but quickly solved. So I can say there are no real connection with the length of the clips, because it occurred 3 times on different parts of a TL playback which involves only a 7 mn clip...
BUT, as I've read here, it indeed involved mixed framerates, because I had a UHD 30 fps cartoon-like graphic clip (ProRes 4444) on a 25 fps TL with only PR 422 clips.
These clips (2 actually) come from what I made on Apple Motion and I firstly thought it was the reason because the app was still open (though it had happened very frequently without a hiccup), but no...

Normally I always change the fps of the Motion project I make (or anything on another app) to fit the 25 fps of my Resolve TLs destination, and this is probably the reason why I never have to deal with the full GPU message; yesterday I did not and it occurred...
Don't know if it will really help, cannot tell more about it, except maybe that it disappeared as soon as the specific clips were cached (smart, output, ...).
Legacy MacPro 8core Xeons, 32 Go ram, 2 x gtx 980 ti, 1SSD for system, 2 SSDs raid0 for footage and caches, OSX ElCap and Sierra, Resolve 15 Studio
Offline

Manuel Senfft

  • Posts: 6
  • Joined: Sun Feb 26, 2017 10:10 pm

Re: Your GPU Memory is full.

PostMon Mar 12, 2018 12:36 pm

Thanks for this feedback. I will look further into the project and if I maybe missed some clips which have different framerates or similar. I somehow hope so ... :?
Offline

Chris Blake

  • Posts: 3
  • Joined: Thu Nov 30, 2017 8:00 pm

Re: Your GPU Memory is full.

PostTue May 08, 2018 8:10 pm

I mentioned above that: "I can edit a simple 4k project my macbook pro with its under-powered 2GB AMD R9 M370X, but with my more powerful nvidia GTX 670 (2GB) windows machine I get constant GPU full errors for the same project."

I never did mange solve this with my gtx 670. It seems to me that, in my experience, Resolve needs much more graphics capability to run on a windows machine compared to mac, or it is better tuned for amd on macs compared to nvidia on windows (i.e. known quantity on a mac, in the same way Apple can tune fcpx). Or some other reason, but ultimately the experience with a low spec card on a mac laptop, for me, was better than editing the same project on a higher spec windows 10 desktop. The mac was still v slow and painful, but at least it wasn't constantly failing with GPU memory full messages

For me, the only way to get around this issue with the pc version of Resolve was to upgrade the card. I have yet to experience the gpu full issue on a my new gtx 1060 with 6GB ram. The main thing is, I'm now back up and running on my PC, which for me (given the cost of upgrading with Apple) is my preferred/most cost effective option. :)
Offline

JosiahThiesen

  • Posts: 6
  • Joined: Mon Oct 23, 2017 3:02 am

Re: Your GPU Memory is full.

PostFri Oct 05, 2018 12:11 am

I'm in the middle of a 5K Red project. 3 timelines, 2 minutes long with a few Fusion comps used for paint outs. I too had been getting the GPU memory full error... to which I would yell at the computer... then take a breath and get back to work! That did not work.

I have two 770 SLI GPUs and 32gb of System Memory.

What seems to be working is reducing the amount of System memory allocated to Fusion. In preferences, REsolve 15 gives the ability to set memory used for Resolve and for Fusion. If I reduce the Fusion memory by a few gigs... it renders and playback without the memory error. I've exported 3 timelines that had previously not been working, so I hope this is an actual solution and not just a temporary fix.
Offline

MishaEngel

  • Posts: 128
  • Joined: Wed Aug 29, 2018 12:18 am
  • Real Name: Misha Engel

Re: Your GPU Memory is full.

PostFri Oct 05, 2018 12:24 am

JosiahThiesen wrote:I have two 770 SLI GPUs and 32gb of System Memory.


Remove the SLI bridge and it will work even better.
Offline

ranghaal

  • Posts: 1
  • Joined: Sun Oct 07, 2018 3:12 pm
  • Real Name: Ralf Langer

Re: Your GPU Memory is full.

PostSun Oct 07, 2018 3:32 pm

I get this Message instantely after loading a picture with more that 1920 x 1080, regardless of timeline settings. I even tried the lowest resolution (around 720 I guess) without any processing(!)

I tried 1920 x 1920 -> BAM!

I need a higher resolution because I rotate the picture and zoom in. So I need a higher resolution than the output (Full HD).

NVIDIA drivers.
Offline

Carlos Anguiano

  • Posts: 8
  • Joined: Sun Dec 14, 2014 12:22 am

Re: Your GPU Memory is full.

PostWed Oct 10, 2018 8:33 am

I'm getting the gpu memory error...
Windows 10
NVida gtx 1080 (8.0gb)
64gb RAM
processor intel i7-6850k
Davinci 15.1.1.005

only one clip in the time line (1:08:17) Photo JPEG 4096x2160

I'm trying to work in Ultra HD, but i can only work in 1080p

I've narrowed down the temporal noise reduction as the culprit, i can only use one node....

I'm currently splitting the clip into Reg Green and Blue, and denoising each channel and recombining (avoid the funky warp effect)


I'm attaching a image of my color correction tree, pretty simple....
i can replicate 100% of the time even with out the nodes previous to the split...

So far, the only fix is to work in 1080p monitoring my GPU memory doesn't seem to get higher than 57% (according to CPUID HWMonitor)

https://drive.google.com/file/d/1U8haNY ... sp=sharing
https://drive.google.com/file/d/1vtqFfl ... sp=sharing
Offline
User avatar

Dwaine Maggart

Blackmagic Design

  • Posts: 4471
  • Joined: Wed Aug 22, 2012 2:53 pm

Re: Your GPU Memory is full.

PostWed Oct 10, 2018 4:56 pm

Do a Project Export of that project and provide a link to the .drp file.

Also do a Resolve Diagnostics log (from the Resolve Help menu) and provide a link to that.

Open Windows System Information and do a File - Save and provide a link to the .NFO file.
Dwaine Maggart
Blackmagic Design DaVinci Support
Previous

Return to DaVinci Resolve

Who is online

Users browsing this forum: Boris Kovalev, Jim Jordan, Lawrence Arnold, Paul Dore, Steve Alexander and 37 guests