Page 1 of 1

Resolve cache location wont change

PostPosted: Sat Apr 06, 2013 1:41 pm
by mark brindle
Hi

i installed Resolve Lite on a machine that had a volume called FAST. I have moved over to a newer machine and installed a new version of Resolve lite over the top of previous version that was 'migrated' and i no longer have a volume with that name on my new machine.

However, Resolve tries to write render cache files to volume FAST no matter what i do.
I have checked project settings and settings for Resolve and these do not contain any reference to volume FAST.
I did originally get 'failed to write' errors for volume FAST and it seems my MAC has decided to create me a folder called /Volumes/FAST on my system drive, which is worse as its the slowest drive in my system!

My GPU is doing 19fps so i probably dont need render cache but i don't want all these hidden files being created.

i have tried removing this folder i have restarted Resolve and reset the Media Storage folder settings multiple times to no avil.

Every new project i create tries to use this same Volume/FAST even though there is no reference to it.

Can i edit a file somewhere to get rid of it or should i remove Resolve completely and install it again ?
thanks

Re: Resolve cache location wont change

PostPosted: Mon Apr 08, 2013 2:14 pm
by mark brindle
Ive managed to fix this after going through every project and removing the correct and incorrect cache and gallery locations and saving. For some projects i had to do this multiple times to get the new locations to stick but its working now.

Re: Resolve cache location wont change

PostPosted: Mon Oct 08, 2018 10:24 pm
by Dragonstone
I have the same problem. But when I change the cache location it won't change. It will change for .gallery but not for CacheClip.
And I have the latest version of Resolve 15.1.1

Re: Resolve cache location wont change

PostPosted: Thu Oct 11, 2018 9:59 am
by Dragonstone
I've tried changing the settings in all my projects. Deleting them, starting a new project, uninstalling the program reinstalling it, deleting the the cache folders, assigning them to other drives, deleting the Blackmagic folders in documents and Roaming folders. Nothing works! :(

Can anybody help please?

Re: Resolve cache location wont change

PostPosted: Thu Oct 18, 2018 12:09 am
by Jason Tackaberry
Yup, same problem. The old cache location is removed, replaced by a new one, but Resolve insists on writing to the old location.

It's clearly a bug.

(Resolve 15.1.2 on Windows.)

Re: Resolve cache location wont change

PostPosted: Thu Oct 18, 2018 12:42 am
by Jason Tackaberry
I found a solution, but it's relatively advanced so not for the faint of heart ...

I noticed that if I created a new database, the new location was properly being used for cache.

I wanted to change my Resolve media storage location from F:\Data\Resolve to H:\Data\Resolve. Even after changing the media storage location in settings, I found a pile of stray references to the old location in my Resolve database directory. (I'm using the local database rather than postgres.)

So I just decided to brute-force a search-and-replace in my existing Resolve database directory.

This works on Windows using WSL (Windows Subsystem for Linux). The same should work on Linux, and I assume Mac too.

Code: Select all
user@host:~$ sudo apt-get install sqlite3

user@host:~$ cd /mnt/f/Projects/Video/Resolve\ Disk\ Database/

user@host:/mnt/f/Projects/Video/Resolve Disk Database/Resolve Projects$ find -name '*.xml' -exec grep -l 'F:\\Data\\Resolve' "{}" \; | xargs sed -i 's,F:\\Data\\Resolve,H:\\Data\\Resolve,'

user@host:/mnt/f/Projects/Video/Resolve Disk Database/Resolve Projects$ find -name '*.db' -exec grep -l 'F:\\Data\\Resolve' "{}" \; | while read db; do sqlite3 "$db" "update SM_UserSetup set GalleryPath='H:\Data\Resolve\.gallery', CachePath='H:\Data\Resolve\CacheClip';"; done

Re: Resolve cache location wont change

PostPosted: Fri Dec 21, 2018 8:32 pm
by Buckwheat
Short of re-writing code like the last poster has done is there any other solutions to this problem. Very frustrating having this not function like it should.

Re: Resolve cache location wont change

PostPosted: Mon Feb 04, 2019 9:42 pm
by Dragonstone
Hey guys, sorry for the late post. I found the solution some time ago but forgot to post.

The problem was that I didn't have assigned the drive my cache folder was in, the "Media Storage Locations" in the Preferences menu.

So you need to go to in the menu bar (on Windows) to "DaVinci Resolve > Preferences > Media Storage" and click on "Add" and add your drive either in as a root. Or point to the exact specific folder your custom cache folder is located.

But remember if you don't just add the drive as a root and point to a spesific folder. And afterwards you move your cache folder outside of that specific folder, but still in the same drive, you then need to "Add" that location again in the "Media Storage" tab.

And you only need to do this one time.

Hope this helps.
Cheers