50fps source, 25fps timeline, 1/2 speed 25fps delivered??

Get answers to your questions about color grading, editing and finishing with DaVinci Resolve.
  • Author
  • Message
Offline

wildtypitch

  • Posts: 11
  • Joined: Wed Mar 21, 2018 12:25 pm
  • Real Name: Nathaniel McMahon

50fps source, 25fps timeline, 1/2 speed 25fps delivered??

PostWed Mar 21, 2018 12:32 pm

Having an issue trying to get Resolve to output 50 fps source footage at 25 fps without altering the speed. At the moment my timeline is set to 50fps playback so plays fine in edit, timeline is set to 25fps. But any delivered output is half speed. I'd rather it drop half the frames than stretch 50fps to 25. What am I missing?
Offline

Uli Plank

  • Posts: 4409
  • Joined: Fri Feb 08, 2013 2:48 am

Re: 50fps source, 25fps timeline, 1/2 speed 25fps delivered?

PostWed Mar 21, 2018 5:02 pm

Make sure that your clip shows 50 fps under it's attributes, but set the TL to 25.
You footage should run at normal speed then.
Resolve Studio and Fusion Studio
iMac 2017 Radeon Pro 580 8 GB VRAM and 32 GB RAM
Offline

wildtypitch

  • Posts: 11
  • Joined: Wed Mar 21, 2018 12:25 pm
  • Real Name: Nathaniel McMahon

Re: 50fps source, 25fps timeline, 1/2 speed 25fps delivered?

PostWed Mar 21, 2018 5:47 pm

Uli Plank wrote:Make sure that your clip shows 50 fps under it's attributes, but set the TL to 25.
You footage should run at normal speed then.

Confirmed all clips are set to 50 and timeline is 25.
Still output is 25fps and half speed
Offline
User avatar

Dwaine Maggart

Blackmagic Design

  • Posts: 4917
  • Joined: Wed Aug 22, 2012 2:53 pm

Re: 50fps source, 25fps timeline, 1/2 speed 25fps delivered?

PostWed Mar 21, 2018 9:02 pm

Are you using Individual Clips or Single Clip render mode?
Dwaine Maggart
Blackmagic Design DaVinci Support
Offline

wildtypitch

  • Posts: 11
  • Joined: Wed Mar 21, 2018 12:25 pm
  • Real Name: Nathaniel McMahon

Re: 50fps source, 25fps timeline, 1/2 speed 25fps delivered?

PostWed Mar 21, 2018 10:59 pm

Single clip output, in out range selected. Comprised of multiple 50fps clips.
Offline

wildtypitch

  • Posts: 11
  • Joined: Wed Mar 21, 2018 12:25 pm
  • Real Name: Nathaniel McMahon

Re: 50fps source, 25fps timeline, 1/2 speed 25fps delivered?

PostThu Mar 22, 2018 2:03 am

Very strange, so the output clip is twice the intended length, The audio is the right length and finishes half way. the movie stops half way ( at the intended end) but having only played half the footage at half speed.
Offline
User avatar

Dwaine Maggart

Blackmagic Design

  • Posts: 4917
  • Joined: Wed Aug 22, 2012 2:53 pm

Re: 50fps source, 25fps timeline, 1/2 speed 25fps delivered?

PostThu Mar 22, 2018 4:18 am

Something seems wrong. If you leave the clip frame rate at it's native mode (50FPS), the clip should play at the correct speed on the 25 FPS timeline. Frames will be dropped to make that happen.

But you said you've set your playback rate to 50 FPS. That SHOULD make the clip play back at double speed. If it's playing back normally, then something is wrong somewhere.

Something is making the clip play at half speed. And that's why it's rendering at half speed.

If you had changed the clip attributes frame rate to 25 FPS, this is the exact behavior I would expect. Can you right click the clip in the Media Pool, select Clip Attributes, and make sure the Video Frame Rate is 50, and not 25?
Dwaine Maggart
Blackmagic Design DaVinci Support
Offline

Andrew Kolakowski

  • Posts: 4815
  • Joined: Tue Sep 11, 2012 10:20 am

Re: 50fps source, 25fps timeline, 1/2 speed 25fps delivered?

PostThu Mar 22, 2018 10:21 am

As a test you can also try new project instead of doing it in existing one.
Offline

wildtypitch

  • Posts: 11
  • Joined: Wed Mar 21, 2018 12:25 pm
  • Real Name: Nathaniel McMahon

Re: 50fps source, 25fps timeline, 1/2 speed 25fps delivered?

PostThu Mar 22, 2018 1:41 pm

Yes, can't try that now but I'm pretty sure everything is set up right. I have a being suspicion that I set this project up with the timeline in the wrong frame rate then changed it after inserting some clips in the timeline and doing some workaround solution to change it which likely has resulted in this problem. That's was a long time ago. Since have done a lot of work. Sounds like I'm going to have to start from scratch.
Last edited by wildtypitch on Fri Mar 23, 2018 10:42 am, edited 1 time in total.
Offline

Ryan Payne

  • Posts: 225
  • Joined: Sat Apr 15, 2017 6:48 am

Re: 50fps source, 25fps timeline, 1/2 speed 25fps delivered?

PostThu Mar 22, 2018 9:44 pm

Jumping in here to say ive had an issue with the same thing.

Created a premiere XML from the premiere project which had a timeline of 25p with some 50p footage conformed to play at 25 in slow motion but it also had some of the 50p footage play back at normal speed. It also had an interview shot at 25p.

I could not for the life of me figure out how to ensure each clip played back correctly, using each of the frame rate options when importing the XML (resolve, final cut etc.) Would cause some clips to show up as still frames, using none caused all of the footage that was 50p to play back/ render in slow motion.

The clip attributes had the fps set to 50 but greyed out and I was unable to change it. Having everything in slow motion moved each clip along it's in and out points.

In the end I just had to created a whole new project with the source clips shot at 50p to render them all at 50p, then relink them as offline media in premiere. This took ages, wasted a lot of time.

Surely there's a better way? But anyway ops issue may be caused because it came from an XML?
Offline

Andrew Kolakowski

  • Posts: 4815
  • Joined: Tue Sep 11, 2012 10:20 am

Re: 50fps source, 25fps timeline, 1/2 speed 25fps delivered?

PostThu Mar 22, 2018 9:58 pm

Well, going over XML when you change speed, have different fps assets etc. is is asking for problems for sure. Often this doesn't work inside single app.
Offline

Ryan Payne

  • Posts: 225
  • Joined: Sat Apr 15, 2017 6:48 am

Re: 50fps source, 25fps timeline, 1/2 speed 25fps delivered?

PostThu Mar 22, 2018 11:02 pm

Andrew Kolakowski wrote:Well, going over XML when you change speed, have different fps assets etc. is is asking for problems for sure. Often this doesn't work inside single app.


Mm what would be the best way to tackle this in the future? It must be edited in premiere the come over to resolve.
Offline

Andrew Kolakowski

  • Posts: 4815
  • Joined: Tue Sep 11, 2012 10:20 am

Re: 50fps source, 25fps timeline, 1/2 speed 25fps delivered?

PostThu Mar 22, 2018 11:22 pm

Shot end edit in native fps :D
Seriously - I don't think there is an easy and good solution for it.
FCP XML is not going to be interpreted by different apps in the same way as different apps do things differently. Even fairly simple things like fade don't translate well sometimes, so things like e.g. speed change will about never translate well. Maybe I'm to sceptic. Any fps change is always a huge problem- even halving fps is in reality problematic as motion blur is different.

Some solution- if you do use speed change etc. then normalise (by making new files, not by in-app interpretation) all clips to final fps and then edit and exchange over XML.
Offline

Brian Breheny

  • Posts: 3
  • Joined: Wed Apr 26, 2017 9:07 am

Re: 50fps source, 25fps timeline, 1/2 speed 25fps delivered?

PostTue Oct 23, 2018 9:30 pm

Dwaine Maggart wrote:Something seems wrong. If you leave the clip frame rate at it's native mode (50FPS), the clip should play at the correct speed on the 25 FPS timeline. Frames will be dropped to make that happen.

But you said you've set your playback rate to 50 FPS. That SHOULD make the clip play back at double speed. If it's playing back normally, then something is wrong somewhere.

Something is making the clip play at half speed. And that's why it's rendering at half speed.

If you had changed the clip attributes frame rate to 25 FPS, this is the exact behavior I would expect. Can you right click the clip in the Media Pool, select Clip Attributes, and make sure the Video Frame Rate is 50, and not 25?


Hi Dwaine,
Shot a project at50fps, made 25p timeline and slowed clips by 50% to render out as individual clips to send to editor after 1 light grade.Render of individual clips came out at 25p, had to export whole timeline as one clip to get 50fps slo mo. Am I missing something? Changed attributes but to no avail
Thanks in advance
Offline
User avatar

Dwaine Maggart

Blackmagic Design

  • Posts: 4917
  • Joined: Wed Aug 22, 2012 2:53 pm

Re: 50fps source, 25fps timeline, 1/2 speed 25fps delivered?

PostThu Oct 25, 2018 12:43 am

Individual Clip render renders source clips at the source clip frame rate.

This is why the Deliver page frame rate selection disappears when you select Individual Clip render mode.
Dwaine Maggart
Blackmagic Design DaVinci Support
Offline

MarcKubik

  • Posts: 9
  • Joined: Tue Oct 10, 2017 12:53 pm

Re: 50fps source, 25fps timeline, 1/2 speed 25fps delivered?

PostThu Nov 15, 2018 8:42 am

And is there any way to render one or two "Individual Clip" at the desired frame rate like 50% e.g.?


Dwaine Maggart wrote:Individual Clip render renders source clips at the source clip frame rate.

This is why the Deliver page frame rate selection disappears when you select Individual Clip render mode.
Offline
User avatar

Dwaine Maggart

Blackmagic Design

  • Posts: 4917
  • Joined: Wed Aug 22, 2012 2:53 pm

Re: 50fps source, 25fps timeline, 1/2 speed 25fps delivered?

PostFri Nov 16, 2018 4:18 am

Use Single Clip render mode.
Dwaine Maggart
Blackmagic Design DaVinci Support
Offline

dstbst

  • Posts: 10
  • Joined: Tue Feb 27, 2018 6:59 am
  • Real Name: Dustin Rush

Re: 50fps source, 25fps timeline, 1/2 speed 25fps delivered?

PostSat Feb 23, 2019 6:38 am

For anyone else who has this issue...I was having the same problem and found a workaround.

I have clips shot on a Blackmagic Pocket camera at 50fps that I want to render at 25fps (slow mo). I imported them into Resolve 15.2.2.7 and let the timeline be auto-adjusted to fit the clips. Playback of the clips in the timeline is regular speed. The playback frame rate in the timeline format master settings for the project is set to 50. The Timeline frame rate is locked at 50 (cannot be changed).

Annotation 2019-02-22 223235.jpg
Annotation 2019-02-22 223235.jpg (70.15 KiB) Viewed 247 times


When I try to render the clip using the "Single Clip" mode the frame rate drop down only allows me to select 50. There are no other options in the drop down.

If I change the project settings Playback frame rate to 25, the clip plays in slow motion in the timeline but still I am only able to export the clip at 50fps. There are no other options available in the drop down:

Annotation 2019-02-22 220930.jpg
Annotation 2019-02-22 220930.jpg (62.09 KiB) Viewed 247 times


So like Dwaine was saying (I think) I had to create a new project with 25fps as the timeline frame rate. I imported the 50fps footage but didn't let Resolve change the timeline settings. I set the timeline settings to 25fps. Playback in the timeline was then slow motion and I was able to export a 25fps clip. Still no other options were in the frame rate drop down on the render page, but since my timeline was at 25fps the render settings where correct and produced the slow mo clip I needed.

Return to DaVinci Resolve

Who is online

Users browsing this forum: Alexander Nikishin, Google [Bot], Google Feedfetcher, Igor Riđanović, John Avenoso, xunile and 42 guests