Audio Crackles & Pops after Export?

Get answers to your questions about color grading, editing and finishing with DaVinci Resolve.
  • Author
  • Message
Offline

DJ John L

  • Posts: 6
  • Joined: Wed Jan 09, 2019 12:09 pm
  • Real Name: John-Lawrence Fagan

Audio Crackles & Pops after Export?

PostWed Jan 09, 2019 12:23 pm

Hi, Im pretty new to Resolve but have been enjoying it and prefer it greatly to PP.

I do have this one recurring issue however. All audio is perfect on the timeline and in fairlight, however when exported, certain clips on the final video have crakling and popping in them.

Example: @ 0:45 !


The only difference in this clip and the rest in the video is that it was shot in 1080/59.94 and the rest was shot in 1080/23.98

The Audio bitrate on both the crackling and non crackling clips is 254kbps @48.000kHz Dual channel

Everything was shot with a Canon Eos200d/SL2

Resolve 15.2.2.007

I have tried all possible types of export settings and nothing seems to fix it. I could of course import all files into PP for uniform export to then edit them further in resolve but this is a cumbersome extra step Id rather not introduce.

Any help would be massively appreciated!

Thanks,
JL
Offline

DJ John L

  • Posts: 6
  • Joined: Wed Jan 09, 2019 12:09 pm
  • Real Name: John-Lawrence Fagan

Re: Audio Crackles & Pops after Export?

PostThu Jan 10, 2019 7:52 pm

Sorry I should add some more info:
My Specs:
Ryzen 5 2600
8gb 2200mhz DDR4
GTX680 4GB
WD SSD

Audio setup:
Native Instruments Komplete Audio 6 interface

Ran into the same issue again tonight. Different project except this time it happened on a clip that was the same framerate as everything else. The crackling also appears in the timeline after the export.
Had to redo the entire project in PP. No problems at all.

This is really getting at me. I've tried different sample rates, framerates, cameras and nothing is immune to this seemingly random crackling appearance.

Really any help would be massively appreciated as I love Resolve and don't want to be forced back to PP.

Thanks,
John
Offline

Shrinivas Ramani

Blackmagic Design

  • Posts: 220
  • Joined: Wed Sep 20, 2017 10:19 am

Re: Audio Crackles & Pops after Export?

PostFri Jan 11, 2019 10:01 am

Which OS? Are you using the Studio version?

Could I request a log archive?

If you are able to, could you also include a copy of your project (an exported drp file) and a sample audio clip

Thanks
Shrinivas
Offline

DJ John L

  • Posts: 6
  • Joined: Wed Jan 09, 2019 12:09 pm
  • Real Name: John-Lawrence Fagan

Re: Audio Crackles & Pops after Export?

PostFri Jan 11, 2019 5:05 pm

Hello Shrinivas,

Thank you very much for getting back to me and not leaving me stranded.
I am was using the latest Resolve 15 Free Version on Windows 10 Home.

Here is an example @0:35:


The clip in the car was shot the same way every other clip in the video was. (Eos200D) 1080p @ 23/59fps (depending on the clip). In another project the problem appeared whilst editing a clip that was no different at all from the ones before or after it.

I tried everything again this morning namely resetting options, matching sample rates on my interface, uninstalling realtek drivers but to no avail. I reverted to 14.3 to see if it would fix my issue but that has yet to be seen in my new project. As soon as I have it exported I will reinstall v15 and generate the log archive and drp file in 15 for you.

For now I have generated the Log files for 14.3 also.
https://drive.google.com/open?id=1xJaeP ... ZRgNiRtdZG

Thank you very much for your response. I absolutely love resolve and don't want to have to stop using it!
Offline

DJ John L

  • Posts: 6
  • Joined: Wed Jan 09, 2019 12:09 pm
  • Real Name: John-Lawrence Fagan

Re: Audio Crackles & Pops after Export?

PostFri Jan 11, 2019 8:32 pm

I have accidentally found a way to recreate the issue accurately in Resolve 14.3.0.014

It reproduces this in the timeline ONLY. Exporting in 14 does not carry the crackling on into the final file as Exporting in 15 does.

From the start:
I created a project from scratch with the project settings in attachment 1.
*Note here that I set the timeline framerate to 29.97. I did NOT change anything else. Video format & Playback Framerate options were left on 23.97

Then I imported a clip that I rendered out previously.
MP4 1920x1090 29.97fps (Standard Resolve MP4 settings at "Best")

This results in the following sound:
https://drive.google.com/open?id=1IKnIL ... zcbcaXS_px

The problem goes away when changing the project settings as shown in attachment 2
(Video format & Playback Framerate to 29.97 instead of just timeline framerate)

I rendered the file just to test it whilst the crackling was occurring on the timeline and the rendered file did NOT contain the same crackling as it did in Resolve 15.

Logs:
https://drive.google.com/file/d/1nPOe8h ... sp=sharing

DRP:
https://drive.google.com/open?id=1F9Vah ... vn9z5A5b_G

This is the exact same crackling I was experiencing in 15.
It appears to me that this crackling would also arise when having clips of different framerates within one project (60 & 23.97 fps shots on a 23.97 fps timeline, not something uncommon for anyone to do). I don't mind this happening in real time on the timeline. It does however become an issue for me in 15 when the Rendered file contains the same crackling.

Hope this helps somewhat. Thanks for your support.
Attachments
Project settings 2.JPG
Project settings 2.JPG (167.22 KiB) Viewed 92 times
Project settings 1.JPG
Project settings 1.JPG (169.31 KiB) Viewed 92 times
Offline

DJ John L

  • Posts: 6
  • Joined: Wed Jan 09, 2019 12:09 pm
  • Real Name: John-Lawrence Fagan

Re: Audio Crackles & Pops after Export?

PostMon Jan 14, 2019 6:39 am

Went back to Resolve 15.2.2.007 today and once again lost hours worth of work due to this bug.

Resolve 14 worked fine for me. Is there any way to convert a 15 project file to 14 so I can Rerender it without issues?

Logs, DRP & Audio Below:

https://drive.google.com/open?id=1UiMcH ... ka0jDeO6gX
Offline

Uli Plank

  • Posts: 3869
  • Joined: Fri Feb 08, 2013 2:48 am

Re: Audio Crackles & Pops after Export?

PostMon Jan 14, 2019 9:57 am

You can only try an XML export and import that into 14. Projects are not backward compatible.
Resolve Studio and Fusion Studio
iMac 2017 Radeon Pro 580 8 GB VRAM and 32 GB RAM
Offline

DJ John L

  • Posts: 6
  • Joined: Wed Jan 09, 2019 12:09 pm
  • Real Name: John-Lawrence Fagan

Re: Audio Crackles & Pops after Export?

PostMon Jan 14, 2019 10:31 am

Super I'll try that Uli, Thanks!

Return to DaVinci Resolve

Who is online

Users browsing this forum: dirk-pel, Google [Bot], Mark Sterne, Mathematics, mister_cg, Theo Ribeiro and 32 guests