The Project could not be loaded in collaboration mode

Get answers to your questions about color grading, editing and finishing with DaVinci Resolve.
  • Author
  • Message
Offline

AndreasOberg

  • Posts: 343
  • Joined: Wed Sep 25, 2013 9:09 am

The Project could not be loaded in collaboration mode

PostFri Aug 30, 2019 11:16 am

I managed to setup postgreSQL on our QNAP NAS and create a database.
Both workstations connect with individual 10GbE cables to the NAS. NAS is not connected to internet.
Both workstations also has 1GB network connected to a router that connects to the internet.

Everything works fine, except when I click on a timeline that the other project has open I get this:

"The project could not be loaded in collaboration mode as Resolve as Resolve was unable to establish a connection to communicate with other users.
Please ensure that the machines are not connected using a VPN and that Davinci Resolve is not being blocked by the system firewall."
Then the project is instantly closed.

1. No VPN
2. We use Norton and Resolve is set to allow on both computers.
3. I also checked the channel 56789 and no other programs are using this channel on any of the computers. Resolve seems to not use this channel either however.
4. We both use identical versions of Resolve
5. Both is Windows base, no mac. The NAS I guess is QNAP Linux.
6. PostgreSQL version on NAS is 9.3.13. For macOS I know 9.5 is needed but this should be fine since its not Mac, right? (As I understand 8.4 is used then)

I do not have postgreSQL installed on the workstations so Resolve Project Server cannot launch. Is that a problem? It just did not seem like a point to install postgreSQL on our workstations when we have it on the NAS.

I followed this tutorial on how to set it up.
https://www.qnap.com/en-au/how-to/tutorial/article/how-to-host-a-multi-user-collaborative-environment-for-davinci-resolve-15-studio/
Any pointers?

Thanks
Andreas
Consulting Lead VFX Microsoft Games/Rare Ltd
Offline

AndreasOberg

  • Posts: 343
  • Joined: Wed Sep 25, 2013 9:09 am

Re: The Project could not be loaded in collaboration mode

PostFri Aug 30, 2019 9:28 pm

Been trying several things and can still not collaborate.
Contacting the database from both workstations works solid. It seems to be the connection between the two Davinci. I'm thinking that its trying to contact each other through the router 1GB network that we also use to connect to internet and somehow fails. I'm guessing it does not go through the 10GbE that the NAS uses. Will try to see how well these 2 computers can actually talk to each other and maybe that will clear it up.

Andreas
Consulting Lead VFX Microsoft Games/Rare Ltd
Offline

Danielrutledge

  • Posts: 8
  • Joined: Tue Sep 24, 2013 12:29 pm

Re: The Project could not be loaded in collaboration mode

PostWed Sep 11, 2019 6:54 pm

Keep me posted. I am looking into a similar setup, but on Mac and with up to 6 users (not all at once. Probably there will be 3 edit stations, and then producers and a designer accessing the QNAP). Once you get the bugs worked out, I'd be interested in hearing any advice.
Offline
User avatar

Dwaine Maggart

Blackmagic Design

  • Posts: 5512
  • Joined: Wed Aug 22, 2012 2:53 pm

Re: The Project could not be loaded in collaboration mode

PostWed Sep 11, 2019 9:08 pm

Are both machines on the same subnet (i.e. the first 3 octets of the IP address match)? They need to be.

Resolve can use a range of ports for the cross Resolve communication link. If one is in use by another app, it will increment until it finds a free one.

Prior to 15.2, we did use port 56789. But that port is no longer used. We now use a port in the range of 50059 to 50314. If port 50059 is in use by something else, we'll increment to find the next available port.

So it's very likely your firewall is blocking the port. As a test, disable the firewalls on both machines, and that will quickly prove if that's where the issue is.
Dwaine Maggart
Blackmagic Design DaVinci Support

Return to DaVinci Resolve

Who is online

Users browsing this forum: Bing [Bot] and 41 guests