Jump to: Board index » General » Fusion

[BUG] Displace tool + Expressions

Learn about 3D compositing, animation, broadcast design and VFX workflows.
  • Author
  • Message
Offline
User avatar

Serge Ilinov

  • Posts: 11
  • Joined: Tue Nov 18, 2014 2:41 pm
  • Location: ru-mo

[BUG] Displace tool + Expressions

PostSun Nov 30, 2014 4:35 pm

Hmm.. seems I can't connect to any of "Displace" tool attributes by an expression..
(haha and I can't attach a Fusion *.comp file to this Fusion forum :o so there is an copypasta :ugeek: )

Code: Select all
{
   Tools = ordered() {
      FastNoise1 = FastNoise {
         Inputs = {
            Width = Input { Value = 400, },
            Height = Input { Value = 300, },
            ["Gamut.SLogVersion"] = Input { Value = FuID { "SLog2", }, },
            Contrast = Input { Value = 3.6285714, },
            XScale = Input { Value = 14, },
            Gradient = Input {
               Value = Gradient {
                  Colors = {
                     [0] = { 0, 0, 0, 1, },
                     [1] = { 1, 1, 1, 1, },
                  },
               },
            },
         },
         ViewInfo = OperatorInfo { Pos = { 419, -43, }, },
      },
      Blur1 = Blur {
         CtrlWZoom = false,
         Inputs = {
            XBlurSize = Input { Expression = "Displace1.Offset", },
            Input = Input {
               SourceOp = "Displace1",
               Source = "Output",
            },
         },
         ViewInfo = OperatorInfo { Pos = { 554, 37, }, },
      },
      Text1 = TextPlus {
         Inputs = {
            Width = Input { Value = 400, },
            Height = Input { Value = 300, },
            ["Gamut.SLogVersion"] = Input { Value = FuID { "SLog2", }, },
            Size = Input { Value = 0.0928571, },
            Font = Input { Value = "Arial", },
            StyledText = Input { Value = "This is a bug?\r\nSeems I can't use \r\nDisplace tool as a source\r\nfor expressions connections", },
            Style = Input { Value = "Bold", },
            ManualFontKerningPlacement = Input {
               Value = StyledText {
                  Array = {
                  },
                  Value = "",
               },
            },
            ShadingGradient1 = Input {
               Value = Gradient {
                  Colors = {
                     [0] = { 0, 0, 0, 1, },
                     [1] = { 1, 1, 1, 1, },
                  },
               },
            },
            RenderToDPTFile = Input { Disabled = true, },
            DPTType = Input { Disabled = true, },
            DPTResolution = Input { Disabled = true, },
         },
         ViewInfo = OperatorInfo { Pos = { 284, 39, }, },
      },
      Displace1 = Displace {
         CtrlWZoom = false,
         Inputs = {
            Offset = Input { Value = 0.5, },
            RefractionStrength = Input { Value = 0.1142857, },
            Input = Input {
               SourceOp = "Text1",
               Source = "Output",
            },
            Foreground = Input {
               SourceOp = "FastNoise1",
               Source = "Output",
            },
         },
         ViewInfo = OperatorInfo { Pos = { 421, 38, }, },
      },
      Note1 = Note {
         Inputs = {
            Comments = Input { Value = "I try to use any of Displace node attributes in Blur node.. But no luck.\r\nIt works fine in Fu6.4 though..", },
         },
         ViewInfo = StickyNoteInfo {
            Pos = { 680, -2, },
            Flags = {
               Expanded = true,
            },
            Size = { 201, 96.3, },
         },
      },
   },
}
hi there, pigsfly guys, it's me, robocop! ;b

Return to Fusion

Who is online

Users browsing this forum: No registered users and 9 guests