Jump to: Board index » General » Fusion

CL_MEM_OBJECT_ALLOCATION_FAILURE

Learn about 3D compositing, animation, broadcast design and VFX workflows.
  • Author
  • Message
Offline

AndyThirtover

  • Posts: 52
  • Joined: Sun Oct 04, 2015 12:01 pm

CL_MEM_OBJECT_ALLOCATION_FAILURE

PostSun Oct 18, 2015 3:45 pm

Good afternoon Forum

Its fairly obvious that CL_MEM_OBJECT_ALLOCATION_FAILURE means that memory can't be allocated.

However, I should like to know why.

Here's the console log from 8.0 build 16.

OpenCL clEnqueueNDRangeKernel failed: CL_MEM_OBJECT_ALLOCATION_FAILURE
Loader1 failed to load file "/Volumes/LaCie/guff/FusionTests/Doors/Doors.mov" (clip "/Volumes/LaCie/guff/FusionTests/Doors/Doors.mov" at frame 0) : Invalid argument
Loader1 failed at time 0
Loader1 failed to load file "/Volumes/LaCie/guff/FusionTests/Doors/Doors.mov" (clip "/Volumes/LaCie/guff/FusionTests/Doors/Doors.mov" at frame 0) : Invalid argument
Loader1 failed at time 0
OpenCL clEnqueueNDRangeKernel failed: CL_MEM_OBJECT_ALLOCATION_FAILURE
OpenCL clEnqueueNDRangeKernel failed: CL_MEM_OBJECT_ALLOCATION_FAILURE
OpenCL clEnqueueNDRangeKernel failed: CL_MEM_OBJECT_ALLOCATION_FAILURE
OpenCL clEnqueueNDRangeKernel failed: CL_MEM_OBJECT_ALLOCATION_FAILURE
OpenCL clEnqueueNDRangeKernel failed: CL_MEM_OBJECT_ALLOCATION_FAILURE
OpenCL clEnqueueNDRangeKernel failed: CL_MEM_OBJECT_ALLOCATION_FAILURE
OpenCL clEnqueueNDRangeKernel failed: CL_MEM_OBJECT_ALLOCATION_FAILURE
OpenCL clEnqueueNDRangeKernel failed: CL_MEM_OBJECT_ALLOCATION_FAILURE
OpenCL clEnqueueNDRangeKernel failed: CL_MEM_OBJECT_ALLOCATION_FAILURE
OpenCL clEnqueueNDRangeKernel failed: CL_MEM_OBJECT_ALLOCATION_FAILURE
OpenCL clEnqueueNDRangeKernel failed: CL_MEM_OBJECT_ALLOCATION_FAILURE

So there's an invalid argument - suggest frame 0 is corrupt?. The video loads and plays in quicktime.

Any thoughts?

Regards



Andy
Offline

Clayton Krause

  • Posts: 29
  • Joined: Tue Oct 31, 2017 3:31 pm

Re: CL_MEM_OBJECT_ALLOCATION_FAILURE

PostTue Oct 31, 2017 8:05 pm

You ever figure this one out? I'm getting the same error, but don't really know what is causing it. Thanks.
Offline

Kel Philm

  • Posts: 221
  • Joined: Sat Nov 19, 2016 6:21 am

Re: CL_MEM_OBJECT_ALLOCATION_FAILURE

PostWed Nov 01, 2017 7:27 pm

I found that I could improve stability of Fusion 8 (Windows) be re-encoding quicktimes to exr sequences instead and I am pretty sure that these were the errors I was getting.
Offline

Clayton Krause

  • Posts: 29
  • Joined: Tue Oct 31, 2017 3:31 pm

Re: CL_MEM_OBJECT_ALLOCATION_FAILURE

PostWed Nov 01, 2017 7:34 pm

I'm getting the error when rendering out still EXR frames from multiple savers. :/ It doesn't seem to affect anything, but it'd still be cool to figure out what it's barking at. Something to do with rendering apparently. :)
Offline
User avatar

Jed Mitchell

  • Posts: 77
  • Joined: Tue Nov 03, 2015 11:04 pm
  • Location: New York, NY

Re: CL_MEM_OBJECT_ALLOCATION_FAILURE

PostThu Nov 02, 2017 3:25 pm

Kel Philm wrote:I found that I could improve stability of Fusion 8 (Windows) be re-encoding quicktimes to exr sequences instead and I am pretty sure that these were the errors I was getting.


I have no evidence that Quicktime was the culprit, but I also stopped getting as many CL errors in the console when I stopped using Quicktimes in Loaders -- both on Win10 & OSX (Fu9). I was usually rendering the QTs back out to exr or dpx sequences as an intermediary step in my comps anyway, but just having them loaded (even if not piped to a viewer) seems to have caused those errors to pop up sometimes.
"It's amazing what you can do when you don't know you can't do it."

System:
DR15.1 | Win10 | i9 7940X | 128GB RAM | 2x 1080 Ti | 960Pro Cache Disk

Return to Fusion

Who is online

Users browsing this forum: Google Feedfetcher, Tanawat Wattanachinda and 3 guests