Jump to: Board index » General » Fusion

Matte Control - noob alert

Learn about 3D compositing, animation, broadcast design and VFX workflows.
  • Author
  • Message
Offline

Mark Sterne

  • Posts: 291
  • Joined: Wed Dec 17, 2014 6:15 pm

Matte Control - noob alert

PostWed Apr 20, 2016 2:13 am

Just starting with Fusion 8 and doing the first exercise in the current manual. I have a problem with "Combining a Foreground with an Alpha Channel" on page 42.

The manual appears to be confused at times about whether Hue Curves connects to foreground or background but I've worked out that foreground of Matte Control is correct and the UltraKeyer needs to feed the background.

The problem is that it doesn't work. The foreground does not appear in the output of the MatteControl. I have the same output as with the HueCurves tool in pass through.

Looking at the tool reference, it appears that the Copy Combine Op seeks to combine alphas from the foreground and the background, and there is no alpha in the foreground. I also looked for the Merge Over and Merge Under combine ops to try them, but they aren't there at all. The list ends at Or.

Anyone help a noob out and explain what I'm doing wrong? Thanks!
Offline
User avatar

Chad Capeland

  • Posts: 2239
  • Joined: Mon Nov 10, 2014 9:40 pm

Re: Matte Control - noob alert

PostWed Apr 20, 2016 2:44 am

The instructions are correct, the UltraKeyer connects to the foreground, and the HueCurves to the background.

Merge Over and Merge Under wouldn't apply here, since those are RGBA operations.

I wouldn't worry too much about the results of the tutorial. It shows you how the UI works, but I wouldn't recommend actually compositing that way. There's a lot of stuff in there that is not good for production comps.
Chad Capeland
Indicated, LLC
www.floweffects.com
Offline

Mark Sterne

  • Posts: 291
  • Joined: Wed Dec 17, 2014 6:15 pm

Re: Matte Control - noob alert

PostWed Apr 20, 2016 10:06 pm

Thanks, Chad. I finally got it working as expected; either the manual neglected to mention that I needed to check Post Multiply Image in the Matte Control, or I overlooked it.

I agree this is not the way to go about the operation, I just hate when I can't figure out why things don't work as it seems they should. :)

Return to Fusion

Who is online

Users browsing this forum: No registered users and 104 guests