Jump to: Board index » General » Fusion

Wrong transparency of particles with software renderer

Learn about 3D compositing, animation, broadcast design and VFX workflows.
  • Author
  • Message
Offline

John Tiefenbrunner

  • Posts: 14
  • Joined: Tue Mar 14, 2017 3:58 pm

Wrong transparency of particles with software renderer

PostTue Mar 14, 2017 4:28 pm

Hi everyone!

I'm currently evaluating Fusion (coming from Nuke) and ran into a strange issue with particles. I found one post regarding this from about a year ago
viewtopic.php?f=22&t=47690
and was wondering if this issue has been addressed in the meantime and I just don't know how to set this up right.

The issue is this:

When using the bitmap style of the particle emitter (in 3D mode) the transparency of overlapping particles is calculated wrong when using the software renderer. When using the OpenGL renderer everything is fine but to ensure consistency across different machines I would prefer the software renderer.

Interestingly enough this is only true for particles. If I replicate a few image planes and stack them up much like what the emitter produced - and let them use the exact same image (texture) - also the software renderer produces the correct result.

I've attached an image and a sample composition showing the issue. You can switch the renderer between OpenGL and software to see the difference. With the software renderer some of the circles have the wrong brightness and some show a strange outline in the overlapping areas.

Thanks in advance for any feedback!

Cheers!
John

PS: Using the Mac version of Fusion - if that makes a difference...
Attachments
ParticleTransparencyIssue_Zoom.png
ParticleTransparencyIssue_Zoom.png (234.8 KiB) Viewed 207 times
ParticleTransparencyIssue.comp.zip
(3.03 KiB) Downloaded 13 times
Offline
User avatar

michael vorberg

  • Posts: 672
  • Joined: Wed Nov 12, 2014 8:47 pm
  • Location: stuttgart, germany

Re: Wrong transparency of particles with software renderer

PostSat Mar 18, 2017 6:06 pm

i seems that there is still this issue

looks like a sorting issue, because it disappears with less particles or a bigger emitter
Offline

John Tiefenbrunner

  • Posts: 14
  • Joined: Tue Mar 14, 2017 3:58 pm

Re: Wrong transparency of particles with software renderer

PostMon Mar 20, 2017 5:27 pm

Michael,

thanks for your response. Yes, looks like a sorting issue (reducing the particles or increasing the emitter size leads to less overlaps and thus the problem does not show).

Could you give me a hint what the established bug reporting procedure is?

Cheers!
John


michael vorberg wrote:i seems that there is still this issue

looks like a sorting issue, because it disappears with less particles or a bigger emitter

Return to Fusion

Who is online

Users browsing this forum: No registered users and 2 guests