Page 1 of 1

Memory Problem

PostPosted: Wed Jun 14, 2017 3:27 pm
by Martin Ziebell
Hey Fusion People
I have the problem that rendering long sequences will fill up the memory either from the render nodes as from the main render machine. That means after 1300 frames more than than the 60% are allocated the machines get really slow and at the end after reaching around 45 GB memory the rendering breaks down ...

What is the problem ? I have not a complicate comp, just 3 4k layer nothing special...
Anyone has a solution for that?

Re: Memory Problem

PostPosted: Sun Jun 18, 2017 7:55 pm
by michael vorberg
maybe this topic can help you:


or this topic over at steakunderwater: ... 5684#p5684

Re: Memory Problem

PostPosted: Mon Jun 19, 2017 9:31 am
by Martin Ziebell
Thanks michael for your help.
I copied the script into the script folder in the comp folder, but there are only .lua scripts ...
Is there another place to copy this .eyonscript file for purching the memory?
kind regards from the summer in cologne

Re: Memory Problem

PostPosted: Mon Jun 19, 2017 3:52 pm
by michael vorberg
The script is from fusion 7, in fusion 8 the extension is changed to .lua and probably some parts need to change to fit the new Syntax.

Try to rename it to.lua and see if it works

Otherwise follow the other link, there is a solution with an expression which you can put into a saver

Re: Memory Problem

PostPosted: Mon Jun 19, 2017 7:48 pm
by Martin Ziebell
Hi Micheal

the script does not seemed to the memory rises up again...
I have not found any link to an expression in the saver node.
Could you please share this one?

kind regards from hot cologne


Re: Memory Problem

PostPosted: Tue Jun 20, 2017 8:28 pm
by michael vorberg
Code: Select all
fusion = eyeon.scriptapp("Fusion", "localhost")

i guess this should still work, goes into the "frame saved script"

but as in the other thread discussed: its nearly the same as setting the cache in the preferences to 0

you will lose some speed in the rendering, because each frame everything has to be calculated no chaching of static parts

Re: Memory Problem

PostPosted: Thu Jun 22, 2017 11:02 am
by Martin Ziebell
Dear Micheal

it looks like even this script does not change anything to the behaviour of fusion...
It s a pitty... I will try a complete uninstall and reinstall.

Thanks anyway for your help