Page 1 of 1

Fusion 9 OpenCL slower?

PostPosted: Thu Aug 03, 2017 11:34 pm
by David_Cox
Hi all,

Can anyone confirm they are seeing the same thing as me - openCL seems slower than CPU in Fusion 9?

Test - I took a DnxHR movie and connected it to a color corrector with an elliptical mask attached. So there was a circular color change in the middle of the frame.

With OpenCL OFF in the color corrector, playback was real time. With OpenCL on, playback dropped to 8FPS.

My system is 12 core CPU / 2 x NVidia Titan / Win 10 64bit / 64GB Ram / 600Mbytes-sec RAID.

Interestingly, GPU usage (as measured by GPU-Z) shows less than 4% usage with OpenCL on and around 6% usage with it off. Perhaps this is just due to more interface updates with the higher playback rate. I tried messing with the prefs>gpu settings, for example, specifically setting the target card, changing caching etc, but no difference.

Am I missing anything - any set up to enable the GPU?

Thanks :-)
DC

Re: Fusion 9 OpenCL slower?

PostPosted: Fri Aug 04, 2017 6:32 am
by Bryan Ray
I have noticed the same thing. I'm doing some more rigorous testing right now, comparing Fu8 to Fu9, with and without OpenCL enabled. So far, Fusion 9 with OCL is faster on a couple of tools, evenly matched on a few more, but noticeably slower on most. The system specs I have been testing with are similar to yours, but on Windows 7.

Re: Fusion 9 OpenCL slower?

PostPosted: Fri Aug 04, 2017 8:05 am
by Max Seredkin
The big scene in FUSION 9, including 3d and various processing threads, works with Opencl 30% slower than the same scene in FUSION 8

Re: Fusion 9 OpenCL slower?

PostPosted: Fri Aug 04, 2017 8:24 am
by Vladimir LaFortune
It's going to be a long road

Re: Fusion 9 OpenCL slower?

PostPosted: Fri Aug 04, 2017 5:34 pm
by Tomek Sadowski
Much slower. With demo spaceship project 2 times slower than Fu8.
GPU load is small (GTX1070). Checked on different OpenCL settings. (playing around 1.4fps)

Re: Fusion 9 OpenCL slower?

PostPosted: Sun Aug 06, 2017 10:32 am
by Phil Hoppes
I have found Fusion 9 to be at best only equal to Fusion 8 when rendering CPU only on Windows 10 and significantly slower when GPU rendering.

Below is a screenshot analysis that I did with a fairly sophisticated scene that renders one 4K frame (4096x2304) into a 16bit EXR file. I ran the render on my MacBook Pro and my Windows 10 workstation. The specs on both those machines are seen below the data. Note the Win10 workstation actually has 2xGTX1080 graphic cards NOT in SLI mode so they are specifically set up for GPU rendering. I rendered the scene with OpenCL setting at Auto, GPU, CPU for both Fusion 8 and Fusion 9 on both machines. Render times are in seconds.

Image

This is a screenshot of the node network. You can see the details but it's not trivial.

Image

Re: Fusion 9 OpenCL slower?

PostPosted: Sun Aug 06, 2017 1:14 pm
by Ryan Bloomer
The delta keyer is also about 2x as fast with 10bit 4k dpx sequences when turning off the OpenCL option. I've tried on two different computers, and different locations from the loader (network and local) looks like it is the OpenCL what's causing the slow down.

Re: Fusion 9 OpenCL slower?

PostPosted: Sun Aug 06, 2017 9:19 pm
by Kel Philm
I also ran a test with a heavy comp I have and found it ran around 7% slower in v 9.0 over v 8.2 on Win 10 with GTx 1080. Will try it with open CL switched of and see what happens.

Re: Fusion 9 OpenCL slower?

PostPosted: Mon Aug 07, 2017 2:10 am
by daniel.koch
One thing to check is your OpenCL caching pref. This defaulted to Off/disabled, which was fine for the few heavyweight OpenCL tools in Fusion 8 - but may actually slow down the many lighter tools in Fusion 9, because transferring images to and from GPU memory is relatively slow.

Full caching allows Fusion to pass GPU images from tool to tool without downloading back to system memory, so this is recommended for general OpenCL usage. Basic caching always downloads GPU images right after processing, but still passes it on to the next too, while turning caching off will minimise GPU memory usage at the cost of more transfer overhead.

Re: Fusion 9 OpenCL slower?

PostPosted: Mon Aug 07, 2017 4:44 am
by Bryan Ray
Turning on caching does significantly improve many of the tools I've tested, but it's still slower than OCL off.

Re: Fusion 9 OpenCL slower?

PostPosted: Sun Aug 13, 2017 5:31 am
by Hideki Inoue
New Delta keyer is great but extreme slow. I found OpenCL mode is slower than CPU. I made a simple comp that have 4K footage and just merge. It seemed to be slower than Fu7. I found OpenCL option in merge tool. :?

Win7 and Quadro K4200

Re: Fusion 9 OpenCL slower?

PostPosted: Mon Aug 21, 2017 11:23 am
by Hideki Inoue
BMD said a simple comp like only merging may be slower than CPU mode. Because Transfer of memory to GPU takes time. OK, I understood.

Please explain that defocus tool (default setting and defocus size is 10) is 14 times slower than Fu8s. Fu8 is 8.6 secs/frame. Fu9 is 120 secs/frame. Both is 4K footage and Of course OpenCL mode. :?

Re: Fusion 9 OpenCL slower?

PostPosted: Fri Aug 25, 2017 4:16 pm
by David_Cox
Hello,

I also got the same response from BM Support - that individual tools might be slower because of the time it takes to copy images to the GPU before it can start processing. They said that this won't be the case with "real world" comps where there are many tools, because images will be retained on the GPU. But that's not what I'm finding and to be honest, the transfer time thing doesn't really add up.

Transfer time from CPU RAM to GPU memory should be several gigabytes a second, so shouldn't add many milliseconds at all to the per-frame render time. But in a green screen test with the Delta Keyer, Color Corrector and a Merge, render times jumped from 0.2 seconds a frame CPU to 1.2 seconds a frame openCL. Transfer time of a 1920 x 1080 16 bit image shouldn't take a second!

Something isn't right - or am I missing something? Has anyone else found substantial speed improvements with OpenCL?

DC

Re: Fusion 9 OpenCL slower?

PostPosted: Wed Aug 30, 2017 7:18 pm
by Grant Tompkins
I hadn't realized how many tools now have OpenCL on by default ( merge, blur, etc ). I ended up turning off OpenCL off all together and things not only sped up but also became more stable.

Re: Fusion 9 OpenCL slower?

PostPosted: Mon Sep 04, 2017 7:15 am
by Hideki Inoue
Grant Tompkins wrote:I hadn't realized how many tools now have OpenCL on by default ( merge, blur, etc ). I ended up turning off OpenCL off all together and things not only sped up but also became more stable.


You can benefit from OpenCL only with a limited CPU and GPU combination. In my case, new OpenCL tools are slower than CPU. I don't know who has benefits? By the way, BMD's testing machine seems to be faster than CPU.

12Core/24Threads(Xeon X5690 x2) >>> Quadro K4200
2Core/4Threads(Kaby lake) >>> Intel Iris Plus Graphics 650

4Core/8Threads(Skylake Core i7) <<< GTX1080 (BMD's Testing machine)

And some GPU drivers may cause memory leak problems. You should test some versions.

Re: Fusion 9 OpenCL slower?

PostPosted: Fri Sep 15, 2017 9:14 am
by Mattias Lindberg
I have x4 GTX 1080 Ti. One would think that using GPU to speed up would make it faster.
But I rendered out a .comp 4K images in 2 minutes instead of 4 minutes with OpenCL off...

:|

Re: Fusion 9 OpenCL slower?

PostPosted: Sun Sep 17, 2017 1:26 pm
by Axel Mertes
Phil Hoppes wrote:I have found Fusion 9 to be at best only equal to Fusion 8 when rendering CPU only on Windows 10 and significantly slower when GPU rendering.

Below is a screenshot analysis that I did with a fairly sophisticated scene that renders one 4K frame (4096x2304) into a 16bit EXR file. I ran the render on my MacBook Pro and my Windows 10 workstation. The specs on both those machines are seen below the data. Note the Win10 workstation actually has 2xGTX1080 graphic cards NOT in SLI mode so they are specifically set up for GPU rendering. I rendered the scene with OpenCL setting at Auto, GPU, CPU for both Fusion 8 and Fusion 9 on both machines. Render times are in seconds.

[..]


Can you repeat the test by forcefully DISABLING OpenCL and ENABLING GPU. Or selecting manually the desired CPU?

Without having it deeply tested myself, I believe that the original GPU tools had been written in CUDA for Nvidia cards. OpenCL was added for better compatibility to AMD and other GPU brands (Intel...). That being said, its quite common sense among software developers that CUDA is usually faster than OpenCL.

I can enable GPU but disable OpenCL - which would leave CUDA the only meaningful option then. Maybe the GUI is simply confusing here?

I wonder what render times you will get when enabling GPU but disabling OpenCL at the same time.

Please try. Maybe it will shed some light on this.

Cheers
Axel

Re: Fusion 9 OpenCL slower?

PostPosted: Mon Sep 18, 2017 1:50 pm
by David_Cox
Just a quick update from ibc Amsterdam...

Black magic are aware of the openCL issue and are working on it. There are some fixes in the latest maintenance version released today and no doubt more to come.

Dc.

Re: Fusion 9 OpenCL slower?

PostPosted: Tue Oct 10, 2017 9:32 pm
by Adelson Munhoz
Some information I would like to share.

NVIDIA released yesterday the 387.92 driver.

With the (now old) 385.69 driver I was getting several OpenCL-related errors in the console.

With the installation of the 387.92 driver, the errors dissapeared and I have experienced a 20-25% increase in rendering speed (at least with the compositions I have tested so far).

My system:
Windows 10 64-bit
FX-8150
32GB RAM
2 x GTX1060 6GB

Re: Fusion 9 OpenCL slower?

PostPosted: Wed Nov 01, 2017 2:21 pm
by daniel.partzsch
I am having the same problem and switched to using CPU via the global OpenCL preferences. In there I've also disabled OpenCL tools however new tools (and existing ones) still have the "use OpenCL"option checked on the tools by default. So, how can this be changed and if I am already on CPU only do I still have to uncheck this setting on every tool manually? Or is the preference overriding it? Is there actually a way to change the same setting on multiple tools at once? Thanks!

Re: Fusion 9 OpenCL slower?

PostPosted: Thu Nov 02, 2017 8:48 pm
by michael vorberg
daniel.partzsch wrote:I am having the same problem and switched to using CPU via the global OpenCL preferences. In there I've also disabled OpenCL tools however new tools (and existing ones) still have the "use OpenCL"option checked on the tools by default. So, how can this be changed and if I am already on CPU only do I still have to uncheck this setting on every tool manually? Or is the preference overriding it? Is there actually a way to change the same setting on multiple tools at once? Thanks!



if you checked the CPU as OpenCL device then fusion still runs the OpenCL code but on the CPU, if you want disable it you need to set "OpenCL" tools to disable

additional you can set the "Use OpenCL" in the nodes to disable and save that as default for the node. after that every new node you create will have the setting already "disable"

Re: Fusion 9 OpenCL slower?

PostPosted: Fri Nov 03, 2017 4:59 pm
by daniel.partzsch
michael vorberg wrote:
daniel.partzsch wrote:I am having the same problem and switched to using CPU via the global OpenCL preferences. In there I've also disabled OpenCL tools however new tools (and existing ones) still have the "use OpenCL"option checked on the tools by default. So, how can this be changed and if I am already on CPU only do I still have to uncheck this setting on every tool manually? Or is the preference overriding it? Is there actually a way to change the same setting on multiple tools at once? Thanks!



if you checked the CPU as OpenCL device then fusion still runs the OpenCL code but on the CPU, if you want disable it you need to set "OpenCL" tools to disable

additional you can set the "Use OpenCL" in the nodes to disable and save that as default for the node. after that every new node you create will have the setting already "disable"
Yeah, did this already for the tools I am using most frequently. Would be cool to have a global switch for that though. Thought disabling open cl tools would just do that. However this sounds like disabling open cl tools and switching to CPU in the preferences is somehow doing what I want to do. Thanks!

Gesendet von meinem SM-G930F mit Tapatalk

Re: Fusion 9 OpenCL slower?

PostPosted: Sat Dec 16, 2017 12:43 am
by LandonParks
Are you guys using nVidia or AMD? OpenCL performance is much better on AMD cards. nVidia has been so stuck on CUDA for so long, that they still neglect proper OpenCL implementation. I run an RX VEGA 64 with Fusion, and have noticed VAST speed improvements over Fusion 8 running the same card.