Jump to: Board index » General » Fusion

color corrector crash

Learn about 3D compositing, animation, broadcast design and VFX workflows.
  • Author
  • Message
Offline

Rick van den Berg

  • Posts: 135
  • Joined: Tue Jun 02, 2015 7:47 am

color corrector crash

PostWed Sep 27, 2017 7:28 am

not sure if it has already been posted, i did search for it.. but i tested different comps, and each time i made a change in the color corrector node, fusion crashed.

fusion 9.0.1 on windows 10
Offline

David_Cox

  • Posts: 68
  • Joined: Thu Aug 03, 2017 11:20 pm
  • Location: London UK

Re: color corrector crash

PostWed Sep 27, 2017 5:12 pm

Yes I have seen this too.

I have two computers - the older one always exhibits this behaviour although it worked fine with version 9.0. I suspect it is to do with GPU acceleration because if I go to preferences>openCL, this also causes a crash. Same with other colour related nodes such as Gamut.

On my newer computer, this happened when I changed GPU setup (I removed a second GPU card). In this case, deleting the fusion user preferences from the OS fixed the issue, so might be worth a try. On windows, the user prefs are in c:/users/<username>/AppData/Roaming/Fusion. Just rename Fusion to Fusion_old or something and fusion will make new prefs when it next starts.

DC
Showreels: vimeo.com/davidcoxtv
Website: www.davidcox.tv
Offline

Timo Lenton

  • Posts: 4
  • Joined: Fri Sep 29, 2017 12:30 am

Re: color corrector crash

PostFri Sep 29, 2017 12:34 am

Yes!

Im having the same issue. Very frustrating especially since Im trying to learn.

Fusion 9.0
Mac Pro
NVIDIA GeForce GTX 980 4095 MB
Offline

Rick van den Berg

  • Posts: 135
  • Joined: Tue Jun 02, 2015 7:47 am

Re: color corrector crash

PostMon Oct 02, 2017 8:11 am

do you mean ''fusion.prefs'' in the folder profiles-->default?

i tried to delete/change that file, but it didn't help
Offline

Ciufudean Alin

  • Posts: 5
  • Joined: Sat Mar 14, 2015 9:15 am

Re: color corrector crash

PostMon Oct 02, 2017 2:20 pm

I had that problem to.
Just update Nvidia drivers and everything will be fine.
Offline

Timo Lenton

  • Posts: 4
  • Joined: Fri Sep 29, 2017 12:30 am

Re: color corrector crash

PostMon Oct 02, 2017 4:23 pm

updated Nvidia drivers and still crashes...
Offline
User avatar

Bryan Ray

  • Posts: 277
  • Joined: Mon Nov 28, 2016 5:32 am

Re: color corrector crash

PostMon Oct 02, 2017 9:56 pm

This is a known issue in 9.0.1. The simplest solution is to go into the CC node's Common Controls tab and set use OpenCL to Disable. Do the same thing in the Gamut node.

If Fusion crashes when attempting to view the OpenCL Preferences, you can disable them via a script command in the console. For convenience, one of the devs recently supplied this script, which will disable OpenCL for all Color Correct and Gamut nodes and then set the OpenCL preferences for both the comp and Fusion to disabled:

Code: Select all
for _,id in ipairs{"ColorCorrector", "GamutConvert"} do
   local n = 0
   for _,t in pairs(comp:GetToolList(false, id)) do
      t.UseOpenCL[0] = 0
      n = n + 1
   end
   print("Disabled OpenCL on "..n.." x "..id)
end
comp:SetPrefs("Comp.Tweaks.OpenCL.Enable", 0)
fu:SetPrefs("Comp.Tweaks.OpenCL.Enable", 0)
fu:SetPrefs("Global.Tweaks.OpenCL.Device", "cpu")
fu:SavePrefs()


Save that as a .lua file and simply drag-and-drop it into the console view.
Bryan Ray
http://www.bryanray.name
http://www.musevfx.com
Offline

Timo Lenton

  • Posts: 4
  • Joined: Fri Sep 29, 2017 12:30 am

Re: color corrector crash

PostSat Oct 07, 2017 9:19 am

Thanks Bryan,

I cant seem to find the "common Controls" tab to switch off Open CL.

I tried dragging the .lua file into the console but im getting an error:

/Desktop/openclfix.lua:1: unexpected symbol near '{'


Im very new to Fusion so am not very familiar yet and hopefully Im just overlooking something obvious.

Thanks
Offline
User avatar

Andrea De Paolis

  • Posts: 3
  • Joined: Fri Aug 25, 2017 7:04 am
  • Location: Italy

Re: color corrector crash

PostSat Oct 07, 2017 3:13 pm

try this:
for _,id in ipairs({"ColorCorrector", "GamutConvert"}) do
local n = 0
for _,t in pairs(comp:GetToolList(false, id)) do
t.UseOpenCL[0] = 0
n = n + 1
end
print("Disabled OpenCL on "..n.." x "..id)
end
comp:SetPrefs("Comp.Tweaks.OpenCL.Enable", 0)
fu:SetPrefs("Comp.Tweaks.OpenCL.Enable", 0)
fu:SetPrefs("Global.Tweaks.OpenCL.Device", "cpu")
fu:SavePrefs()
Windows 10 64 bit i5 3340 16GB RAM Geforce GTX 750Ti latest NVIDIA Drivers
Offline
User avatar

Bryan Ray

  • Posts: 277
  • Joined: Mon Nov 28, 2016 5:32 am

Re: color corrector crash

PostSun Oct 08, 2017 4:18 am

Common Controls is here:

Untitled.png
Untitled.png (94.37 KiB) Viewed 1679 times


For your script error, did you save the script with a plaintext editor or did you try to use a word processor? A programmer's code editor is ideal, but if you don't want to bother with that, at least use Notepad (not Wordpad) on Windows. Textedit on Mac (make sure you do Format > Make Plain Text). I just tested it, and it works as expected, so there's nothing wrong with the code.
Bryan Ray
http://www.bryanray.name
http://www.musevfx.com
Offline
User avatar

Aaron Nye

  • Posts: 2
  • Joined: Thu May 18, 2017 9:41 pm

Re: color corrector crash

PostSun Oct 15, 2017 5:20 pm

Bryan Ray wrote:Save that as a .lua file and simply drag-and-drop it into the console view.


Suppose we can't even get Fusion to start because of this error. How would we go about either installing Fusion with OpenCL disabled or turn it off after install?

My problem is that I'm using Fusion on Linux with an RX Vega 64 (which is just too new for most of what I want to do with it).

Any help would be greatly appreciated.
Offline
User avatar

Bryan Ray

  • Posts: 277
  • Joined: Mon Nov 28, 2016 5:32 am

Re: color corrector crash

PostMon Oct 16, 2017 6:57 pm

To apply this fix when Fusion won't even start you'll need to edit the Preferences file by hand. I'm not sure where the data folders live on Linux, but the preferences are at Fusion\Profiles\Default\Fusion.prefs

There are two places where OpenCL needs to be disabled: one in the default Comp preferences and one in the Globals. In both places, set:
Enable = 0,

and in the Globals, which has a lot more options listed, set:

Device = "cpu",

Don't omit the comma at the end of the line.
These lines are the only places that the word OpenCL appears, so they should be easy to find.
Bryan Ray
http://www.bryanray.name
http://www.musevfx.com
Offline

Kel Philm

  • Posts: 134
  • Joined: Sat Nov 19, 2016 6:21 am

Re: color corrector crash

PostThu Oct 19, 2017 10:27 pm

Damn this stuff is so flakey. I am getting a crash about every 10 mins in Fusion now, tried to disable the OpenCL in pref's but it would just crash, so disabled the OpenCL in prefs config file, now if I even go to check the preferences it crashes as well. Its nearly enough to drive me back to Nuke.

Win 10, Studio V 9.0.1, Nvidia Driver 387.92
Offline
User avatar

michael vorberg

  • Posts: 760
  • Joined: Wed Nov 12, 2014 8:47 pm
  • Location: stuttgart, germany

Re: color corrector crash

PostFri Oct 20, 2017 9:03 am

The prefs in the crash is also a bug if fusion can't find a proper OpenCL device. Try do delete the file and restart. if it still crashes you can manually change the preferences and disable all OpenCL there
Offline
User avatar

Michal Golebiowski

  • Posts: 2
  • Joined: Fri Dec 08, 2017 10:07 pm
  • Location: London, UK

Re: color corrector crash

PostFri Dec 08, 2017 10:10 pm

Hi there,

I've been trying to follow Bryan's advice and set OpenCL in CC node's Common Controls tab (I know which one it is), but there is no option like this in there... why is that?

I'm using the newest version of Fusion. Many thanks in advance!

Edit: I have tried all the other methods multiple times - but nothing helps. Every time when I'm trying to use CC node, Fusion crashes.

I really start losing hope it's gonna work... and I have barely started with the software.
Offline
User avatar

michael vorberg

  • Posts: 760
  • Joined: Wed Nov 12, 2014 8:47 pm
  • Location: stuttgart, germany

Re: color corrector crash

PostSat Dec 09, 2017 10:56 am

If you don't see the OpenCL settings in a node it means fusion does not find a OpenCL device. If you go to the preferences and try to change the OpenCL settings it should crash too
Solutions that worked for other people :
(Re) install graphics driver
Or change the OpenCL settings in the preferences file by hand
Offline

JP Docherty

  • Posts: 52
  • Joined: Wed Dec 31, 2014 2:37 pm

Re: color corrector crash

PostSat Dec 09, 2017 1:33 pm

See this recent thread

viewtopic.php?f=22&t=67368

and also on WeSuckLess

https://www.steakunderwater.com/wesuckl ... =19&t=1698

which suggests that it's not the driver, it's the reinstall itself that does the trick.
Offline
User avatar

Michal Golebiowski

  • Posts: 2
  • Joined: Fri Dec 08, 2017 10:07 pm
  • Location: London, UK

Re: color corrector crash

PostSat Dec 09, 2017 2:52 pm

Thanks guys. Let me clarify a few things and add some extra information.

My system:
Intel Xeon E5-1650 (6-core) 3.2 GHz
64 GB RAM
Nvidia Quadro 2000 1GB
Windows 10 Pro 1709

I've spent half a day trying all possible solutions from every forum (incl. WeSuckLess) and nothing worked. This is everything I did:

- I've pasted the code provided by Bryan in order to disable OpenCL from within Fusion: applying this to the console as .lua file. The only thing that has changed was the fact that Fusion stopped crashing instantly, instead it was hanging for a while and I was getting Windows prompt that the program needs to be closed.
- I couldn't disable OpenCL in CC node's Common Controls because I couldn't see any option like this there, as indicated by another user as well.
- I've changed OpenCL settings in preferences file many times, I also deleted/hid prefs as advised elsewhere; no results.

I then followed an advice from another user in different thread (there needs to be better flow of information about critical issues like this between threads on this forum...) and re-installed graphics drivers. Since I have Nvidia Quadro 2000, I couldn't follow his advice and install "Quadro New Feature" driver 388.16 refering to "Fall Creators Update" cause it's not supported by my graphics card. I then decided to "downgrade" from my current 377.61 ODE driver to the newest "Quadro New Feature" driver for Nvidia 2000, which was version 372.95 (without any mention about "Fall Creator Update" since it was released 2016.9.27, but that was still the newest QNF driver for my card). Nothing.

I went as far as installing Intel's app to check all drivers related to processor and I have also installed the newest OpenCL drivers manually. Nothing.

After the whole evening and night of trying to find a fix, I went back to Fusion 8 instead.

Today, I decided to try make it work one more time and I pasted different piece of code into console, provided by user Andrea De Paolis. Guess what... IT WORKED! I mean, so far it's working: I can use the "problematic" nodes and even access OpenCL in Fusion's preferences...

I don't know why this particular solution worked and the others didn't, but I hope this is going to help someone.

Btw, the only advice I decided not to follow was to downgrade/re-install my Windows to any of the previous versions. First of all, I honestly don't have time for this, secondly, it's a headache to go back to any of previous Win versions and I cannot spend another half a day to dig into this one, thirdly, all the other apps (like Adobe stuff, DaVinci, Blender, Houdini etc.) works perfectly fine on this version. I know there are issues related to "Fall's Creator Update" and I believe this update is responsible for the death of my (quite old) laptop quite recently, but on my desktop everything works so far...

Anyway, this is a serious bug and if BM wants users to switch from Nuke or AE, then they really need to take care of critical problems like this a bit faster... I've noticed reports of this error in previous months. I hope this will be fixed because I'm a big fan of Fusion, I want to support it and spread the word about the software to my fellow VFX/film peers...

Thank you for everyone who contributed to this thread!

Btw, the code that helped me (author: Andrea De Paolis) that needs to be saved as .lua file (by going into Script > Edit > New Script, opening notepad/similar, pasting, saving) and dragged into console:

for _,id in ipairs({"ColorCorrector", "GamutConvert"}) do
local n = 0
for _,t in pairs(comp:GetToolList(false, id)) do
t.UseOpenCL[0] = 0
n = n + 1
end
print("Disabled OpenCL on "..n.." x "..id)
end
comp:SetPrefs("Comp.Tweaks.OpenCL.Enable", 0)
fu:SetPrefs("Comp.Tweaks.OpenCL.Enable", 0)
fu:SetPrefs("Global.Tweaks.OpenCL.Device", "cpu")
fu:SavePrefs()
Last edited by Michal Golebiowski on Tue Dec 12, 2017 9:46 pm, edited 1 time in total.
Offline

DenisLinine

  • Posts: 1
  • Joined: Tue Nov 07, 2017 10:19 pm

Re: color corrector crash

PostTue Dec 12, 2017 4:05 pm

Same issue. Nvidia 1080 on Win 10 64-bit. The machine generally works rock solid, I use Houdini, modo, V-Ray, Octane, etc, without a single issue of such kind. I believe the issue is probably common for all configurations like nvidia on win or nvidia on win 10-64 -considering numerous reports it can hardly be specific for some rare configuration.

What I would expect in such a situation, which should not occur at all and produces the question "What is the QA procedure at the manufacturer releasing a product with such an obvious and critical bug?":
1) Immediate availability of some hot fix, for instance, something that simply turns OpenCL off and it should be handled by the manufacturer, not by the user's community.
2) Release of a new product version with the proper fix as soon as it possible or release of something like SP that fixes the issue properly (not by simply turning off OpenCL, for instance) - in the course of days.

Return to Fusion

Who is online

Users browsing this forum: No registered users and 8 guests