Jump to: Board index » General » Fusion

I can't get any of the Blur Effects to Work

Learn about 3D compositing, animation, broadcast design and VFX workflows.
  • Author
  • Message
Offline

Steven Newby

  • Posts: 4
  • Joined: Sat Mar 11, 2017 1:55 pm

I can't get any of the Blur Effects to Work

PostWed Oct 11, 2017 2:00 pm

I am teaching myself how to use this program, and can do some pretty cool modelling, but I can't for the life of me get any of the Blur Masks to work. Even following steps outlined in YouTube videos, either the blur node or the object I am attempting to apply the blur to gets a red light and the object disappears from the merge view (and the render view). I recognize there's probably a simple, fundamental step that any other user would have taken for granted (and thus not worth mentioning in their tutorial videos), but I am missing this step. Any help would be appreciated.

Thanks,
Steven
Offline

Sander de Regt

  • Posts: 581
  • Joined: Thu Nov 13, 2014 10:09 pm

Re: I can't get any of the Blur Effects to Work

PostWed Oct 11, 2017 6:38 pm

Can you post an example here? You're probably right in that it's probably a pretty simple thing.
If you can create an example without any loaders, then we can all take a look with you.

To post examples here, select all your tools in the Fusion workspace, CTRL+C and then paste inbetween 'code' brackets to share your comp with us.
Offline

Steven Newby

  • Posts: 4
  • Joined: Sat Mar 11, 2017 1:55 pm

Re: I can't get any of the Blur Effects to Work

PostThu Oct 12, 2017 7:24 pm

Ok, here's a ridiculously simple example, from which I can figure how to apply to a more complex model. I'm going to add a glow node to a sphere. This comp won't have any other objects. I will include a merge node and a render node, if that helps.

Code: Select all
[code]{
   Tools = ordered() {
      Glow1 = Glow {
         CtrlWZoom = false,
         Inputs = {
            Blend = Input { Value = 0.2, },
         },
         ViewInfo = OperatorInfo { Pos = { 194, 105 } },
      },
      Shape3D1 = Shape3D {
         Inputs = {
            Shape = Input { Value = FuID { "SurfaceSphereInputs" }, },
            MaterialInput = Input {
               SourceOp = "Glow1",
               Source = "Output",
            },
            ["MtlStdInputs.MaterialID"] = Input { Value = 1, },
            ["SurfacePlaneInputs.ObjectID.ObjectID"] = Input { Value = 1, },
            ["SurfaceSphereInputs.Radius"] = Input { Value = 0.03, },
            ["SurfaceSphereInputs.ObjectID.ObjectID"] = Input { Value = 2, }
         },
         ViewInfo = OperatorInfo { Pos = { 186, 33.5 } },
      },
      Merge3D1 = Merge3D {
         Inputs = {
            SceneInput1 = Input {
               SourceOp = "Shape3D1",
               Source = "Output",
            },
         },
         ViewInfo = OperatorInfo { Pos = { 366, 23.5 } },
      },
      Renderer3D1 = Renderer3D {
         CustomData = {
            ToolVersion = 2,
         },
         Inputs = {
            Width = Input { Value = 1920, },
            Height = Input { Value = 1080, },
            ["Gamut.SLogVersion"] = Input { Value = FuID { "SLog2" }, },
            SceneInput = Input {
               SourceOp = "Merge3D1",
               Source = "Output",
            },
         },
         ViewInfo = OperatorInfo { Pos = { 515, 26.5 } },
      }
   }
}[/code]


Thanks for checking into this.

Steven
Offline
User avatar

michael vorberg

  • Posts: 728
  • Joined: Wed Nov 12, 2014 8:47 pm
  • Location: stuttgart, germany

Re: I can't get any of the Blur Effects to Work

PostThu Oct 12, 2017 7:34 pm

that will not work!

the glow node is a 2D node, it cant glow a 3d Object. it can add a glow after you used a Render3d and "convert" the 3d scene into a 2d image

right now your imageplane has the glow as texture/material input. but the glow itself has no input image. so there is nothing the glow node can process, this leads to a failure of the shape3d node (Because of a failed material input), this leads to the empty 3d scene

Return to Fusion

Who is online

Users browsing this forum: Andrew Hazelden and 6 guests