Page 1 of 1

Fusion with Linux mint 18.2 (Linux newb install)

PostPosted: Wed Nov 15, 2017 5:58 pm
by Justin Courneya
Im new to Linux and having trouble running Fusion on the Mint distro. ( Does it only work for centOS? )

I extracted the download and ran the installer .
When i loaded Fusion up it would crash the moment i created a loader or tried to drop an image sequence in .
It also crashed when i went into preferences and tried to select the opencl section .
I then installed opencl after reading an earlier post about linux with version 8.2 . I was then able to view my gtx 970 in the opencl preferences . Im still crashing when trying to drop a image sequence, loader, merge and other nodes .
The 3d merge didnt crash it though.

Re: Fusion with Linux mint 18.2 (Linux newb install)

PostPosted: Wed Nov 15, 2017 6:50 pm
by Darren Cook
Have you set ffmpeg up? viewtopic.php?f=22&t=62308&p=367661#p367587

I'm using Mint 18.x, xfce, and once I had ffmpeg set up it has generally been working smoothly. I have gtx 1070, but haven't touched the OpenCL preferences (They are "auto", "full" and "auto"; I've not actually been paying attention to if it is using gpu or cpu.)

Re: Fusion with Linux mint 18.2 (Linux newb install)

PostPosted: Wed Nov 15, 2017 9:12 pm
by Justin Courneya
I think i have ffmpeg up . I do not usually load codecs in Fusion . Only image sequences . If i try and drop one jpeg in it will crash . Also if i drop a merge , fast noise , loader it will crash .
When i load it from the terminal and drop a node i know will crash it i get this .



FusionScript Server [3951] Started
Host 'FusionServer' [3954] Added
DNX SDK API version 2.3.1-36-r
FFmpeg Ver: 56.60.100
libDeckLinkAPI.so: cannot open shared object file: No such file or directory
Unable to read VR Path Registry from /home/justin/.config/openvr/openvrpaths.vrpath
Host 'Fusion' [3937] Added
libDeckLinkAPI.so: cannot open shared object file: No such file or directory
DNX SDK API version 2.3.1-36-r
FFmpeg Ver: 56.60.100
Host 'StudioPlayer' [3999] Added
QFileSystemWatcher::removePaths: list is empty
Host 'StudioPlayer' Removed
Segmentation fault

Re: Fusion with Linux mint 18.2 (Linux newb install)

PostPosted: Wed Nov 15, 2017 9:23 pm
by Darren Cook
I have just about the same messages as you (except for the last three, of course). I have ffmpeg 57.107.100 (from https://launchpad.net/~jonathonf/+archi ... u/ffmpeg-3 )
Kernel is 4.10.0-21, and I have the nvidia proprietary packages installed.

Re: Fusion with Linux mint 18.2 (Linux newb install)

PostPosted: Thu Nov 16, 2017 3:29 pm
by Justin Courneya
My Kernel is 4.8.0-53, and I have the nvidia proprietary packages installed aswell . Maybe i installed it wrong ?
I installed from the terminal using sudo . But i still crash instantly when adding a loader , fast noise or a merge node .
I installed the Cuda kit aswell

Re: Fusion with Linux mint 18.2 (Linux newb install)

PostPosted: Sun Nov 19, 2017 3:29 pm
by Justin Courneya
Its working now .Ii wish i knew why so i could have learned a lesson . I repeated the steps of installing from the terminal and now it works .

Re: Fusion with Linux mint 18.2 (Linux newb install)

PostPosted: Thu Jan 18, 2018 9:39 pm
by Jeff McGuire
I've been experiencing something similar on CentOS7 - I can't drop in LOADERS and SAVERS without Fusion 9.0.2 bringing up a window with no UI elements, hanging, then terminating the program without an assert.

Was your problem similar to this and if so, all it took was installing the downloaded ".run" installer from the Terminal?

Regards,

Jeff