Page 1 of 1

Decklink SDI update firmware error

PostPosted: Wed Oct 24, 2012 2:00 pm
by Joep
Hi,

I've bought a new PC for streaming live to YouTube (using Telestream Wirecast). When I try to install the latest drivers for the Decklink SDI there is a message that the firmware needs an update. When I click OK there is a error message after several seconds: "An error has occured that has prevented the firmware on your Decklink SDI from being upgraded".

I tried also earlier drivers, but I still get the error.
Can someone help please?

The PC setup is:
Intel Core i3-­‐2130
Kingston ValueRam 8GB(2x4GB)
Gigabyte GA-­‐H77-­‐DS3H
Samsung 830 Series 64GB 2.5"
Microsoft Windows 7 H. Prem. 64b

Re: Decklink SDI update firmware error

PostPosted: Thu Oct 25, 2012 12:49 pm
by Kristofer
I have an Decklink HD Extream 2 that also just did this to me.

And now it doesn't work at all after this incident.
Tried the card in an XP an Win 7 and an OSX machine.
None of the machines can find the card at all.

Re: Decklink SDI update firmware error

PostPosted: Thu Oct 25, 2012 6:13 pm
by Joep
I tried a lot last days and the conclusion is the Decklink SDI does not work with a PCI-E risercard. So I removed the risercard and put everything in a new case. Now the Decklink works like a charm!