Installing DeckLink SDI drivers on Ubuntu 14.04

Do you have questions about Desktop Video, Converters, Routers and Monitoring?
  • Author
  • Message
Offline

wshirey

  • Posts: 3
  • Joined: Wed Aug 22, 2012 1:37 pm

Installing DeckLink SDI drivers on Ubuntu 14.04

PostMon Jul 14, 2014 1:13 pm

I'm trying to install Desktop Video 10.1.1 drivers on Linux (Ubuntu 14.04 x86_64). There seems to be an error compiling the driver for 64 bit Linux. Please help if possible.

Code: Select all
$ uname -a
Linux linux-dev 3.13.0-30-generic #55-Ubuntu SMP Fri Jul 4 21:40:53 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux

$ sudo lspci -s 69:00.0 -nnv
69:00.0 Multimedia video controller [0400]: Blackmagic Design DeckLink SDI/Duo/Quad [bdbd:a11b]
   Subsystem: Blackmagic Design DeckLink SDI/Duo/Quad [bdbd:a11b]
   Flags: fast devsel, IRQ 3
   Memory at ef900000 (32-bit, non-prefetchable) [disabled] [size=1M]
   Memory at ef800000 (64-bit, non-prefetchable) [disabled] [size=1M]
   Capabilities: [40] Power Management version 3
   Capabilities: [48] MSI: Enable- Count=1/1 Maskable- 64bit+
   Capabilities: [58] Express Endpoint, MSI 00
   Capabilities: [100] Device Serial Number 00-00-00-01-00-00-0a-35

$ sudo dpkg -i desktopvideo_10.1.1a26_amd64.deb
(Reading database ... 207894 files and directories currently installed.)
Preparing to unpack desktopvideo_10.1.1a26_amd64.deb ...
Stopping upstart services...
  DesktopVideoHelper
Unloading modules...
Removing old drivers...
  blackmagic
  blackmagic-io
Unpacking desktopvideo (10.1.1a26) over (10.1.1a26) ...
Setting up desktopvideo (10.1.1a26) ...
Preparing new blackmagic driver for 3.13.0-30-generic kernel...
  Adding to DKMS
  Building (failed)
Preparing new blackmagic-io driver for 3.13.0-30-generic kernel...
  Adding to DKMS
  Building (failed)
Loading modules...
Starting upstart services...
  DesktopVideoHelper
********************************************************************************
Failed to build driver(s)

Possible causes:
 1. Driver is incompatible with your kernel version
 2. Kernel headers/gcc/make/etc. is not installed
 3. Kernel header version does not match the running kernel (3.13.0-30-generic)

Error messages:
dkms build -m blackmagic -v 10.1.1a26
---

Kernel preparation unnecessary for this kernel.  Skipping...

Building module:
cleaning build area....
make KERNELRELEASE=3.13.0-30-generic KERNELRELEASE=3.13.0-30-generic....(bad exit status: 2)
Error! Bad return status for module build on kernel: 3.13.0-30-generic (x86_64)
Consult /var/lib/dkms/blackmagic/10.1.1a26/build/make.log for more information.

dkms build -m blackmagic-io -v 10.1.1a26
---

Kernel preparation unnecessary for this kernel.  Skipping...

Building module:
cleaning build area....
make KERNELRELEASE=3.13.0-30-generic KERNELRELEASE=3.13.0-30-generic....(bad exit status: 2)
Error! Bad return status for module build on kernel: 3.13.0-30-generic (x86_64)
Consult /var/lib/dkms/blackmagic-io/10.1.1a26/build/make.log for more information.


********************************************************************************
Processing triggers for man-db (2.6.7.1-1) ...
Processing triggers for ureadahead (0.100.0-16) ...
Processing triggers for libc-bin (2.19-0ubuntu6) ...

$ cat /var/lib/dkms/blackmagic/10.1.1a26/build/make.log
DKMS make.log for blackmagic-10.1.1a26 for kernel 3.13.0-30-generic (x86_64)
Mon Jul 14 08:06:28 CDT 2014
make -C /lib/modules/3.13.0-30-generic/build M=/var/lib/dkms/blackmagic/10.1.1a26/build
make[1]: Entering directory `/usr/src/linux-headers-3.13.0-30-generic'
  LD      /var/lib/dkms/blackmagic/10.1.1a26/build/built-in.o
  CC [M]  /var/lib/dkms/blackmagic/10.1.1a26/build/blackmagic_serial.o
  CC [M]  /var/lib/dkms/blackmagic/10.1.1a26/build/blackmagic_core.o
  CC [M]  /var/lib/dkms/blackmagic/10.1.1a26/build/blackmagic_lib.o
  CC [M]  /var/lib/dkms/blackmagic/10.1.1a26/build/blackmagic_dma.o
  CC [M]  /var/lib/dkms/blackmagic/10.1.1a26/build/blackmagic_gate.o
  LD [M]  /var/lib/dkms/blackmagic/10.1.1a26/build/blackmagic.o
ld: Relocatable linking with relocations from format elf64-x86-64 (/var/lib/dkms/blackmagic/10.1.1a26/build/bmd-support.a) to format elf32-i386 (/var/lib/dkms/blackmagic/10.1.1a26/build/blackmagic.o) is not supported
make[2]: *** [/var/lib/dkms/blackmagic/10.1.1a26/build/blackmagic.o] Error 1
make[1]: *** [_module_/var/lib/dkms/blackmagic/10.1.1a26/build] Error 2
make[1]: Leaving directory `/usr/src/linux-headers-3.13.0-30-generic'
make: *** [all] Error 2

$ cat /var/lib/dkms/blackmagic-io/10.1.1a26/build/make.log
DKMS make.log for blackmagic-io-10.1.1a26 for kernel 3.13.0-30-generic (x86_64)
Mon Jul 14 08:06:35 CDT 2014
make -C /lib/modules/3.13.0-30-generic/build M=/var/lib/dkms/blackmagic-io/10.1.1a26/build
make[1]: Entering directory `/usr/src/linux-headers-3.13.0-30-generic'
  LD      /var/lib/dkms/blackmagic-io/10.1.1a26/build/built-in.o
  CC [M]  /var/lib/dkms/blackmagic-io/10.1.1a26/build/bmio_client.o
  CC [M]  /var/lib/dkms/blackmagic-io/10.1.1a26/build/bmio_dev.o
  CC [M]  /var/lib/dkms/blackmagic-io/10.1.1a26/build/bmio_driver.o
  CC [M]  /var/lib/dkms/blackmagic-io/10.1.1a26/build/bmio_serial.o
  CC [M]  /var/lib/dkms/blackmagic-io/10.1.1a26/build/bmio_export.o
  CC [M]  /var/lib/dkms/blackmagic-io/10.1.1a26/build/bm_locks.o
  CC [M]  /var/lib/dkms/blackmagic-io/10.1.1a26/build/bm_mm.o
  CC [M]  /var/lib/dkms/blackmagic-io/10.1.1a26/build/bm_pci.o
  CC [M]  /var/lib/dkms/blackmagic-io/10.1.1a26/build/bm_util.o
  CC [M]  /var/lib/dkms/blackmagic-io/10.1.1a26/build/bmio_audio.o
  LD [M]  /var/lib/dkms/blackmagic-io/10.1.1a26/build/blackmagic-io.o
ld: Relocatable linking with relocations from format elf64-x86-64 (/var/lib/dkms/blackmagic-io/10.1.1a26/build/blackmagic.a) to format elf32-i386 (/var/lib/dkms/blackmagic-io/10.1.1a26/build/blackmagic-io.o) is not supported
make[2]: *** [/var/lib/dkms/blackmagic-io/10.1.1a26/build/blackmagic-io.o] Error 1
make[1]: *** [_module_/var/lib/dkms/blackmagic-io/10.1.1a26/build] Error 2
make[1]: Leaving directory `/usr/src/linux-headers-3.13.0-30-generic'
make: *** [all] Error 2

Offline

Paul Parsons

  • Posts: 27
  • Joined: Wed Apr 30, 2014 10:38 pm

Re: Installing DeckLink SDI drivers on Ubuntu 14.04

PostTue Jul 15, 2014 8:45 am

The references to elf64-x86-64 and elf32-i386 from the linker suggest that you are linking the 64-bit object module blackmagic.a with a 32-bit toolchain.
Offline

Lukas Bachschwell

  • Posts: 3
  • Joined: Tue Jul 29, 2014 1:11 pm

Re: Installing DeckLink SDI drivers on Ubuntu 14.04

PostTue Jul 29, 2014 1:14 pm

Same here... trying tu use the decklink card in Ubuntu 14.04 with desktopvideo 10.1.1
exactly the same error...
Offline

Lukas Bachschwell

  • Posts: 3
  • Joined: Tue Jul 29, 2014 1:11 pm

Re: Installing DeckLink SDI drivers on Ubuntu 14.04

PostTue Jul 29, 2014 2:30 pm

Solved!!!
That problem occours because of the wrong kernel headers

You need to install the newest kernel headers, then reinstall dkms and it'll work =D
Offline
User avatar

Patrick Woodard

  • Posts: 10
  • Joined: Fri Aug 24, 2012 6:20 pm
  • Location: Hollywood

Re: Installing DeckLink SDI drivers on Ubuntu 14.04

PostSat Apr 14, 2018 5:03 pm

I get this same error. Please help

Code: Select all
[root@pwoodard x86_64]# yum install --nogpgcheck desktopvideo-10.9.12a3.x86_64.rpm
Loaded plugins: langpacks, nvidia, product-id, search-disabled-repos, subscription-manager
Examining desktopvideo-10.9.12a3.x86_64.rpm: desktopvideo-10.9.12-a3.x86_64
Marking desktopvideo-10.9.12a3.x86_64.rpm to be installed
Resolving Dependencies
--> Running transaction check
---> Package desktopvideo.x86_64 0:10.9.12-a3 will be installed
--> Finished Dependency Resolution

Dependencies Resolved

=========================================================================================================================
 Package                   Arch                Version                 Repository                                   Size
=========================================================================================================================
Installing:
 desktopvideo              x86_64              10.9.12-a3              /desktopvideo-10.9.12a3.x86_64               83 M

Transaction Summary
=========================================================================================================================
Install  1 Package

Total size: 83 M
Installed size: 83 M
Is this ok [y/d/N]: y
Downloading packages:
Running transaction check
Running transaction test
Transaction test succeeded
Running transaction
  Installing : desktopvideo-10.9.12-a3.x86_64                                                                        1/1
Preparing new blackmagic driver for 3.10.0-693.21.1.el7.x86_64 kernel...
  Adding to DKMS
  Building (failed)
Preparing new blackmagic-io driver for 3.10.0-693.21.1.el7.x86_64 kernel...
  Adding to DKMS
  Building (failed)
Loading modules...
Enabling systemd services...
  DesktopVideoHelper
Starting systemd services...
  DesktopVideoHelper
********************************************************************************
Failed to build driver(s)

Possible causes:
 1. Driver is incompatible with your kernel version
 2. Kernel headers/gcc/make/etc. is not installed
 3. Kernel header version does not match the running kernel (3.10.0-693.21.1.el7.x86_64)

Error messages:
dkms build -m blackmagic -v 10.9.12a3 --rpm_safe_upgrade
---
Error! echo
Your kernel headers for kernel 3.10.0-693.21.1.el7.x86_64 cannot be found at
/lib/modules/3.10.0-693.21.1.el7.x86_64/build or /lib/modules/3.10.0-693.21.1.el7.x86_64/source.

dkms build -m blackmagic-io -v 10.9.12a3 --rpm_safe_upgrade
---
Error! echo
Your kernel headers for kernel 3.10.0-693.21.1.el7.x86_64 cannot be found at
/lib/modules/3.10.0-693.21.1.el7.x86_64/build or /lib/modules/3.10.0-693.21.1.el7.x86_64/source.


********************************************************************************
  Verifying  : desktopvideo-10.9.12-a3.x86_64                                                                        1/1

Installed:
  desktopvideo.x86_64 0:10.9.12-a3                                                                                       

Complete!
Patrick Woodard C.S.I. | Colorist at DigitalFilm Tree | Hollywood

SUPERMICRO GPU SUPERWORKSTATION 7048GR-TR, Dual Xeon E5-2690V4 2.6 14 Core, 128GB DDR4 2133, 3 GTX 1080, (2x) 950 PRO NVMe M.2 SSD, Raid0 (5x256) SSD storage, CentOS 6.8

Return to Post Production

Who is online

Users browsing this forum: No registered users and 10 guests