GTX 480 - Your GPU Memory is full

Do you have questions about Desktop Video, Converters, Routers and Monitoring?
  • Author
  • Message
Offline

MikeHo

  • Posts: 7
  • Joined: Tue Nov 13, 2012 10:52 pm

GTX 480 - Your GPU Memory is full

PostTue Nov 13, 2012 11:12 pm

I am having a problem with Resolve 9 Lite - I keep getting the error message "Your GPU Memory is full - Try reducing the timeline resolution or the number of correctors".

My system configuration is a OSX 10.6.8, MacPro 3,1, 20 GB Ram, Nvidia GTX480 in Slot 1 running as both GUI and GPU. I am using the Nvidia Quadro 4000 driver and CUDA driver 5.0.36. I also have a Black Magic Intensity Pro in Slot 3 and CalDigit FASTA-6GU3 6G in slot 4. I'm running the BM Desktop video 9.5.3.

It first occurred with a project which had previously worked fine (that project was corrected using version 9.0, Cuda driver 5.0.17 and a Geforce 8800) - but I made some changes to my system adding a GTX 480 to replace a GeForce8800 (ironically to improve DaVinci performance!)

At first the project was OK on loading - it was only when I scrolled to the 80th (approx) shot in the color tab that I got the error message. The same thing occurred with rendering - it rendered up to about the 80th shot OK and then the remainder of the file was scrambled. When this problem occurred I upgraded to version 9.0.3 and cud a driver 5.0.36 to see if this would fix it. I have since tried uninstalling and reverting to version 9.0 and I have also tried Cuda drivers 5.0.17, 5.0.24 and 5.0.36.

Reading around various web forums I have the preferences set to: 8 bit video Depth, "Use optimised display mode during playback", and Bilinear filter to try to reduce the demands on the system.

I have also tried reducing the resolution and removing some nodes from corrections but this didn't seem to help either.

When I first installed Resolve (with a GeForce 8800 at the time) I got the same error - and I solved it by updating my CUDA drivers to 5.0.17.

The source file for the project in question is a single 15 minute Prores file, 1920x1080 which is conformed into 98 shots using "Scene Detection".

I thought this might be the problem (using a large single file) so as a test I created a new project with just a single short ProRes file imported. Even with a single node and only one short file as soon as I modify a parameter I get the "Your GPU Memory is full - Try reducing the timeline resolution or the number of correctors".

I know my system is not a supported configuration but as I had it working before with the Geforce 8800 would anyone have any suggestions how I might get it working again with the GTX 480?

Thanks in advance!
Offline
User avatar

Dwaine Maggart

Blackmagic Design

  • Posts: 5236
  • Joined: Wed Aug 22, 2012 2:53 pm

Re: GTX 480 - Your GPU Memory is full

PostTue Nov 13, 2012 11:36 pm

Did you have the 8800 card working in V9?

OSX 10.6.8 is not a supported V9 OS. While some people seem to be running V9 OK in 10.6.8, others have reported various odd problems. So your problem might be related to that.

Also, I didn't think you could really use a GTX480 card with 10.6.8? Is this an EFI BIOS modified card? Have you patched the AGPM kext?

Using the GTX480 card would probably work better (Resolve too!) if you could upgrade to OS X 10.7.5.
Dwaine Maggart
Blackmagic Design DaVinci Support
Offline

MikeHo

  • Posts: 7
  • Joined: Tue Nov 13, 2012 10:52 pm

Re: GTX 480 - Your GPU Memory is full

PostTue Nov 13, 2012 11:53 pm

Hi Dwaine,

Thanks for the swift reply.

I did have the 8800 working in v9 (but slowly ;)

The 480 is a EFI modified card from these guys: http://www.ebay.co.uk/sch/7systems/m.html
(I'm based in the UK).

I haven't patched the AGPM kext, how would I do that?

I will try the kext - and if it doesn't work bite the bullet, backup and upgrade.
I didn't want to because it was all working... until now ;)

Thanks for your help
(Great software BTW!)
Offline
User avatar

Dwaine Maggart

Blackmagic Design

  • Posts: 5236
  • Joined: Wed Aug 22, 2012 2:53 pm

Re: GTX 480 - Your GPU Memory is full

PostWed Nov 14, 2012 12:32 am

I am not expert at the changes you need to make to the AGPM kext to make the 480 work. You might try just deleting the AGPM kext entirely and see what happens. But I'm not totally sure that is a valid thing to do in 10.6.8, so definitely keep a copy of the kext, in case you need to put it back. Google could help you here, but be aware that a lot of the hits will be for Hackintosh scenarios.
Dwaine Maggart
Blackmagic Design DaVinci Support
Offline

MikeHo

  • Posts: 7
  • Joined: Tue Nov 13, 2012 10:52 pm

Re: GTX 480 - Your GPU Memory is full

PostWed Nov 14, 2012 12:39 am

I tried removing the kext but it didn't help. The instructions for patching it seemed to be saying you only needed to do it on 4,1 and 5,1 MacPro's and I'm still soldiering on with my 3,1...

I'm going to upgrade to 10.7.4 - fingers crossed.

I'll report back once I've done it.

Thanks Dwaine
Offline
User avatar

Dwaine Maggart

Blackmagic Design

  • Posts: 5236
  • Joined: Wed Aug 22, 2012 2:53 pm

Re: GTX 480 - Your GPU Memory is full

PostWed Nov 14, 2012 12:56 am

Why not 10.7.5? Whichever version, make sure you get the matching NVIDIA GPU driver from the NVIDIA driver download site and install that. There is a different version for 10.7.4 and 10.7.5.
Dwaine Maggart
Blackmagic Design DaVinci Support
Offline

MikeHo

  • Posts: 7
  • Joined: Tue Nov 13, 2012 10:52 pm

Re: GTX 480 - Your GPU Memory is full

PostFri Nov 23, 2012 2:39 am

Hi Dwaine,

So I upgraded to 10.7.4
Now when I launch Resolve I get two error messages:

"Unable to connect to QTDecoder"

then

"No OpenCL Acceleration Hardware Detected"

I have uninstalled and reinstalled Resolve (9.0.3)

My GPU driver version is 270.00.00f06
I have tried CUDA 5.0.36 and also rolled back to 5.0.17

I'm currently updating to 10.7.5.

Any ideas?

Thanks in advance
Mike
Offline

Peter Chamberlain

Blackmagic Design

  • Posts: 6143
  • Joined: Wed Aug 22, 2012 7:08 am

Re: GTX 480 - Your GPU Memory is full

PostFri Nov 23, 2012 5:08 am

Hi, are you logged into the Mac with the same user name as you had when you installed Resolve, and have Admin permissions?
Peter
DaVinci Resolve Product Manager
Offline

MikeHo

  • Posts: 7
  • Joined: Tue Nov 13, 2012 10:52 pm

Re: GTX 480 - Your GPU Memory is full

PostFri Nov 23, 2012 4:24 pm

Hi Peter,

Yes I am logged in as administrator.
I have now upgraded to 10.7.5
I have updated my GPU driver to 295.00.05f02 and the CUDA driver to 5.0.36

I have uninstalled and reinstalled Resolve again with this configuration.

Now I still get the message:

"Unable to connect to QTDecoder"

But I do not get the message:

"No OpenCL Acceleration Hardware Detected"

Resolve will open but I do not see any image for a ProRes QT in the media pool (I assume because of the QTDecoder issue) - it exists as a clip on the timeline and conform tab but is just black.

Nevertheless, if I try to make an adjustment on the blank clip in the correction tab - Even with a single node and no correction applied as soon as I modify a parameter I get the "Your GPU Memory is full - Try reducing the timeline resolution or the number of correctors".
Offline

Radman

  • Posts: 518
  • Joined: Thu Nov 01, 2012 5:26 pm

Re: GTX 480 - Your GPU Memory is full

PostFri Nov 23, 2012 6:41 pm

Seems to be getting complicated. Change of direction maybe.
Can you borrow a Quadro 4000 and see what that does.
Also check your network. Maybe you have a block somewhere.
Are you on a wireless network by any chance? Just a long shot!
Cheers
Radman.
Offline

MikeHo

  • Posts: 7
  • Joined: Tue Nov 13, 2012 10:52 pm

Re: GTX 480 - Your GPU Memory is full

PostMon Nov 26, 2012 5:41 pm

Hi Radman,

Unfortunately I can't borrow a Quadro...
This computer is not usually connected to the internet at all.

I have actually done a completely fresh install of the machine 10.7.5.

Resolve appears to work OK now - but if I attempt to use any of the controls in the the blur/sharpen tab I still get the GPU memory is full error. Resolve must just not like my GTX 480 for some reason.

A bit annoying as I bought the card especially for Resolve - Oh well I guess I'll just have to live without blur...

Dwaine have you come across this before? I mean another example where only the blur modifiers were causing problems?

Thanks for all your help guys
Offline
User avatar

Dwaine Maggart

Blackmagic Design

  • Posts: 5236
  • Joined: Wed Aug 22, 2012 2:53 pm

Re: GTX 480 - Your GPU Memory is full

PostMon Nov 26, 2012 10:51 pm

Hi Mike,

Please send a CaptureLog .tgz file and your Mac System Profile .spx file to davincihelp (AT) blackmagicdesign (DOT) com. Details for obtaining those files below:

For the .spx file, click on the Apple icon in the upper left of the display and select "About This Mac". Then click on More Info and then System Report. In the System Information menus at the top of the display, select the File menu, then Save.

For the .tgz file, open a Finder window, and navigate to the /Library/Application Support/Blackmagic Design/DaVinci Resolve folder and double click CaptureLogs. That will place a .tgz file on your desktop.
Dwaine Maggart
Blackmagic Design DaVinci Support
Offline

MikeHo

  • Posts: 7
  • Joined: Tue Nov 13, 2012 10:52 pm

Re: GTX 480 - Your GPU Memory is full

PostMon Nov 26, 2012 11:11 pm

I have done that.

Thanks so much for your help

Return to Post Production

Who is online

Users browsing this forum: No registered users and 8 guests