Resolve 9 Beta render bug - flashing highlights / darks

Do you have questions about Desktop Video, Converters, Routers and Monitoring?
  • Author
  • Message
Offline

Nicolas Duchon

  • Posts: 27
  • Joined: Thu Aug 30, 2012 4:38 pm

Resolve 9 Beta render bug - flashing highlights / darks

PostThu Aug 30, 2012 5:38 pm

There seems to be a render bug occuring on some mac systems with OSX 10.7.x and non CUDA cards : extreme highlights and dark areas randomly "flashes" either to black or to a flat color. It happens on the GUI, on the video output and on the rendered files, but seemingly never twice on the same frames (if you pause, rewind / move the playhead then play again the flashing will occur on different frames). The scopes also reflect the bugged picture.

The bug looks like this :

Image

I saw some other peoples experiencing the same bug on creative cow forums. The only fix that worked for some of them seems to be rendering at a slower speed. Some got rid of the bug with 50% speed, while in my case even 1% speed still output bugged files (even if the number of bugged frames is far lower).

My system is :
Mid 2011 27" iMac
OSX 10.7.4
3.4 GHz Core i7
16 GB of ram
AMD Radeon HD 6970M w/ 2048 MB ram
Pegasus R6
Resolve 9 lite Beta 3
CUDA 5.0.17

Is this a known beta bug that will be ironed out of the final release ?
Offline

Peter Chamberlain

Blackmagic Design

  • Posts: 6474
  • Joined: Wed Aug 22, 2012 7:08 am

Re: Resolve 9 Beta render bug - flashing highlights / darks

PostFri Aug 31, 2012 2:24 am

Hi, the issue is GPU/driver and OS related so we can only recommend upgrading to Mountain Lion as we don't see the problem there.
Peter
DaVinci Resolve Product Manager
Offline

Nicolas Duchon

  • Posts: 27
  • Joined: Thu Aug 30, 2012 4:38 pm

Re: Resolve 9 Beta render bug - flashing highlights / darks

PostFri Aug 31, 2012 9:53 am

I'll be able to give a try at 10.8 today and this week end, but upgrading to 10.8 will probably be absolutely out of question for a lot of people who are currently running 10.7.4.
Offline

Nicolas Duchon

  • Posts: 27
  • Joined: Thu Aug 30, 2012 4:38 pm

Re: Resolve 9 Beta render bug - flashing highlights / darks

PostFri Aug 31, 2012 6:31 pm

OSX 10.8.1 has indeed wiped out the bug and Resolve 9 beta 3 is now performing flawlessly on my system.

I had fear about issues between CS6 and OSX 10.8 but everything is working nice so far (even the legacy FCS3 I'm keeping installed).

I did a clean install, for those who have the same bug and would like to try the upgrade from 10.7 to 10.8, do not attempt an overwrite install. Something will almost certainly fail sooner or later.

For those who can't upgrade to 10.8 ... well I hope someone will find a fix :?
Offline

Winston Hoy

  • Posts: 8
  • Joined: Mon Oct 01, 2012 5:33 pm

Re: Resolve 9 Beta render bug - flashing highlights / darks

PostMon Oct 01, 2012 5:46 pm

I'm running a release version of Resolve and getting this problem. If it's not a Resolve bug, where do you suggest we write a bug report? What exactly does this OS bug affect? Specific codecs, frame rates?

Installing 10.8 is not on the top of my list of things to do..

My system is :
Mid 2011 27" iMac
OSX 10.7.5
3.4 GHz Core i7
32 GB of ram
AMD Radeon HD 6970M
Resolve Lite 9.0.1lite.010
Offline
User avatar

Dwaine Maggart

Blackmagic Design

  • Posts: 5402
  • Joined: Wed Aug 22, 2012 2:53 pm

Re: Resolve 9 Beta render bug - flashing highlights / darks

PostMon Oct 01, 2012 6:53 pm

It's a Lion OpenCL issue that affects Resolve use of AMD/ATI graphics cards used as Resolve GPU's.

The solution is to update to Mountain Lion. Lion 10.7.5 does not fix the issue.
Dwaine Maggart
Blackmagic Design DaVinci Support
Offline

CaptainHook

Blackmagic Design

  • Posts: 1487
  • Joined: Wed Aug 22, 2012 4:50 am
  • Location: Melbourne, Australia

Re: Resolve 9 Beta render bug - flashing highlights / darks

PostMon Oct 01, 2012 9:05 pm

Off-topic - is that Jeezo from the interview with Fabrice? That was a good watch by the way. :)
http://www.captainhook.co.nz/blackmagic-cinema-camera-lut/

**Any post by me prior to Aug 2014 was before i started working for Blackmagic**
Offline

Manny Edwards

  • Posts: 68
  • Joined: Sat Sep 08, 2012 5:41 pm

Re: Resolve 9 Beta render bug - flashing highlights / darks

PostWed Oct 03, 2012 1:08 pm

I upgraded to 10.8 a couple of days ago. Not only did the bug go away, but my renders are at least 3x as fast, and I'm getting real-time output to the monitor.
Resolve 9 Lite
Mac OS 10.8.2
ATI Radeon HD 5770 1024 MB
Offline

Caryl Deyn

  • Posts: 37
  • Joined: Thu Oct 04, 2012 5:25 am
  • Location: Los Angeles - California

Re: Resolve 9 Beta render bug - flashing highlights / darks

PostThu Oct 04, 2012 5:37 am

1
Last edited by Caryl Deyn on Tue Sep 23, 2014 11:50 pm, edited 1 time in total.
Offline

Rohit Gupta

Blackmagic Design

  • Posts: 1149
  • Joined: Wed Aug 22, 2012 5:00 am

Re: Resolve 9 Beta render bug - flashing highlights / darks

PostThu Oct 04, 2012 6:52 am

Colorist_Cdk wrote:This is really outrageous.

I have the problem now that I upgraded to 9.0.1.
And I see here the BlackMagic people asking people to upgrade to Mountain Lion as a solution to the issue.
Guys common. It is clear in the requirements of the 9.0 version that it says it supports Lion. So if you produce a version that it's suppose to support Lion. Then make it work and support the actual OS you are saying it supports.

Don't go around and say in a fifth line of a forum that it actually doesn't supports that OS and that you need to change your OS.

Please guys, that's misleading and not been honest about your product in so many ways.


If you are using CUDA cards, you can continue to use OS X Lion. Unfortunately, the latest 10.7.5 update still has this OpenCL issue, and there is nothing we can do to work around this 3rd party issue.
Rohit Gupta

DaVinci Resolve Software Development
Blackmagic Design
Offline

Caryl Deyn

  • Posts: 37
  • Joined: Thu Oct 04, 2012 5:25 am
  • Location: Los Angeles - California

Re: Resolve 9 Beta render bug - flashing highlights / darks

PostThu Oct 04, 2012 11:22 am

Well I indeed will prefer to have an Nvidia card on my MAC.

One question I couldn't make the tracking to work. Is that because of the openCl issue too?
Offline

Caryl Deyn

  • Posts: 37
  • Joined: Thu Oct 04, 2012 5:25 am
  • Location: Los Angeles - California

Re: Resolve 9 Beta render bug - flashing highlights / darks

PostThu Oct 04, 2012 12:50 pm

I couldn't make the tracking tool to work either, is it the same problem with the open CL?
Offline
User avatar

Dwaine Maggart

Blackmagic Design

  • Posts: 5402
  • Joined: Wed Aug 22, 2012 2:53 pm

Re: Resolve 9 Beta render bug - flashing highlights / darks

PostThu Oct 04, 2012 3:51 pm

For tracking issues, check in Project Settings / Image Scaling / Input Sizing Preset. If you have the "Center crop with no resizing" preset selected, that will cause tracking issues. Assuming you are working with HD material on an HD timeline, these presets should have no effect on your image, so select any of the other presets, and the tracking should work properly.
Dwaine Maggart
Blackmagic Design DaVinci Support
Offline

Caryl Deyn

  • Posts: 37
  • Joined: Thu Oct 04, 2012 5:25 am
  • Location: Los Angeles - California

Re: Resolve 9 Beta render bug - flashing highlights / darks

PostThu Oct 18, 2012 6:28 pm

Does the new version 9.0.2 resolves this issues?
Offline
User avatar

Dwaine Maggart

Blackmagic Design

  • Posts: 5402
  • Joined: Wed Aug 22, 2012 2:53 pm

Re: Resolve 9 Beta render bug - flashing highlights / darks

PostThu Oct 18, 2012 7:19 pm

Which issues? The issue in the thread topic, or the tracking issue not related to the thread topic?

The tracking issue appears to be fixed.
Dwaine Maggart
Blackmagic Design DaVinci Support
Offline

Caryl Deyn

  • Posts: 37
  • Joined: Thu Oct 04, 2012 5:25 am
  • Location: Los Angeles - California

Re: Resolve 9 Beta render bug - flashing highlights / darks

PostThu Oct 18, 2012 10:07 pm

Good to know about the tracking issue fixed.

But was asking about the flashing highlights/darks.

I have a device that might not work on Mountain Lion, so I can't change to it yet.

Already tested the version 9, and besides the issue it rocks.
Offline
User avatar

Dwaine Maggart

Blackmagic Design

  • Posts: 5402
  • Joined: Wed Aug 22, 2012 2:53 pm

Re: Resolve 9 Beta render bug - flashing highlights / darks

PostThu Oct 18, 2012 10:09 pm

Only updating to Mountain Lion is going to fix the potential ATI/AMD card OpenCL issue.
Dwaine Maggart
Blackmagic Design DaVinci Support
Offline

Caryl Deyn

  • Posts: 37
  • Joined: Thu Oct 04, 2012 5:25 am
  • Location: Los Angeles - California

Re: Resolve 9 Beta render bug - flashing highlights / darks

PostThu Oct 18, 2012 10:15 pm

Thanks Dwaine.

Well I'll have to wait.

Do you know if through Windows 8. Resolve will be able to handle Thunderbolt drives, and the Ultrastudio 3D?
Offline
User avatar

Dwaine Maggart

Blackmagic Design

  • Posts: 5402
  • Joined: Wed Aug 22, 2012 2:53 pm

Re: Resolve 9 Beta render bug - flashing highlights / darks

PostThu Oct 18, 2012 10:29 pm

I do not know. But neither of those issues is really Resolve specific. If Windows presents a Thunderbolt connected hard drive as a valid Windows storage device, it will be available to Resolve. If BMD provides a Windows capable Thunderbolt driver for the UltraStudio 3D, and the PC has supported Thunderbolt I/O hardware, then the UltraStudio 3D should be available as a Video Capture Hardware selection in Resolve.
Dwaine Maggart
Blackmagic Design DaVinci Support
Offline

Caryl Deyn

  • Posts: 37
  • Joined: Thu Oct 04, 2012 5:25 am
  • Location: Los Angeles - California

Re: Resolve 9 Beta render bug - flashing highlights / darks

PostThu Oct 18, 2012 10:31 pm

Thanks again Dwaine you are awesome :)

Return to Post Production

Who is online

Users browsing this forum: Google [Bot] and 18 guests